summaryrefslogtreecommitdiffstats
path: root/php-cs-fixer.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-cs-fixer.spec')
-rw-r--r--php-cs-fixer.spec22
1 files changed, 20 insertions, 2 deletions
diff --git a/php-cs-fixer.spec b/php-cs-fixer.spec
index b4850a6..5a08473 100644
--- a/php-cs-fixer.spec
+++ b/php-cs-fixer.spec
@@ -10,7 +10,7 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit 5fed214993e7863cef88a08f214344891299b9e4
+%global gh_commit d5b8a9d852b292c2f8a035200fa6844b1f82300b
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20150717
%global gh_owner FriendsOfPHP
@@ -26,7 +26,7 @@
%global gh_diff_short %(c=%{gh_diff_commit}; echo ${c:0:7})
Name: php-cs-fixer
-Version: 2.18.6
+Version: 2.19.0
Release: 1%{?gh_date:.%{gh_date}git%{gh_short}}%{?dist}
Summary: A tool to automatically fix PHP code style
@@ -298,10 +298,25 @@ cat << 'EOF' | tee vendor/autoload.php
'%{php_home}/PHPUnitGoodPractices/Polyfill/autoload.php',
'%{buildroot}%{php_home}/PhpCsFixer/autoload.php',
'%{php_home}/Symfony3/Component/Yaml/autoload.php',
+ __DIR__ . '/ExpectDeprecationTrait.php',
]);
\Fedora\Autoloader\Autoload::addPsr4('PhpCsFixer\\Tests\\', dirname(__DIR__) . '/tests');
EOF
+cat << 'EOF' | tee vendor/ExpectDeprecationTrait.php
+<?php
+
+namespace Symfony\Bridge\PhpUnit;
+
+trait ExpectDeprecationTrait /* Fake trait which skip test relying on it */
+{
+ public function expectDeprecation(): void
+ {
+ $this->markTestSkipped("no Symfony v5");
+ }
+}
+EOF
+
# test using keradus/cli-executor
rm tests/Smoke/CiIntegrationTest.php
rm tests/Smoke/StdinTest.php
@@ -349,6 +364,9 @@ exit $ret
%changelog
+* Tue May 4 2021 Remi Collet <remi@remirepo.net> - 2.19.0-1
+- update to 2.19.0
+
* Tue Apr 20 2021 Remi Collet <remi@remirepo.net> - 2.18.6-1
- update to 2.18.6
- switch to composer/xdebug-handler version 2