summaryrefslogtreecommitdiffstats
path: root/php-cs-fixer.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-cs-fixer.spec')
-rw-r--r--php-cs-fixer.spec17
1 files changed, 10 insertions, 7 deletions
diff --git a/php-cs-fixer.spec b/php-cs-fixer.spec
index f989ca6..dad07d0 100644
--- a/php-cs-fixer.spec
+++ b/php-cs-fixer.spec
@@ -10,7 +10,7 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit a53f39a72cf0baa03909fae779a4de6d3772c74f
+%global gh_commit beef6cbe6dec7205edcd143842a49f9a691859a6
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20150717
%global gh_owner FriendsOfPHP
@@ -26,8 +26,8 @@
%global gh_diff_short %(c=%{gh_diff_commit}; echo ${c:0:7})
Name: php-cs-fixer
-Version: 2.12.0
-Release: 2%{?gh_date:.%{gh_date}git%{gh_short}}%{?dist}
+Version: 2.12.1
+Release: 1%{?gh_date:.%{gh_date}git%{gh_short}}%{?dist}
Summary: A tool to automatically fix PHP code style
License: MIT
@@ -88,10 +88,10 @@ BuildRequires: php-symfony3-debug
# "mikey179/vfsStream": "^1.6",
# "php-coveralls/php-coveralls": "^2.1",
# "php-cs-fixer/accessible-object": "^1.0",
-# "php-cs-fixer/phpunit-constraint-isidenticalstring": "^1.0",
-# "php-cs-fixer/phpunit-constraint-xmlmatchesxsd": "^1.0",
+# "php-cs-fixer/phpunit-constraint-isidenticalstring": "^1.0.1",
+# "php-cs-fixer/phpunit-constraint-xmlmatchesxsd": "^1.0.1",
# "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1",
-# "phpunitgoodpractices/traits": "^1.4",
+# "phpunitgoodpractices/traits": "^1.5",
# "symfony/phpunit-bridge": "^4.0"
# ignored as test using it fail strangely
#BuildRequires: php-composer(keradus/cli-executor) < 2
@@ -307,7 +307,7 @@ rm tests/Smoke/InstallViaComposerTest.php
rm tests/Fixtures/Integration/priority/combine_consecutive_issets,no_singleline_whitespace_before_semicolons.test
# Disable listener
-sed -e 's/listeners/nolistener/' phpunit.xml.dist >phpunit.xml
+sed -e '/<listeners>/,/<\/listeners>/d' phpunit.xml.dist >phpunit.xml
# Redirect to buildroot
sed -e 's:%{php_home}:%{buildroot}%{php_home}:' -i %{name}
@@ -335,6 +335,9 @@ exit $ret
%changelog
+* Mon Jun 11 2018 Remi Collet <remi@remirepo.net> - 2.12.1-1
+- update to 2.12.1
+
* Tue Jun 5 2018 Remi Collet <remi@remirepo.net> - 2.12.0-2
- add weak dependency on php-cs-fixer/phpunit-constraint-isidenticalstring
- add weak dependency on php-cs-fixer/phpunit-constraint-xmlmatchesxsd