summaryrefslogtreecommitdiffstats
path: root/php-cs-fixer.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-cs-fixer.spec')
-rw-r--r--php-cs-fixer.spec16
1 files changed, 12 insertions, 4 deletions
diff --git a/php-cs-fixer.spec b/php-cs-fixer.spec
index 0c8f274..8512c96 100644
--- a/php-cs-fixer.spec
+++ b/php-cs-fixer.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 12f95d20d7c8f6c2ee68d00a0fad74179ca75339
+%global gh_commit 44f73c3e881805da5957ebd16ea87da9270cd5f3
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20150717
%global gh_owner FriendsOfPHP
@@ -15,7 +15,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-cs-fixer
-Version: 2.2.17
+Version: 2.2.18
Release: 1%{?gh_date:.%{gh_date}git%{gh_short}}%{?dist}
Summary: A tool to automatically fix PHP code style
@@ -64,7 +64,7 @@ BuildRequires: php-spl
BuildRequires: php-xml
# From composer.json, "require-dev": {
# NOTICE: listener disabled
-# "johnkary/phpunit-speedtrap": "^1.0.1",
+# "johnkary/phpunit-speedtrap": "^1.0.1 || ^2.0 || ^3.0",
# "justinrainbow/json-schema": "^5.0",
# "keradus/cli-executor": "^1.0",
# "mikey179/vfsStream": "^1.6",
@@ -234,9 +234,14 @@ sed -e 's/listeners/nolistener/' phpunit.xml.dist >phpunit.xml
sed -e 's:%{php_home}:%{buildroot}%{php_home}:' -i %{name}
# see https://github.com/FriendsOfPHP/PHP-CS-Fixer/blob/master/.travis.yml
-if php -r 'exit (version_compare(PHP_VERSION, "5.6", "<") ? 0 : 1);'; then
+VERID=$(php -r 'echo PHP_VERSION_ID;')
+if [ $VERID -lt 50600 ]; then
export SKIP_LINT_TEST_CASES=1
fi
+if [ $VERID -lt 50500 ]; then
+ rm tests/Fixer/Phpdoc/PhpdocAnnotationWithoutDotFixerTest.php
+ rm tests/AutoReview/ProjectCodeTest.php
+fi
%{_bindir}/phpunit -d memory_limit=2G --verbose
%else
@@ -254,6 +259,9 @@ fi
%changelog
+* Thu Mar 8 2018 Remi Collet <remi@remirepo.net> - 2.2.18-1
+- update to 2.2.18
+
* Fri Feb 23 2018 Remi Collet <remi@remirepo.net> - 2.2.17-1
- Update to 2.2.17
- drop dependency on gecko-packages/gecko-php-unit