summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json7
-rw-r--r--php-cs-fixer.spec11
2 files changed, 8 insertions, 10 deletions
diff --git a/composer.json b/composer.json
index 84661d3..8068d48 100644
--- a/composer.json
+++ b/composer.json
@@ -42,7 +42,7 @@
"php-cs-fixer/phpunit-constraint-xmlmatchesxsd": "^1.1",
"phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1",
"phpunitgoodpractices/traits": "^1.8",
- "symfony/phpunit-bridge": "^4.0"
+ "symfony/phpunit-bridge": "^4.3"
},
"suggest": {
"ext-mbstring": "For handling non-UTF8 characters in cache signature.",
@@ -53,11 +53,6 @@
"config": {
"sort-packages": true
},
- "extra": {
- "branch-alias": {
- "dev-master": "2.15-dev"
- }
- },
"autoload": {
"psr-4": {
"PhpCsFixer\\": "src/"
diff --git a/php-cs-fixer.spec b/php-cs-fixer.spec
index 49daa0a..56c1234 100644
--- a/php-cs-fixer.spec
+++ b/php-cs-fixer.spec
@@ -10,7 +10,7 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit adfab51ae979ee8b0fcbc55aa231ec2786cb1f91
+%global gh_commit 20064511ab796593a3990669eff5f5b535001f7c
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20150717
%global gh_owner FriendsOfPHP
@@ -26,7 +26,7 @@
%global gh_diff_short %(c=%{gh_diff_commit}; echo ${c:0:7})
Name: php-cs-fixer
-Version: 2.15.0
+Version: 2.15.1
Release: 1%{?gh_date:.%{gh_date}git%{gh_short}}%{?dist}
Summary: A tool to automatically fix PHP code style
@@ -94,7 +94,7 @@ BuildRequires: php-symfony3-debug
# "php-cs-fixer/phpunit-constraint-xmlmatchesxsd": "^1.1",
# "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1",
# "phpunitgoodpractices/traits": "^1.8",
-# "symfony/phpunit-bridge": "^4.0"
+# "symfony/phpunit-bridge": "^4.3"
# ignored as test using it fail strangely
#BuildRequires: php-composer(keradus/cli-executor) < 2
#BuildRequires: php-composer(keradus/cli-executor) >= 1.0
@@ -316,7 +316,7 @@ sed -e '/<listeners>/,/<\/listeners>/d' phpunit.xml.dist >phpunit.xml
sed -e 's:%{php_home}:%{buildroot}%{php_home}:' -i %{name}
ret=0
-for cmdarg in "php %{phpunit}" php71 php72 php73; do
+for cmdarg in "php %{phpunit}" php71 php72 php73 php74; do
if which $cmdarg; then
set $cmdarg
$1 -d memory_limit=2G ${2:-%{_bindir}/phpunit7} \
@@ -340,6 +340,9 @@ exit $ret
%changelog
+* Tue Jun 4 2019 Remi Collet <remi@remirepo.net> - 2.15.1-1
+- update to 2.15.1
+
* Mon May 6 2019 Remi Collet <remi@remirepo.net> - 2.15.0-1
- update to 2.15.0
- add patch for libpcre2 10.33 from