summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--php-cs-fixer.spec7
1 files changed, 3 insertions, 4 deletions
diff --git a/php-cs-fixer.spec b/php-cs-fixer.spec
index 0fb4807..13234ae 100644
--- a/php-cs-fixer.spec
+++ b/php-cs-fixer.spec
@@ -314,13 +314,12 @@ sed -e '/<listeners>/,/<\/listeners>/d' phpunit.xml.dist >phpunit.xml
sed -e 's:%{php_home}:%{buildroot}%{php_home}:' -i %{name}
ret=0
-# TODO 7.4 The (real) cast is deprecated, use (float) instead
-# TODO 7.4 Unbinding $this of closure is deprecated
-for cmdarg in "php %{phpunit}" php71 php72 php73; do
+# skip testFix74Deprecated as we don't use symfony/phpunit-bridge
+for cmdarg in "php %{phpunit}" php71 php72 php73 php74; do
if which $cmdarg; then
set $cmdarg
$1 -d memory_limit=2G ${2:-%{_bindir}/phpunit7} \
- --filter '^((?!(testFixerContainsAllPhpunitStaticMethodsInItsList)).)*$' \
+ --filter '^((?!(testFixerContainsAllPhpunitStaticMethodsInItsList|testFix74Deprecated)).)*$' \
|| ret=1
fi
done