summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json6
-rw-r--r--installed.json112
-rw-r--r--php-cs-fixer.spec23
3 files changed, 75 insertions, 66 deletions
diff --git a/composer.json b/composer.json
index 5b54d41..e3ea370 100644
--- a/composer.json
+++ b/composer.json
@@ -3,6 +3,12 @@
"description": "A tool to automatically fix PHP code style",
"license": "MIT",
"type": "application",
+ "keywords": [
+ "fixer",
+ "standards",
+ "static analysis",
+ "static code analysis"
+ ],
"authors": [
{
"name": "Fabien Potencier",
diff --git a/installed.json b/installed.json
index 014fb12..cf22126 100644
--- a/installed.json
+++ b/installed.json
@@ -713,17 +713,17 @@
},
{
"name": "symfony/console",
- "version": "v5.4.19",
- "version_normalized": "5.4.19.0",
+ "version": "v5.4.21",
+ "version_normalized": "5.4.21.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/console.git",
- "reference": "dccb8d251a9017d5994c988b034d3e18aaabf740"
+ "reference": "c77433ddc6cdc689caf48065d9ea22ca0853fbd9"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/console/zipball/dccb8d251a9017d5994c988b034d3e18aaabf740",
- "reference": "dccb8d251a9017d5994c988b034d3e18aaabf740",
+ "url": "https://api.github.com/repos/symfony/console/zipball/c77433ddc6cdc689caf48065d9ea22ca0853fbd9",
+ "reference": "c77433ddc6cdc689caf48065d9ea22ca0853fbd9",
"shasum": ""
},
"require": {
@@ -761,7 +761,7 @@
"symfony/lock": "",
"symfony/process": ""
},
- "time": "2023-01-01T08:32:19+00:00",
+ "time": "2023-02-25T16:59:41+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -795,7 +795,7 @@
"terminal"
],
"support": {
- "source": "https://github.com/symfony/console/tree/v5.4.19"
+ "source": "https://github.com/symfony/console/tree/v5.4.21"
},
"funding": [
{
@@ -885,17 +885,17 @@
},
{
"name": "symfony/event-dispatcher",
- "version": "v5.4.19",
- "version_normalized": "5.4.19.0",
+ "version": "v5.4.21",
+ "version_normalized": "5.4.21.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/event-dispatcher.git",
- "reference": "abf49cc084c087d94b4cb939c3f3672971784e0c"
+ "reference": "f0ae1383a8285dfc6752b8d8602790953118ff5a"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/event-dispatcher/zipball/abf49cc084c087d94b4cb939c3f3672971784e0c",
- "reference": "abf49cc084c087d94b4cb939c3f3672971784e0c",
+ "url": "https://api.github.com/repos/symfony/event-dispatcher/zipball/f0ae1383a8285dfc6752b8d8602790953118ff5a",
+ "reference": "f0ae1383a8285dfc6752b8d8602790953118ff5a",
"shasum": ""
},
"require": {
@@ -925,7 +925,7 @@
"symfony/dependency-injection": "",
"symfony/http-kernel": ""
},
- "time": "2023-01-01T08:32:19+00:00",
+ "time": "2023-02-14T08:03:56+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -953,7 +953,7 @@
"description": "Provides tools that allow your application components to communicate with each other by dispatching events and listening to them",
"homepage": "https://symfony.com",
"support": {
- "source": "https://github.com/symfony/event-dispatcher/tree/v5.4.19"
+ "source": "https://github.com/symfony/event-dispatcher/tree/v5.4.21"
},
"funding": [
{
@@ -1055,17 +1055,17 @@
},
{
"name": "symfony/filesystem",
- "version": "v5.4.19",
- "version_normalized": "5.4.19.0",
+ "version": "v5.4.21",
+ "version_normalized": "5.4.21.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/filesystem.git",
- "reference": "648bfaca6a494f3e22378123bcee2894045dc9d8"
+ "reference": "e75960b1bbfd2b8c9e483e0d74811d555ca3de9f"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/filesystem/zipball/648bfaca6a494f3e22378123bcee2894045dc9d8",
- "reference": "648bfaca6a494f3e22378123bcee2894045dc9d8",
+ "url": "https://api.github.com/repos/symfony/filesystem/zipball/e75960b1bbfd2b8c9e483e0d74811d555ca3de9f",
+ "reference": "e75960b1bbfd2b8c9e483e0d74811d555ca3de9f",
"shasum": ""
},
"require": {
@@ -1074,7 +1074,7 @@
"symfony/polyfill-mbstring": "~1.8",
"symfony/polyfill-php80": "^1.16"
},
- "time": "2023-01-14T19:14:44+00:00",
+ "time": "2023-02-14T08:03:56+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -1102,7 +1102,7 @@
"description": "Provides basic utilities for the filesystem",
"homepage": "https://symfony.com",
"support": {
- "source": "https://github.com/symfony/filesystem/tree/v5.4.19"
+ "source": "https://github.com/symfony/filesystem/tree/v5.4.21"
},
"funding": [
{
@@ -1122,17 +1122,17 @@
},
{
"name": "symfony/finder",
- "version": "v5.4.19",
- "version_normalized": "5.4.19.0",
+ "version": "v5.4.21",
+ "version_normalized": "5.4.21.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/finder.git",
- "reference": "6071aebf810ad13fe8200c224f36103abb37cf1f"
+ "reference": "078e9a5e1871fcfe6a5ce421b539344c21afef19"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/finder/zipball/6071aebf810ad13fe8200c224f36103abb37cf1f",
- "reference": "6071aebf810ad13fe8200c224f36103abb37cf1f",
+ "url": "https://api.github.com/repos/symfony/finder/zipball/078e9a5e1871fcfe6a5ce421b539344c21afef19",
+ "reference": "078e9a5e1871fcfe6a5ce421b539344c21afef19",
"shasum": ""
},
"require": {
@@ -1140,7 +1140,7 @@
"symfony/deprecation-contracts": "^2.1|^3",
"symfony/polyfill-php80": "^1.16"
},
- "time": "2023-01-14T19:14:44+00:00",
+ "time": "2023-02-16T09:33:00+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -1168,7 +1168,7 @@
"description": "Finds files and directories via an intuitive fluent interface",
"homepage": "https://symfony.com",
"support": {
- "source": "https://github.com/symfony/finder/tree/v5.4.19"
+ "source": "https://github.com/symfony/finder/tree/v5.4.21"
},
"funding": [
{
@@ -1188,17 +1188,17 @@
},
{
"name": "symfony/options-resolver",
- "version": "v5.4.19",
- "version_normalized": "5.4.19.0",
+ "version": "v5.4.21",
+ "version_normalized": "5.4.21.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/options-resolver.git",
- "reference": "b03c99236445492f20c61666e8f7e5d388b078e5"
+ "reference": "4fe5cf6ede71096839f0e4b4444d65dd3a7c1eb9"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/options-resolver/zipball/b03c99236445492f20c61666e8f7e5d388b078e5",
- "reference": "b03c99236445492f20c61666e8f7e5d388b078e5",
+ "url": "https://api.github.com/repos/symfony/options-resolver/zipball/4fe5cf6ede71096839f0e4b4444d65dd3a7c1eb9",
+ "reference": "4fe5cf6ede71096839f0e4b4444d65dd3a7c1eb9",
"shasum": ""
},
"require": {
@@ -1207,7 +1207,7 @@
"symfony/polyfill-php73": "~1.0",
"symfony/polyfill-php80": "^1.16"
},
- "time": "2023-01-01T08:32:19+00:00",
+ "time": "2023-02-14T08:03:56+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -1240,7 +1240,7 @@
"options"
],
"support": {
- "source": "https://github.com/symfony/options-resolver/tree/v5.4.19"
+ "source": "https://github.com/symfony/options-resolver/tree/v5.4.21"
},
"funding": [
{
@@ -1852,24 +1852,24 @@
},
{
"name": "symfony/process",
- "version": "v5.4.19",
- "version_normalized": "5.4.19.0",
+ "version": "v5.4.21",
+ "version_normalized": "5.4.21.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/process.git",
- "reference": "c5ba874c9b636dbccf761e22ce750e88ec3f55e1"
+ "reference": "d4ce417ebcb0b7d090b4c178ed6d3accc518e8bd"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/process/zipball/c5ba874c9b636dbccf761e22ce750e88ec3f55e1",
- "reference": "c5ba874c9b636dbccf761e22ce750e88ec3f55e1",
+ "url": "https://api.github.com/repos/symfony/process/zipball/d4ce417ebcb0b7d090b4c178ed6d3accc518e8bd",
+ "reference": "d4ce417ebcb0b7d090b4c178ed6d3accc518e8bd",
"shasum": ""
},
"require": {
"php": ">=7.2.5",
"symfony/polyfill-php80": "^1.16"
},
- "time": "2023-01-01T08:32:19+00:00",
+ "time": "2023-02-21T19:46:44+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -1897,7 +1897,7 @@
"description": "Executes commands in sub-processes",
"homepage": "https://symfony.com",
"support": {
- "source": "https://github.com/symfony/process/tree/v5.4.19"
+ "source": "https://github.com/symfony/process/tree/v5.4.21"
},
"funding": [
{
@@ -2003,24 +2003,24 @@
},
{
"name": "symfony/stopwatch",
- "version": "v5.4.19",
- "version_normalized": "5.4.19.0",
+ "version": "v5.4.21",
+ "version_normalized": "5.4.21.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/stopwatch.git",
- "reference": "bd2b066090fd6a67039371098fa25a84cb2679ec"
+ "reference": "f83692cd869a6f2391691d40a01e8acb89e76fee"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/stopwatch/zipball/bd2b066090fd6a67039371098fa25a84cb2679ec",
- "reference": "bd2b066090fd6a67039371098fa25a84cb2679ec",
+ "url": "https://api.github.com/repos/symfony/stopwatch/zipball/f83692cd869a6f2391691d40a01e8acb89e76fee",
+ "reference": "f83692cd869a6f2391691d40a01e8acb89e76fee",
"shasum": ""
},
"require": {
"php": ">=7.2.5",
"symfony/service-contracts": "^1|^2|^3"
},
- "time": "2023-01-01T08:32:19+00:00",
+ "time": "2023-02-14T08:03:56+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -2048,7 +2048,7 @@
"description": "Provides a way to profile code",
"homepage": "https://symfony.com",
"support": {
- "source": "https://github.com/symfony/stopwatch/tree/v5.4.19"
+ "source": "https://github.com/symfony/stopwatch/tree/v5.4.21"
},
"funding": [
{
@@ -2068,17 +2068,17 @@
},
{
"name": "symfony/string",
- "version": "v5.4.19",
- "version_normalized": "5.4.19.0",
+ "version": "v5.4.21",
+ "version_normalized": "5.4.21.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/string.git",
- "reference": "0a01071610fd861cc160dfb7e2682ceec66064cb"
+ "reference": "edac10d167b78b1d90f46a80320d632de0bd9f2f"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/string/zipball/0a01071610fd861cc160dfb7e2682ceec66064cb",
- "reference": "0a01071610fd861cc160dfb7e2682ceec66064cb",
+ "url": "https://api.github.com/repos/symfony/string/zipball/edac10d167b78b1d90f46a80320d632de0bd9f2f",
+ "reference": "edac10d167b78b1d90f46a80320d632de0bd9f2f",
"shasum": ""
},
"require": {
@@ -2098,7 +2098,7 @@
"symfony/translation-contracts": "^1.1|^2",
"symfony/var-exporter": "^4.4|^5.0|^6.0"
},
- "time": "2023-01-01T08:32:19+00:00",
+ "time": "2023-02-22T08:00:55+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -2137,7 +2137,7 @@
"utf8"
],
"support": {
- "source": "https://github.com/symfony/string/tree/v5.4.19"
+ "source": "https://github.com/symfony/string/tree/v5.4.21"
},
"funding": [
{
diff --git a/php-cs-fixer.spec b/php-cs-fixer.spec
index dbc490c..3c7f528 100644
--- a/php-cs-fixer.spec
+++ b/php-cs-fixer.spec
@@ -10,14 +10,14 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit 1b3d9dba63d93b8a202c31e824748218781eae6b
+%global gh_commit fb929675a201b7fc79a516226033e36538d5308d
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20150717
%global gh_owner FriendsOfPHP
%global gh_project PHP-CS-Fixer
Name: php-cs-fixer
-Version: 3.14.4
+Version: 3.14.5
Release: 1%{?gh_date:.%{gh_date}git%{gh_short}}%{?dist}
Summary: PHP Coding Standards Fixer
@@ -63,13 +63,13 @@ Provides: bundled(php-psr-cache) = 1.0.1
Provides: bundled(php-psr-container) = 1.1.2
Provides: bundled(php-psr-event-dispatcher) = 1.0.0
Provides: bundled(php-psr-log) = 1.1.4
-Provides: bundled(php-symfony-console) = v5.4.19
+Provides: bundled(php-symfony-console) = v5.4.21
Provides: bundled(php-symfony-deprecation-contracts) = v2.5.2
-Provides: bundled(php-symfony-event-dispatcher) = v5.4.19
+Provides: bundled(php-symfony-event-dispatcher) = v5.4.21
Provides: bundled(php-symfony-event-dispatcher-contracts) = v2.5.2
-Provides: bundled(php-symfony-filesystem) = v5.4.19
-Provides: bundled(php-symfony-finder) = v5.4.19
-Provides: bundled(php-symfony-options-resolver) = v5.4.19
+Provides: bundled(php-symfony-filesystem) = v5.4.21
+Provides: bundled(php-symfony-finder) = v5.4.21
+Provides: bundled(php-symfony-options-resolver) = v5.4.21
Provides: bundled(php-symfony-polyfill-ctype) = v1.27.0
Provides: bundled(php-symfony-polyfill-intl-grapheme) = v1.27.0
Provides: bundled(php-symfony-polyfill-intl-normalizer) = v1.27.0
@@ -77,10 +77,10 @@ Provides: bundled(php-symfony-polyfill-mbstring) = v1.27.0
Provides: bundled(php-symfony-polyfill-php73) = v1.27.0
Provides: bundled(php-symfony-polyfill-php80) = v1.27.0
Provides: bundled(php-symfony-polyfill-php81) = v1.27.0
-Provides: bundled(php-symfony-process) = v5.4.19
+Provides: bundled(php-symfony-process) = v5.4.21
Provides: bundled(php-symfony-service-contracts) = v2.5.2
-Provides: bundled(php-symfony-stopwatch) = v5.4.19
-Provides: bundled(php-symfony-string) = v5.4.19
+Provides: bundled(php-symfony-stopwatch) = v5.4.21
+Provides: bundled(php-symfony-string) = v5.4.21
Provides: php-composer(friendsofphp/php-cs-fixer) = %{version}
@@ -155,6 +155,9 @@ PHP_CS_FIXER_IGNORE_ENV=1 ./%{name} --version | grep %{version}
%changelog
+* Mon Mar 13 2023 Remi Collet <remi@remirepo.net> - 3.14.5-1
+- update to 3.14.5
+
* Fri Feb 10 2023 Remi Collet <remi@remirepo.net> - 3.14.4-1
- update to 3.14.4