summaryrefslogtreecommitdiffstats
path: root/php-cs-fixer.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-03-21 07:27:12 +0100
committerRemi Collet <remi@remirepo.net>2018-03-21 07:27:12 +0100
commitcf18add2b12532fc00b46ddea9b7c5323e5fd3f3 (patch)
tree2695445e3515bca07e7e034c2277c926e185a3c7 /php-cs-fixer.spec
parent0fb796e3720f22b92d811c0a55bac03de889984e (diff)
v2.11.0
Diffstat (limited to 'php-cs-fixer.spec')
-rw-r--r--php-cs-fixer.spec27
1 files changed, 19 insertions, 8 deletions
diff --git a/php-cs-fixer.spec b/php-cs-fixer.spec
index 8395588..7ffe838 100644
--- a/php-cs-fixer.spec
+++ b/php-cs-fixer.spec
@@ -10,7 +10,7 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit b2dce1dacff988b79c4aadf252e5dee31bc04e19
+%global gh_commit 2ac8defbe07599b79005cca764bfffe7aeac0bf2
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20150717
%global gh_owner FriendsOfPHP
@@ -26,7 +26,7 @@
%global gh_diff_short %(c=%{gh_diff_commit}; echo ${c:0:7})
Name: php-cs-fixer
-Version: 2.10.4
+Version: 2.11.0
Release: 1%{?gh_date:.%{gh_date}git%{gh_short}}%{?dist}
Summary: A tool to automatically fix PHP code style
@@ -46,7 +46,7 @@ BuildArch: noarch
BuildRequires: php(language) >= 5.6
BuildRequires: php-tokenizer
# remirepo:1
-%if 0%{?fedora} >= 27
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(composer/semver) >= 1.4 with php-composer(composer/semver) < 2)
BuildRequires: (php-composer(doctrine/annotations) >= 1.2 with php-composer(doctrine/annotations) < 2)
BuildRequires: (php-composer(symfony/polyfill-php70) >= 1.0 with php-composer(symfony/polyfill-php70) < 2)
@@ -86,19 +86,24 @@ BuildRequires: php-symfony3-debug
# "mikey179/vfsStream": "^1.6",
# "php-coveralls/php-coveralls": "^2.0",
# "php-cs-fixer/accessible-object": "^1.0",
-# "phpunit/phpunit": "^5.7.23 || ^6.4.3",
+# "phpunit/phpunit": "^5.7.23 || ^6.4.3 || ^7.0",
# "phpunitgoodpractices/traits": "^1.3.1",
# "symfony/phpunit-bridge": "^3.2.2 || ^4.0"
# ignored as test using it fail strangely
#BuildRequires: php-composer(keradus/cli-executor) < 2
#BuildRequires: php-composer(keradus/cli-executor) >= 1.0
# remirepo:1
-%if 0%{?fedora} >= 27
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(justinrainbow/json-schema) >= 5.0 with php-composer(justinrainbow/json-schema) < 6)
BuildRequires: (php-composer(mikey179/vfsStream) >= 1.6 with php-composer(mikey179/vfsStream) < 2)
BuildRequires: (php-composer(php-cs-fixer/accessible-object) >= 1.0 with php-composer(php-cs-fixer/accessible-object) < 2)
+%if 0%{?fedora} >= 28 || 0%{?rhel} >= 8
+%global phpunit %{_bindir}/phpunit7
+BuildRequires: phpunit7 >= 7.0
+%else
%global phpunit %{_bindir}/phpunit6
BuildRequires: phpunit6 >= 6.4.3
+%endif
# remirepo:7
%else
BuildRequires: php-justinrainbow-json-schema5
@@ -122,7 +127,7 @@ BuildRequires: php-fedora-autoloader-devel
# "composer/semver": "^1.4",
# "doctrine/annotations": "^1.2",
# Bundled
-# "php-cs-fixer/diff": "^1.2",
+# "php-cs-fixer/diff": "^1.3",
# "symfony/console": "^3.2 || ^4.0",
# "symfony/event-dispatcher": "^3.0 || ^4.0",
# "symfony/filesystem": "^3.0 || ^4.0",
@@ -137,7 +142,7 @@ Requires: php(language) >= 5.6
Requires: php-json
Requires: php-tokenizer
# remirepo:1
-%if 0%{?fedora} >= 27
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-composer(composer/semver) >= 1.4 with php-composer(composer/semver) < 2)
Requires: (php-composer(doctrine/annotations) >= 1.2 with php-composer(doctrine/annotations) < 2)
Requires: (php-composer(symfony/polyfill-php70) >= 1.0 with php-composer(symfony/polyfill-php70) < 2)
@@ -202,6 +207,8 @@ TESTS="
tests/Test/AbstractIntegrationTestCase.php
tests/Test/Assert/AssertTokensTrait.php
tests/Test/Constraint/SameStringsConstraint.php
+ tests/Test/Constraint/SameStringsConstraintForV5.php
+ tests/Test/Constraint/SameStringsConstraintForV7.php
tests/Test/IntegrationCase.php
tests/Test/IntegrationCaseFactory.php
tests/Test/IntegrationCaseFactoryInterface.php
@@ -286,7 +293,7 @@ sed -e 's/listeners/nolistener/' phpunit.xml.dist >phpunit.xml
sed -e 's:%{php_home}:%{buildroot}%{php_home}:' -i %{name}
ret=0
-for cmdarg in "php %{phpunit}" php70 php71 php72; do
+for cmdarg in "php %{phpunit}" php70 php71 "php72 %{_bindir}/phpunit7"; do
if which $cmdarg; then
set $cmdarg
$1 -d memory_limit=2G ${2:-%{_bindir}/phpunit6} || ret=1
@@ -308,6 +315,10 @@ exit $ret
%changelog
+* Wed Mar 21 2018 Remi Collet <remi@remirepo.net> - 2.11.0-1
+- update to 2.11.0
+- use phpunit7 on F28+
+
* Thu Mar 8 2018 Remi Collet <remi@remirepo.net> - 2.10.4-1
- update to 2.10.4