summaryrefslogtreecommitdiffstats
path: root/php-cs-fixer.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-04-14 14:00:32 +0200
committerRemi Collet <remi@remirepo.net>2020-04-14 14:00:32 +0200
commit43138304174227a4c1b1d35045d8e0b3f9ad8ebf (patch)
tree6c2e3fd51b3e863632c43fe97a088b79464daed3 /php-cs-fixer.spec
parentdfdd7c8fc3075a3ee7ce04be16f102a04ec77569 (diff)
update to 2.16.2
Diffstat (limited to 'php-cs-fixer.spec')
-rw-r--r--php-cs-fixer.spec22
1 files changed, 11 insertions, 11 deletions
diff --git a/php-cs-fixer.spec b/php-cs-fixer.spec
index defbfd6..87f105a 100644
--- a/php-cs-fixer.spec
+++ b/php-cs-fixer.spec
@@ -1,6 +1,6 @@
# remirepo/fedora spec file for php-cs-fixer
#
-# Copyright (c) 2016-2019 Remi Collet
+# Copyright (c) 2016-2020 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -10,7 +10,7 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit c8afb599858876e95e8ebfcd97812d383fa23f02
+%global gh_commit c460a3cbaa58f983fe026cd52c45950bf61e9239
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20150717
%global gh_owner FriendsOfPHP
@@ -26,7 +26,7 @@
%global gh_diff_short %(c=%{gh_diff_commit}; echo ${c:0:7})
Name: php-cs-fixer
-Version: 2.16.1
+Version: 2.16.2
Release: 1%{?gh_date:.%{gh_date}git%{gh_short}}%{?dist}
Summary: A tool to automatically fix PHP code style
@@ -98,20 +98,15 @@ BuildRequires: php-symfony3-debug
#BuildRequires: php-composer(keradus/cli-executor) < 2
#BuildRequires: php-composer(keradus/cli-executor) >= 1.0
# remirepo:1
-%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+%if 0%{?fedora} >= 28 || 0%{?rhel} >= 8
BuildRequires: (php-composer(justinrainbow/json-schema) >= 5.0 with php-composer(justinrainbow/json-schema) < 6)
BuildRequires: (php-composer(mikey179/vfsstream) >= 1.6 with php-composer(mikey179/vfsstream) < 2)
BuildRequires: (php-composer(php-cs-fixer/accessible-object) >= 1.0 with php-composer(php-cs-fixer/accessible-object) < 2)
BuildRequires: (php-composer(php-cs-fixer/phpunit-constraint-isidenticalstring) >= 1.1 with php-composer(php-cs-fixer/phpunit-constraint-isidenticalstring) < 2)
BuildRequires: (php-composer(php-cs-fixer/phpunit-constraint-xmlmatchesxsd) >= 1.1 with php-composer(php-cs-fixer/phpunit-constraint-xmlmatchesxsd) < 2)
BuildRequires: (php-composer(phpunitgoodpractices/traits) >= 1.8 with php-composer(phpunitgoodpractices/traits) < 2)
-%if 0%{?fedora} >= 28 || 0%{?rhel} >= 8
%global phpunit %{_bindir}/phpunit7
BuildRequires: phpunit7 >= 7.1
-%else
-%global phpunit %{_bindir}/phpunit6
-BuildRequires: phpunit6 >= 6.5.14
-%endif
# remirepo:10
%else
BuildRequires: php-justinrainbow-json-schema5
@@ -175,10 +170,12 @@ Requires: php-symfony3-stopwatch
# Missing dependency for Console
Requires: php-symfony3-debug
# From composer.json, "suggest": {
+# "ext-dom": "For handling output formats in XML",
# "ext-mbstring": "For handling non-UTF8 characters in cache signature.",
# "php-cs-fixer/phpunit-constraint-isidenticalstring": "For IsIdenticalString constraint.",
# "php-cs-fixer/phpunit-constraint-xmlmatchesxsd": "For XmlMatchesXsd constraint.",
# "symfony/polyfill-mbstring": "When enabling `ext-mbstring` is not possible."
+Requires: php-dom
Requires: php-mbstring
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
@@ -189,7 +186,6 @@ Recommends: php-composer(php-cs-fixer/phpunit-constraint-xmlmatchesxsd)
# From phpcompatinfo report for version 2.4.0
Requires: php-cli
Requires: php-reflection
-Requires: php-dom
Requires: php-pcre
Requires: php-phar
Requires: php-spl
@@ -228,6 +224,7 @@ TESTS="
tests/Test/IntegrationCaseFactory.php
tests/Test/IntegrationCaseFactoryInterface.php
tests/Test/InternalIntegrationCaseFactory.php
+ tests/Test/IsIdenticalConstraint.php
tests/TestCase.php
"
for i in $TESTS; do
@@ -319,7 +316,7 @@ for cmdarg in "php %{phpunit}" php71 php72 php73 php74; do
if which $cmdarg; then
set $cmdarg
$1 -d memory_limit=2G ${2:-%{_bindir}/phpunit7} \
- --filter '^((?!(testFixerContainsAllPhpunitStaticMethodsInItsList|testFix74Deprecated)).)*$' \
+ --filter '^((?!(testFixerContainsAllPhpunitStaticMethodsInItsList|testFix74Deprecated|testFixersPriorityPairsHaveIntegrationTest)).)*$' \
|| ret=1
fi
done
@@ -340,6 +337,9 @@ exit $ret
%changelog
+* Mon Apr 13 2020 Remi Collet <remi@remirepo.net> - 2.16.2-1
+- update to 2.16.2
+
* Tue Nov 26 2019 Remi Collet <remi@remirepo.net> - 2.16.1-1
- update to 2.16.1