summaryrefslogtreecommitdiffstats
path: root/php-cs-fixer.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-08-29 13:13:22 +0200
committerRemi Collet <remi@remirepo.net>2019-08-29 13:13:22 +0200
commit03cce0ab0af654dcd10b1f06cd371ac829850ca0 (patch)
tree0721a43ac80298ccc89cac0bc18eb8a74b205c4f /php-cs-fixer.spec
parent9dc752bc60f1d007b59ed0a2fa6328dcdb3e5513 (diff)
v2.15.2
Diffstat (limited to 'php-cs-fixer.spec')
-rw-r--r--php-cs-fixer.spec15
1 files changed, 9 insertions, 6 deletions
diff --git a/php-cs-fixer.spec b/php-cs-fixer.spec
index 56c1234..8020afc 100644
--- a/php-cs-fixer.spec
+++ b/php-cs-fixer.spec
@@ -10,7 +10,7 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit 20064511ab796593a3990669eff5f5b535001f7c
+%global gh_commit c9d30fddfa3feb8b82663104864224f2ce7a3675
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20150717
%global gh_owner FriendsOfPHP
@@ -26,7 +26,7 @@
%global gh_diff_short %(c=%{gh_diff_commit}; echo ${c:0:7})
Name: php-cs-fixer
-Version: 2.15.1
+Version: 2.15.2
Release: 1%{?gh_date:.%{gh_date}git%{gh_short}}%{?dist}
Summary: A tool to automatically fix PHP code style
@@ -39,8 +39,6 @@ Source2: makesrc.sh
# Use our autoloader
Patch0: %{name}-autoload.patch
-# Fix escape sequence is invalid in character class
-Patch1: https://github.com/FriendsOfPHP/PHP-CS-Fixer/pull/4406.patch
BuildArch: noarch
%if %{with_tests}
@@ -215,7 +213,6 @@ projects. This tool does not only detect them, but also fixes them for you.
%prep
%setup -q -n %{gh_project}-%{gh_commit} -a1
%patch0 -p1 -b .rpm
-%patch1 -p1
mv diff-%{gh_diff_commit}/src src/diff
find src -name \*rpm -delete -print
@@ -316,7 +313,9 @@ sed -e '/<listeners>/,/<\/listeners>/d' phpunit.xml.dist >phpunit.xml
sed -e 's:%{php_home}:%{buildroot}%{php_home}:' -i %{name}
ret=0
-for cmdarg in "php %{phpunit}" php71 php72 php73 php74; do
+# TODO 7.4 The (real) cast is deprecated, use (float) instead
+# TODO 7.4 Unbinding $this of closure is deprecated
+for cmdarg in "php %{phpunit}" php71 php72 php73; do
if which $cmdarg; then
set $cmdarg
$1 -d memory_limit=2G ${2:-%{_bindir}/phpunit7} \
@@ -331,6 +330,7 @@ exit $ret
%files
+# remirepo:1
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc composer.json
@@ -340,6 +340,9 @@ exit $ret
%changelog
+* Thu Aug 29 2019 Remi Collet <remi@remirepo.net> - 2.15.2-1
+- update to 2.15.2
+
* Tue Jun 4 2019 Remi Collet <remi@remirepo.net> - 2.15.1-1
- update to 2.15.1