summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-08-23 09:26:26 +0200
committerRemi Collet <remi@remirepo.net>2017-08-23 09:26:26 +0200
commitfb023defd000e02d2e41ccd1bc98196cf19ba013 (patch)
tree05ad90a72c67a6c726c92660e67118a477bf0bd8
parentdc4e9a97808a996584fbbadd760245c7c2720e17 (diff)
v2.2.6
-rw-r--r--php-cs-fixer.spec15
1 files changed, 13 insertions, 2 deletions
diff --git a/php-cs-fixer.spec b/php-cs-fixer.spec
index 6d1875d..4349238 100644
--- a/php-cs-fixer.spec
+++ b/php-cs-fixer.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 27c2cd9d4abd2178b5b585fa2c3cca656d377c69
+%global gh_commit c1cc52c242f17c4d52d9601159631da488fac7a4
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20150717
%global gh_owner FriendsOfPHP
@@ -15,7 +15,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-cs-fixer
-Version: 2.2.5
+Version: 2.2.6
Release: 1%{?gh_date:.%{gh_date}git%{gh_short}}%{?dist}
Summary: A tool to automatically fix PHP code style
@@ -176,6 +176,10 @@ for i in $TESTS; do
cp -p $i src/$i
done
+# fix dev-tools path
+sed -e 's:../../../dev-tools/::' -i src/Console/Command/HelpCommand.php
+cp -pr dev-tools/ci-integration.sh src/Console/Command/
+
phpab --template fedora --output src/autoload.php src/tests
cat << 'EOF' | tee -a src/autoload.php
@@ -224,10 +228,14 @@ EOF
# Ignore integration test
sed -e "/README.rst/s:__DIR__.*':'$PWD/README.rst':" \
-i tests/Console/Command/ReadmeCommandTest.php
+rm tests/CiIntegrationTest.php
# Disable listener
sed -e 's/listeners/nolistener/' phpunit.xml.dist >phpunit.xml
+# Redirect to buildroot
+sed -e 's:%{php_home}:%{buildroot}%{php_home}:' -i %{name}
+
# see https://github.com/FriendsOfPHP/PHP-CS-Fixer/blob/master/.travis.yml
if php -r 'exit (version_compare(PHP_VERSION, "5.6", "<") ? 0 : 1);'; then
export SKIP_LINT_TEST_CASES=1
@@ -249,6 +257,9 @@ fi
%changelog
+* Wed Aug 23 2017 Remi Collet <remi@remirepo.net> - 2.2.6-1
+- Update to 2.2.6
+
* Thu Aug 3 2017 Remi Collet <remi@remirepo.net> - 2.2.5-1
- add dependency on symfony/polyfill-php72
- Update to 2.2.5