summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-11-03 05:32:47 +0100
committerRemi Collet <remi@remirepo.net>2017-11-03 05:32:47 +0100
commit95dcdf6c4eb5ef165a9275b90d7f63df12de9431 (patch)
tree96185df866c8aa2e4ea28e43eb3dd9286d2ea256
parente4166574c622c48766eb5913e75addc7da3566ff (diff)
v2.2.9
-rw-r--r--composer.json18
-rw-r--r--php-cs-fixer.spec23
2 files changed, 22 insertions, 19 deletions
diff --git a/composer.json b/composer.json
index d2c3b9a..158dcf7 100644
--- a/composer.json
+++ b/composer.json
@@ -21,24 +21,24 @@
"doctrine/annotations": "^1.2",
"gecko-packages/gecko-php-unit": "^2.0",
"sebastian/diff": "^1.4",
- "symfony/console": "^2.4 || ^3.0",
- "symfony/event-dispatcher": "^2.1 || ^3.0",
- "symfony/filesystem": "^2.4 || ^3.0",
- "symfony/finder": "^2.2 || ^3.0",
- "symfony/options-resolver": "^2.6 || ^3.0",
+ "symfony/console": "^2.4 || ^3.0 || ^4.0",
+ "symfony/event-dispatcher": "^2.1 || ^3.0 || ^4.0",
+ "symfony/filesystem": "^2.4 || ^3.0 || ^4.0",
+ "symfony/finder": "^2.2 || ^3.0 || ^4.0",
+ "symfony/options-resolver": "^2.6 || ^3.0 || ^4.0",
"symfony/polyfill-php54": "^1.0",
"symfony/polyfill-php55": "^1.3",
"symfony/polyfill-php70": "^1.0",
"symfony/polyfill-php72": "^1.4",
- "symfony/process": "^2.3 || ^3.0",
- "symfony/stopwatch": "^2.5 || ^3.0"
+ "symfony/process": "^2.3 || ^3.0 || ^4.0",
+ "symfony/stopwatch": "^2.5 || ^3.0 || ^4.0"
},
"require-dev": {
"johnkary/phpunit-speedtrap": "^1.0.1",
"justinrainbow/json-schema": "^5.0",
+ "php-coveralls/php-coveralls": "^1.0.2",
"phpunit/phpunit": "^4.8.35 || ^5.4.3",
- "satooshi/php-coveralls": "^1.0",
- "symfony/phpunit-bridge": "^3.2.2"
+ "symfony/phpunit-bridge": "^3.2.2 || ^4.0"
},
"suggest": {
"ext-mbstring": "For handling non-UTF8 characters in cache signature.",
diff --git a/php-cs-fixer.spec b/php-cs-fixer.spec
index 27e9a77..50b8c72 100644
--- a/php-cs-fixer.spec
+++ b/php-cs-fixer.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit aca23e791784eade7b377d578d6dfc6fcf1398d2
+%global gh_commit eace538b022a2b7db59ef7b5460cb8c66cb20b50
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20150717
%global gh_owner FriendsOfPHP
@@ -15,7 +15,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-cs-fixer
-Version: 2.2.8
+Version: 2.2.9
Release: 1%{?gh_date:.%{gh_date}git%{gh_short}}%{?dist}
Summary: A tool to automatically fix PHP code style
@@ -75,9 +75,9 @@ BuildRequires: php-xml
# NOTICE: listener disabled
# "johnkary/phpunit-speedtrap": "^1.0.1",
# "justinrainbow/json-schema": "^5.0",
+# "satooshi/php-coveralls": "^1.0.2",
# "phpunit/phpunit": "^4.8.35 || ^5.4.3",
-# "satooshi/php-coveralls": "^1.0",
-# "symfony/phpunit-bridge": "^3.2"
+# "symfony/phpunit-bridge": "^3.2 || ^4.0"
BuildRequires: php-composer(justinrainbow/json-schema) < 6
BuildRequires: php-composer(justinrainbow/json-schema) >= 5
BuildRequires: php-composer(phpunit/phpunit) >= 4.8.35
@@ -95,16 +95,16 @@ BuildRequires: php-fedora-autoloader-devel
# "gecko-packages/gecko-php-unit": "^2.0",
# "sebastian/diff": "^1.4",
# "symfony/console": "^2.4 || ^3.0",
-# "symfony/event-dispatcher": "^2.1 || ^3.0",
-# "symfony/filesystem": "^2.4 || ^3.0",
-# "symfony/finder": "^2.2 || ^3.0",
-# "symfony/options-resolver": "^2.6 || ^3.0",
+# "symfony/event-dispatcher": "^2.1 || ^3.0 || ^4.0",
+# "symfony/filesystem": "^2.4 || ^3.0 || ^4.0",
+# "symfony/finder": "^2.2 || ^3.0 || ^4.0",
+# "symfony/options-resolver": "^2.6 || ^3.0 || ^4.0",
# "symfony/polyfill-php54": "^1.0",
# "symfony/polyfill-php55": "^1.3",
# "symfony/polyfill-php70": "^1.0",
# "symfony/polyfill-php72": "^1.4",
-# "symfony/process": "^2.3 || ^3.0",
-# "symfony/stopwatch": "^2.5 || ^3.0"
+# "symfony/process": "^2.3 || ^3.0 || ^4.0",
+# "symfony/stopwatch": "^2.5 || ^3.0 || ^4.0"
# use 5.4 to avoid polyfill
Requires: php(language) >= 5.4
Requires: php-json
@@ -263,6 +263,9 @@ fi
%changelog
+* Fri Nov 3 2017 Remi Collet <remi@remirepo.net> - 2.2.9-1
+- Update to 2.2.9
+
* Mon Oct 2 2017 Remi Collet <remi@remirepo.net> - 2.2.8-1
- Update to 2.2.8