summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2017-02-11 07:08:47 +0100
committerRemi Collet <fedora@famillecollet.com>2017-02-11 07:08:47 +0100
commit5556c2b7d307ef83ebe541f85025689cc5a615fa (patch)
tree068889b4b85cf4a6e7e43d90ffa4b93f29e037cd
parent6664409c2c8b377222d2e6b6fa8667a28dd92efb (diff)
php-cs-fixer: 2.1.0
-rw-r--r--composer.json1
-rw-r--r--php-cs-fixer-autoload.php1
-rw-r--r--php-cs-fixer.spec11
3 files changed, 11 insertions, 2 deletions
diff --git a/composer.json b/composer.json
index 6a759bb..ee7ee78 100644
--- a/composer.json
+++ b/composer.json
@@ -22,6 +22,7 @@
"symfony/filesystem": "^2.4 || ^3.0",
"symfony/finder": "^2.2 || ^3.0",
"symfony/polyfill-php54": "^1.0",
+ "symfony/polyfill-php55": "^1.3",
"symfony/process": "^2.3 || ^3.0",
"symfony/stopwatch": "^2.5 || ^3.0"
},
diff --git a/php-cs-fixer-autoload.php b/php-cs-fixer-autoload.php
index e6c1c9f..8f11222 100644
--- a/php-cs-fixer-autoload.php
+++ b/php-cs-fixer-autoload.php
@@ -8,5 +8,6 @@ require_once '/usr/share/php/Fedora/Autoloader/autoload.php';
\Fedora\Autoloader\Dependencies::required(array(
'/usr/share/php/Symfony/Component/autoload.php',
'/usr/share/php/SebastianBergmann/Diff/autoload.php',
+ '/usr/share/php/Symfony/Polyfill/autoload.php',
));
diff --git a/php-cs-fixer.spec b/php-cs-fixer.spec
index c54836d..87160a3 100644
--- a/php-cs-fixer.spec
+++ b/php-cs-fixer.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 863ad254da1e44904c8bf8fbcc9f5624834fc71a
+%global gh_commit 2c69f4d424f85062fe40f7689797d6d32c76b711
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20150717
%global gh_owner FriendsOfPHP
@@ -15,7 +15,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-cs-fixer
-Version: 2.0.1
+Version: 2.1.0
Release: 1%{?gh_date:.%{gh_date}git%{gh_short}}%{?dist}
Summary: A tool to automatically fix PHP code style
@@ -40,6 +40,7 @@ BuildRequires: php-composer(symfony/console) >= 2.3
BuildRequires: php-composer(symfony/event-dispatcher) >= 2.1
BuildRequires: php-composer(symfony/filesystem) >= 2.4
BuildRequires: php-composer(symfony/finder) >= 2.4
+BuildRequires: php-composer(symfony/polyfill-php55) >= 1.3
BuildRequires: php-composer(symfony/process) >= 2.3
BuildRequires: php-composer(symfony/stopwatch) >= 2.5
BuildRequires: php-composer(sebastian/diff) >= 1.1
@@ -69,6 +70,7 @@ BuildRequires: php-composer(fedora/autoloader)
# "symfony/filesystem": "^2.4 || ^3.0",
# "symfony/finder": "^2.2 || ^3.0",
# "symfony/polyfill-php54": "^1.0",
+# "symfony/polyfill-php55": "^1.3",
# "symfony/process": "^2.3 || ^3.0",
# "symfony/stopwatch": "^2.5 || ^3.0"
# use 5.4 to avoid polyfill
@@ -79,6 +81,7 @@ Requires: php-composer(symfony/console) >= 2.3
Requires: php-composer(symfony/event-dispatcher) >= 2.1
Requires: php-composer(symfony/filesystem) >= 2.4
Requires: php-composer(symfony/finder) >= 2.4
+Requires: php-composer(symfony/polyfill-php55) >= 1.3
Requires: php-composer(symfony/process) >= 2.3
Requires: php-composer(symfony/stopwatch) >= 2.5
# From phpcompatinfo report for version 2.0.0
@@ -180,6 +183,10 @@ rm -rf %{buildroot}
%changelog
+* Sat Feb 11 2017 Remi Collet <remi@fedoraproject.org> - 2.1.0-1
+- update to 2.1.0
+- add dependency on symfony/polyfill-php55 (for EPEL-7)
+
* Thu Feb 9 2017 Remi Collet <remi@fedoraproject.org> - 2.0.1-1
- update to 2.0.1