summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-03-21 06:50:34 +0100
committerRemi Collet <remi@remirepo.net>2018-03-21 06:50:34 +0100
commit52f37b39484a4c6f20e5a517d341603b644cc578 (patch)
tree9442bdcfccbec7b5fffd9a308e988cc535e17ab7
parenta18b1e71ae80e169a221decf53e99c3ad459e573 (diff)
v2.2.19
-rw-r--r--php-cs-fixer-autoload.patch33
-rw-r--r--php-cs-fixer.spec8
2 files changed, 25 insertions, 16 deletions
diff --git a/php-cs-fixer-autoload.patch b/php-cs-fixer-autoload.patch
index 221f1ad..1a058fa 100644
--- a/php-cs-fixer-autoload.patch
+++ b/php-cs-fixer-autoload.patch
@@ -1,15 +1,21 @@
diff -up ./php-cs-fixer.rpm ./php-cs-fixer
---- ./php-cs-fixer.rpm 2017-10-02 15:47:01.068895386 +0200
-+++ ./php-cs-fixer 2017-10-02 15:48:29.217404013 +0200
-@@ -41,18 +41,7 @@ set_error_handler(function ($severity, $
+--- ./php-cs-fixer.rpm 2018-03-21 06:42:07.838432372 +0100
++++ ./php-cs-fixer 2018-03-21 06:43:59.948972275 +0100
+@@ -41,25 +41,7 @@ set_error_handler(function ($severity, $
}
});
--try {
+-$require = true;
+-if (class_exists('Phar')) {
- // Maybe this file is used as phar-stub? Let's try!
-- Phar::mapPhar('php-cs-fixer.phar');
-- require_once 'phar://php-cs-fixer.phar/vendor/autoload.php';
--} catch (PharException $e) {
+- try {
+- Phar::mapPhar('php-cs-fixer.phar');
+- require_once 'phar://php-cs-fixer.phar/vendor/autoload.php';
+- $require = false;
+- } catch (PharException $e) {
+- }
+-}
+-if ($require) {
- // OK, it's not, let give Composer autoloader a try!
- if (file_exists($a = __DIR__.'/../../autoload.php')) {
- require_once $a;
@@ -17,14 +23,15 @@ diff -up ./php-cs-fixer.rpm ./php-cs-fixer
- require_once __DIR__.'/vendor/autoload.php';
- }
-}
+-unset($require);
+require_once '/usr/share/php/PhpCsFixer/autoload.php';
use PhpCsFixer\Console\Application;
diff -up ./src/Console/Command/HelpCommand.php.rpm ./src/Console/Command/HelpCommand.php
---- ./src/Console/Command/HelpCommand.php.rpm 2017-10-02 15:46:28.000000000 +0200
-+++ ./src/Console/Command/HelpCommand.php 2017-10-02 15:47:01.069895391 +0200
-@@ -344,6 +344,8 @@ EOF
+--- ./src/Console/Command/HelpCommand.php.rpm 2018-03-21 06:41:56.000000000 +0100
++++ ./src/Console/Command/HelpCommand.php 2018-03-21 06:42:07.838432372 +0100
+@@ -348,6 +348,8 @@ EOF
{
static $version = null;
@@ -34,9 +41,9 @@ diff -up ./src/Console/Command/HelpCommand.php.rpm ./src/Console/Command/HelpCom
return $version;
}
diff -up ./tests/AutoReview/ProjectCodeTest.php.rpm ./tests/AutoReview/ProjectCodeTest.php
---- ./tests/AutoReview/ProjectCodeTest.php.rpm 2017-10-02 15:46:28.000000000 +0200
-+++ ./tests/AutoReview/ProjectCodeTest.php 2017-10-02 15:47:01.069895391 +0200
-@@ -379,8 +379,10 @@ final class ProjectCodeTest extends Test
+--- ./tests/AutoReview/ProjectCodeTest.php.rpm 2018-03-21 06:41:56.000000000 +0100
++++ ./tests/AutoReview/ProjectCodeTest.php 2018-03-21 06:42:07.838432372 +0100
+@@ -425,8 +425,10 @@ final class ProjectCodeTest extends Test
->files()
->name('*.php')
->in(__DIR__.'/../../src')
diff --git a/php-cs-fixer.spec b/php-cs-fixer.spec
index 8512c96..80fea6c 100644
--- a/php-cs-fixer.spec
+++ b/php-cs-fixer.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 44f73c3e881805da5957ebd16ea87da9270cd5f3
+%global gh_commit 2de0ac9c1d0d48a9b969814f43698223c6e03d6d
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20150717
%global gh_owner FriendsOfPHP
@@ -15,11 +15,10 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-cs-fixer
-Version: 2.2.18
+Version: 2.2.19
Release: 1%{?gh_date:.%{gh_date}git%{gh_short}}%{?dist}
Summary: A tool to automatically fix PHP code style
-Group: Development/Tools
License: MIT
URL: https://github.com/%{gh_owner}/%{gh_project}
# git snapshot to get upstream test suite
@@ -259,6 +258,9 @@ fi
%changelog
+* Wed Mar 21 2018 Remi Collet <remi@remirepo.net> - 2.2.19-1
+- update to 2.2.19
+
* Thu Mar 8 2018 Remi Collet <remi@remirepo.net> - 2.2.18-1
- update to 2.2.18