summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json5
-rw-r--r--php-cakephp.spec15
2 files changed, 11 insertions, 9 deletions
diff --git a/composer.json b/composer.json
index dea0220..4f4b22b 100644
--- a/composer.json
+++ b/composer.json
@@ -43,8 +43,9 @@
"lib-ICU": "The intl PHP library, to use Text::transliterate() or Text::slug()"
},
"require-dev": {
- "phpunit/phpunit": "^5.7.14|^6.0",
- "cakephp/cakephp-codesniffer": "^3.0"
+ "cakephp/cakephp-codesniffer": "^3.0",
+ "cakephp/chronos": "^1.2.1",
+ "phpunit/phpunit": "^5.7.14|^6.0"
},
"autoload": {
"psr-4": {
diff --git a/php-cakephp.spec b/php-cakephp.spec
index e083f8a..65d4412 100644
--- a/php-cakephp.spec
+++ b/php-cakephp.spec
@@ -8,7 +8,7 @@
#
# https://github.com/cakephp/cakephp/releases
-%global gh_commit eae26792654fece99bb121420e179f0a0efcb2ae
+%global gh_commit b0b9a3713720b30cd8e90c8b1a317a8294b2513a
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner cakephp
%global gh_project cakephp
@@ -23,7 +23,7 @@
%global chronos_version 1.2.3
Name: php-%{pk_vendor}
-Version: 3.7.2
+Version: 3.7.3
Release: 1%{?dist}
Summary: The CakePHP framework
@@ -52,11 +52,9 @@ BuildRequires: php-reflection
BuildRequires: php-simplexml
BuildRequires: php-spl
# From composer.json, "require-dev": {
-# "phpunit/phpunit": "<6.0",
-# "athletic/athletic": "~0.1",
-# "cakephp/cakephp-codesniffer": "~2.3",
-# "phpbench/phpbench": "@dev",
-# "phpstan/phpstan": "^0.6.4"
+# "cakephp/cakephp-codesniffer": "^3.0",
+# "cakephp/chronos": "^1.2.1",
+# "phpunit/phpunit": "^5.7.14|^6.0"
BuildRequires: php-composer(phpunit/phpunit)
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(aura/intl) >= 3.0.0 with php-composer(aura/intl) < 4)
@@ -517,6 +515,9 @@ exit $ret
%changelog
+* Tue Jan 22 2019 Remi Collet <remi@remirepo.net> - 3.7.3-1
+- update to 3.7.3
+
* Fri Jan 4 2019 Remi Collet <remi@remirepo.net> - 3.7.2-1
- update to 3.7.2
- add log subpackage