summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-07-09 07:08:48 +0200
committerRemi Collet <remi@remirepo.net>2018-07-09 07:08:48 +0200
commit409a154f304ed1344d7f0f12f863d345ddeba1f0 (patch)
tree42f45fcded9409b4095b1492a89cbedcc38cd456
parent5b30105cfa963fd0ae5e2be8aac19cc403c0da03 (diff)
v3.6.7
-rw-r--r--composer-chronos.json62
-rw-r--r--php-cakephp.spec7
2 files changed, 67 insertions, 2 deletions
diff --git a/composer-chronos.json b/composer-chronos.json
new file mode 100644
index 0000000..77a7e27
--- /dev/null
+++ b/composer-chronos.json
@@ -0,0 +1,62 @@
+{
+ "name": "cakephp/chronos",
+ "type": "library",
+ "description": "A simple API extension for DateTime.",
+ "keywords": [
+ "date",
+ "time",
+ "DateTime"
+ ],
+ "homepage": "http://cakephp.org",
+ "license": "MIT",
+ "authors": [
+ {
+ "name": "Brian Nesbitt",
+ "email": "brian@nesbot.com",
+ "homepage": "http://nesbot.com"
+ },
+ {
+ "name": "The CakePHP Team",
+ "homepage": "http://cakephp.org"
+ }
+ ],
+ "support": {
+ "issues": "https://github.com/cakephp/chronos/issues",
+ "irc": "irc://irc.freenode.org/cakephp",
+ "source": "https://github.com/cakephp/chronos"
+ },
+ "require": {
+ "php": "^5.5.9|^7"
+ },
+ "require-dev": {
+ "phpunit/phpunit": "<6.0",
+ "athletic/athletic": "~0.1",
+ "cakephp/cakephp-codesniffer": "~2.3",
+ "phpbench/phpbench": "@dev",
+ "phpstan/phpstan": "^0.6.4"
+ },
+ "autoload": {
+ "psr-4": {
+ "Cake\\Chronos\\": "src"
+ },
+ "files": ["src/carbon_compat.php"]
+ },
+ "autoload-dev": {
+ "psr-4": {
+ "Cake\\Chronos\\Test\\": "tests"
+ },
+ "files": ["tests/TestCase.php"]
+ },
+ "scripts": {
+ "check": [
+ "@test",
+ "@cs-check",
+ "@phpstan"
+ ],
+ "test": "phpunit",
+ "cs-check": "phpcs",
+ "cs-fix": "phpcbf",
+ "bench": "phpbench run",
+ "phpstan": "phpstan analyze -c phpstan.neon -l 3 src tests"
+ }
+}
diff --git a/php-cakephp.spec b/php-cakephp.spec
index 8292ca9..19bd207 100644
--- a/php-cakephp.spec
+++ b/php-cakephp.spec
@@ -8,7 +8,7 @@
#
# https://github.com/cakephp/cakephp/releases
-%global gh_commit 9cad3bbe48da8386835743058217c2fd99e9d3aa
+%global gh_commit 9a67c9d7158d5e299418f9956d1a8af39128cf57
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner cakephp
%global gh_project cakephp
@@ -24,7 +24,7 @@
%global chronos_version 1.1.4
Name: php-%{pk_vendor}
-Version: 3.6.6
+Version: 3.6.7
Release: 1%{?dist}
Summary: The CakePHP framework
@@ -443,6 +443,9 @@ exit $ret
%changelog
+* Mon Jul 9 2018 Remi Collet <remi@remirepo.net> - 3.6.7-1
+- update to 3.6.7
+
* Mon Jun 25 2018 Remi Collet <remi@remirepo.net> - 3.6.6-1
- update to 3.6.6