summaryrefslogtreecommitdiffstats
path: root/php-brotli.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-brotli.spec')
-rw-r--r--php-brotli.spec27
1 files changed, 15 insertions, 12 deletions
diff --git a/php-brotli.spec b/php-brotli.spec
index 6e91371..67fde56 100644
--- a/php-brotli.spec
+++ b/php-brotli.spec
@@ -18,12 +18,12 @@
%endif
%if 0%{?fedora} >= 30 || 0%{?rhel} >= 7
-%global with_libbrotli 1
+%bcond_without libbrotli
%else
-%global with_libbrotli 0
+%bcond_with libbrotli
%endif
-%global gh_commit c1f837567e630b6cb1d2f1f3e9e7913aa393957d
+%global gh_commit 776d9d5c4113c4f96ac672456bc84fba95574e50
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner kjdev
%global gh_project php-ext-brotli
@@ -34,7 +34,7 @@
Summary: Brotli Extension for PHP
Name: %{?sub_prefix}php-%{pecl_name}
-Version: 0.9.0
+Version: 0.10.0
%if 0%{?gh_date:1}
Release: 1%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%else
@@ -48,7 +48,7 @@ Source1: makesrc.sh
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel
-%if %{?with_libbrotli}
+%if %{with libbrotli}
BuildRequires: brotli-devel >= 0.6.0
%else
Provides: bundled(brotli) = 1.0.7
@@ -58,7 +58,7 @@ Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
-%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
+%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
%if "%{php_version}" > "7.1"
Obsoletes: php71u-%{pecl_name} <= %{version}
Obsoletes: php71w-%{pecl_name} <= %{version}
@@ -99,7 +99,7 @@ cd NTS
rm LICENSE
mv brotli/LICENSE .
-%if %{?with_libbrotli}
+%if %{with libbrotli}
# Use the system library
mv brotli tests
%endif
@@ -132,13 +132,13 @@ EOF
%{?dtsenable}
cd NTS
-%if %{?with_libbrotli}
+%if %{with libbrotli}
mv tests/brotli brotli
%endif
%{_bindir}/phpize
%configure \
--with-php-config=%{_bindir}/php-config \
-%if %{?with_libbrotli}
+%if %{with libbrotli}
--with-libbrotli \
%endif
--with-libdir=%{_lib} \
@@ -147,13 +147,13 @@ make %{?_smp_mflags}
%if %{with_zts}
cd ../ZTS
-%if %{?with_libbrotli}
+%if %{with libbrotli}
mv tests/brotli brotli
%endif
%{_bindir}/zts-phpize
%configure \
--with-php-config=%{_bindir}/zts-php-config \
-%if %{?with_libbrotli}
+%if %{with libbrotli}
--with-libbrotli \
%endif
--with-libdir=%{_lib} \
@@ -198,7 +198,7 @@ cd ../ZTS
--modules | grep %{pecl_name}
# TODO: need investigation
-# EL6 / i386 /ZTS only
+# EL6 / i386 / ZTS only
rm tests/streams_003.phpt
: Upstream test suite for ZTS extension
@@ -224,6 +224,9 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Mon Jul 27 2020 Remi Collet <remi@remirepo.net> - 0.10.0-1
+- update to 0.10.0
+
* Sat Jun 27 2020 Remi Collet <remi@remirepo.net> - 0.9.0-1
- update to 0.9.0