summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION22
-rw-r--r--php-brotli.spec22
3 files changed, 28 insertions, 18 deletions
diff --git a/PHPINFO b/PHPINFO
index 8ae3e62..4507757 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,5 +2,5 @@
brotli
Brotli support => enabled
-Extension Version => 0.6.2
+Extension Version => 0.7.0
Library Version => 1.0.5
diff --git a/REFLECTION b/REFLECTION
index de067c9..4673319 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #76 brotli version 0.6.2 ] {
+Extension [ <persistent> extension #81 brotli version 0.7.0 ] {
- INI {
Entry [ brotli.output_compression <ALL> ]
@@ -9,10 +9,13 @@ Extension [ <persistent> extension #76 brotli version 0.6.2 ] {
}
}
- - Constants [3] {
+ - Constants [6] {
Constant [ integer BROTLI_GENERIC ] { 0 }
Constant [ integer BROTLI_TEXT ] { 1 }
Constant [ integer BROTLI_FONT ] { 2 }
+ Constant [ integer BROTLI_COMPRESS_LEVEL_MIN ] { 0 }
+ Constant [ integer BROTLI_COMPRESS_LEVEL_MAX ] { 11 }
+ Constant [ integer BROTLI_COMPRESS_LEVEL_DEFAULT ] { 11 }
}
- Functions {
@@ -31,6 +34,21 @@ Extension [ <persistent> extension #76 brotli version 0.6.2 ] {
Parameter #1 [ <optional> $max ]
}
}
+ Function [ <internal:brotli> function Brotli\compress ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $data ]
+ Parameter #1 [ <optional> $quality ]
+ Parameter #2 [ <optional> $mode ]
+ }
+ }
+ Function [ <internal:brotli> function Brotli\uncompress ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $data ]
+ Parameter #1 [ <optional> $max ]
+ }
+ }
}
}
diff --git a/php-brotli.spec b/php-brotli.spec
index 9ccca24..b26f094 100644
--- a/php-brotli.spec
+++ b/php-brotli.spec
@@ -23,7 +23,7 @@
%global with_libbrotli 0
%endif
-%global gh_commit a2c3ccb54d0d1270921079f1bb2ea79638b8f876
+%global gh_commit 942eadcd2d81db045a7721cfff37f070e54dfe66
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner kjdev
%global gh_project php-ext-brotli
@@ -34,14 +34,13 @@
Summary: Brotli Extension for PHP
Name: %{?sub_prefix}php-%{pecl_name}
-Version: 0.6.2
+Version: 0.7.0
%if 0%{?gh_date:1}
Release: 1%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%else
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%endif
License: MIT
-Group: Development/Languages
URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: %{pkg_name}-%{version}-%{gh_short}.tgz
# retrieve a recursive git snapshot with submodule
@@ -60,14 +59,6 @@ Requires: %{?scl_prefix}php(api) = %{php_core_api}
%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
-%if "%{php_version}" > "5.6"
-Obsoletes: php56u-%{pecl_name} <= %{version}
-Obsoletes: php56w-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.0"
-Obsoletes: php70u-%{pecl_name} <= %{version}
-Obsoletes: php70w-%{pecl_name} <= %{version}
-%endif
%if "%{php_version}" > "7.1"
Obsoletes: php71u-%{pecl_name} <= %{version}
Obsoletes: php71w-%{pecl_name} <= %{version}
@@ -193,9 +184,8 @@ cd NTS
: Upstream test suite for NTS extension
TEST_PHP_EXECUTABLE=%{__php} \
TEST_PHP_ARGS="-n -d extension=%{buildroot}%{php_extdir}/%{pecl_name}.so" \
-NO_INTERACTION=1 \
REPORT_EXIT_STATUS=1 \
-%{__php} -n run-tests.php --show-diff || : ignore
+%{__php} -n run-tests.php -q --offline --show-diff || : ignore
%if %{with_zts}
cd ../ZTS
@@ -207,9 +197,8 @@ cd ../ZTS
: Upstream test suite for ZTS extension
TEST_PHP_EXECUTABLE=%{__ztsphp} \
TEST_PHP_ARGS="-n -d extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so" \
-NO_INTERACTION=1 \
REPORT_EXIT_STATUS=1 \
-%{__ztsphp} -n run-tests.php --show-diff
+%{__ztsphp} -n run-tests.php -q --offline --show-diff
%endif
@@ -228,6 +217,9 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Fri May 3 2019 Remi Collet <remi@remirepo.net> - 0.7.0-1
+- update to 0.7.0
+
* Mon Jan 7 2019 Remi Collet <remi@remirepo.net> - 0.6.2-1
- update to 0.6.2