summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--REFLECTION12
-rw-r--r--php-ast.spec10
2 files changed, 13 insertions, 9 deletions
diff --git a/REFLECTION b/REFLECTION
index 50825ba..4a5e4e5 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,6 +1,6 @@
-Extension [ <persistent> extension #73 ast version 1.0.0 ] {
+Extension [ <persistent> extension #77 ast version 1.0.1 ] {
- - Constants [171] {
+ - Constants [173] {
Constant [ integer ast\AST_ARG_LIST ] { 128 }
Constant [ integer ast\AST_LIST ] { 255 }
Constant [ integer ast\AST_ARRAY ] { 129 }
@@ -55,6 +55,7 @@ Extension [ <persistent> extension #73 ast version 1.0.0 ] {
Constant [ integer ast\AST_GOTO ] { 284 }
Constant [ integer ast\AST_BREAK ] { 285 }
Constant [ integer ast\AST_CONTINUE ] { 286 }
+ Constant [ integer ast\AST_CLASS_NAME ] { 511 }
Constant [ integer ast\AST_DIM ] { 512 }
Constant [ integer ast\AST_PROP ] { 513 }
Constant [ integer ast\AST_STATIC_PROP ] { 514 }
@@ -76,6 +77,7 @@ Extension [ <persistent> extension #73 ast version 1.0.0 ] {
Constant [ integer ast\AST_SWITCH_CASE ] { 535 }
Constant [ integer ast\AST_DECLARE ] { 536 }
Constant [ integer ast\AST_PROP_ELEM ] { 774 }
+ Constant [ integer ast\AST_PROP_GROUP ] { 767 }
Constant [ integer ast\AST_CONST_ELEM ] { 775 }
Constant [ integer ast\AST_USE_TRAIT ] { 537 }
Constant [ integer ast\AST_TRAIT_PRECEDENCE ] { 538 }
@@ -158,9 +160,9 @@ Extension [ <persistent> extension #73 ast version 1.0.0 ] {
Constant [ integer ast\flags\EXEC_INCLUDE_ONCE ] { 4 }
Constant [ integer ast\flags\EXEC_REQUIRE ] { 8 }
Constant [ integer ast\flags\EXEC_REQUIRE_ONCE ] { 16 }
- Constant [ integer ast\flags\USE_NORMAL ] { 361 }
- Constant [ integer ast\flags\USE_FUNCTION ] { 346 }
- Constant [ integer ast\flags\USE_CONST ] { 347 }
+ Constant [ integer ast\flags\USE_NORMAL ] { 1 }
+ Constant [ integer ast\flags\USE_FUNCTION ] { 2 }
+ Constant [ integer ast\flags\USE_CONST ] { 4 }
Constant [ integer ast\flags\MAGIC_LINE ] { 370 }
Constant [ integer ast\flags\MAGIC_FILE ] { 371 }
Constant [ integer ast\flags\MAGIC_DIR ] { 372 }
diff --git a/php-ast.spec b/php-ast.spec
index 5b2e46c..1dfe641 100644
--- a/php-ast.spec
+++ b/php-ast.spec
@@ -1,6 +1,6 @@
# remirepo spec file for php-ast
#
-# Copyright (c) 2015-2018 Remi Collet
+# Copyright (c) 2015-2019 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -20,14 +20,13 @@
Summary: Abstract Syntax Tree
Name: %{?scl_prefix}php-ast
-Version: 1.0.0
+Version: 1.0.1
%if 0%{?gh_date:1}
Release: 0.5.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%else
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%endif
License: BSD
-Group: Development/Languages
URL: https://github.com/%{gh_owner}/%{gh_project}
%if 0%{?gh_date}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{gh_short}.tar.gz
@@ -237,6 +236,9 @@ fi
%changelog
+* Mon Feb 11 2019 Remi Collet <remi@remirepo.net> - 1.0.1-1
+- update to 1.0.1
+
* Mon Oct 22 2018 Remi Collet <remi@remirepo.net> - 1.0.0-2
- add missing scriptlets