summaryrefslogtreecommitdiffstats
path: root/php-amqplib.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-05-13 10:43:46 +0200
committerRemi Collet <remi@remirepo.net>2019-05-13 10:43:46 +0200
commit48453e9648cb2ad980f7ab4099ad9e6f02c97d3e (patch)
treea95cea189b77266212169b8075f3d7b0f550e736 /php-amqplib.spec
parent2418694321f9a8f9304fcbd337d3ee976d063e57 (diff)
v2.7.3 fromp Fedora
Diffstat (limited to 'php-amqplib.spec')
-rw-r--r--php-amqplib.spec19
1 files changed, 12 insertions, 7 deletions
diff --git a/php-amqplib.spec b/php-amqplib.spec
index 1352351..fa12f16 100644
--- a/php-amqplib.spec
+++ b/php-amqplib.spec
@@ -2,7 +2,7 @@
#
# Fedora spec file for php-php-amqplib-php-amqplib
#
-# Copyright (c) 2017 Shawn Iwinski <shawn@iwin.ski>
+# Copyright (c) 2017-2019 Shawn Iwinski <shawn@iwin.ski>
#
# License: MIT
# http://opensource.org/licenses/MIT
@@ -12,8 +12,8 @@
%global github_owner php-amqplib
%global github_name php-amqplib
-%global github_version 2.7.0
-%global github_commit f48748546e398d846134c594dfca9070c4c3b356
+%global github_version 2.7.3
+%global github_commit a8ba54bd35b973fc6861e4c2e105f71e9e95f43f
%global composer_vendor php-amqplib
%global composer_project php-amqplib
@@ -28,11 +28,10 @@
Name: %{composer_project}
Version: %{github_version}
-Release: 2%{?github_release}%{?dist}
+Release: 1%{?github_release}%{?dist}
Summary: Pure PHP implementation of the AMQP protocol
-Group: Development/Libraries
-License: LGPLv2
+License: LGPLv2+
URL: https://github.com/%{github_owner}/%{github_name}
# GitHub export does not include tests.
@@ -124,6 +123,8 @@ cat <<'BOOTSTRAP' | tee bootstrap.php
date_default_timezone_set('UTC');
require '%{buildroot}%{phpdir}/PhpAmqpLib/autoload.php';
\Fedora\Autoloader\Autoload::addPsr4('PhpAmqpLib\\Tests\\Unit\\', __DIR__.'/tests/Unit');
+
+class_alias('PHPUnit_Framework_TestCase', 'PHPUnit\\Framework\\TestCase');
BOOTSTRAP
: Remove tests requiring a running AMQP service
@@ -132,7 +133,7 @@ rm -f tests/Unit/Wire/IO/SocketIOTest.php
: Upstream tests
RETURN_CODE=0
PHPUNIT=$(which phpunit)
-for PHP_EXEC in php %{?rhel:php54 php55} php56 php70 php71 php72; do
+for PHP_EXEC in php %{?rhel:php54 php55 php56 php70} php71 php72; do
if [ "php" == "$PHP_EXEC" ] || which $PHP_EXEC; then
$PHP_EXEC $PHPUNIT --verbose --bootstrap bootstrap.php \
--testsuite="Unit Tests" || RETURN_CODE=1
@@ -153,6 +154,10 @@ exit $RETURN_CODE
%changelog
+* Fri May 10 2019 Shawn Iwinski <shawn@iwin.ski> - 2.7.3-1
+- Update to 2.7.3
+- Update license from LGPLv2 to LGPLv2+
+
* Fri Nov 03 2017 Shawn Iwinski <shawn@iwin.ski> - 2.7.0-2
- Set default timezone in tests' bootstrap