summaryrefslogtreecommitdiffstats
path: root/php-PhpOption.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-PhpOption.spec')
-rw-r--r--php-PhpOption.spec40
1 files changed, 9 insertions, 31 deletions
diff --git a/php-PhpOption.spec b/php-PhpOption.spec
index c6763c3..525d5bc 100644
--- a/php-PhpOption.spec
+++ b/php-PhpOption.spec
@@ -2,7 +2,7 @@
#
# Fedora spec file for php-PhpOption
#
-# Copyright (c) 2013-2020 Shawn Iwinski <shawn.iwinski@gmail.com>
+# Copyright (c) 2013-2022 Shawn Iwinski <shawn.iwinski@gmail.com>
#
# License: MIT
# http://opensource.org/licenses/MIT
@@ -12,43 +12,18 @@
%global github_owner schmittjoh
%global github_name php-option
-%global github_version 1.7.5
-%global github_commit 994ecccd8f3283ecf5ac33254543eb0ac946d525
+%global github_version 1.8.1
+%global github_commit eab7a0df01fe2344d172bff4cd6dbd3f8b84ad15
%global composer_vendor phpoption
%global composer_project phpoption
-# "php": "^5.5.9 || ^7.0 || ^8.0"
-%global php_min_ver 5.5.9
+# "php": "^7.0 || ^8.0"
+%global php_min_ver 7.0
# PHPUnit
-## v9
-%if 0%{?fedora} >= 31 || 0%{?rhel} >= 8
%global phpunit_require phpunit9
%global phpunit_exec phpunit9
-%else
-## v8
-%if 0%{?fedora} >= 29
-%global phpunit_require phpunit8
-%global phpunit_exec phpunit8
-%else
-## v7
-%if 0%{?fedora} >= 28
-%global phpunit_require phpunit7
-%global phpunit_exec phpunit7
-%else
-## v6
-%if 0%{?fedora} >= 26
-%global phpunit_require phpunit6
-%global phpunit_exec phpunit6
-%else
-## Pre-v6
-%global phpunit_require php-composer(phpunit/phpunit)
-%global phpunit_exec phpunit
-%endif
-%endif
-%endif
-%endif
# Build using "--without tests" to disable tests
%global with_tests 0%{!?_without_tests:1}
@@ -152,7 +127,7 @@ BOOTSTRAP
: Upstream tests
RETURN_CODE=0
PHPUNIT=$(which %{phpunit_exec})
-for PHP_EXEC in "" php73 php74 php80; do
+for PHP_EXEC in "" php74 php80 php81; do
if [ -z "$PHP_EXEC" ] || which $PHP_EXEC; then
$PHP_EXEC $PHPUNIT --verbose --bootstrap bootstrap.php || RETURN_CODE=1
fi
@@ -172,6 +147,9 @@ exit $RETURN_CODE
%changelog
+* Mon Mar 21 2022 Remi Collet <remi@remirepo.net> - 1.8.1-1
+- update to 1.8.1
+
* Mon Aug 17 2020 Shawn Iwinski <shawn.iwinski@gmail.com> - 1.7.5-1
- Update to 1.7.5 (RHBZ #1782417)