summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Makefile10
-rw-r--r--php-PhpOption.spec6
2 files changed, 16 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..d095534
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,10 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+INCL1 := $(shell php-config --includes)
+INCL2 := -I $(shell php-config --include-dir)/sapi/embed
+LIBS := -lphp5 $(shell php-config --libs)
+
+include ../../common/Makefile
+
+tembed: tembed.c
+ gcc -Wall $(INCL1) $(INCL2) tembed.c $(LIBS) -o tembed
diff --git a/php-PhpOption.spec b/php-PhpOption.spec
index 7b95990..4faec83 100644
--- a/php-PhpOption.spec
+++ b/php-PhpOption.spec
@@ -16,6 +16,7 @@ License: ASL 2.0
URL: https://github.com/%{github_owner}/%{github_name}
Source0: %{url}/archive/%{github_commit}/%{name}-%{github_version}-%{github_commit}.tar.gz
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
# Test build requires
BuildRequires: php-common >= %{php_min_ver}
@@ -97,14 +98,19 @@ cp -rp tests/* %{buildroot}%{_datadir}/tests/%{name}/
%files
+%defattr(-,root,root,-)
%doc LICENSE README.md composer.json
%{_datadir}/php/%{lib_name}
%files tests
+%defattr(-,root,root,-)
%dir %{_datadir}/tests
%{_datadir}/tests/%{name}
%changelog
+* Fri Jan 25 2013 Remi Collet <RPMS@famillecollet.com> 1.1.0-1
+- backport 1.1.0 for remi repo
+
* Tue Jan 22 2013 Shawn Iwinski <shawn.iwinski@gmail.com> 1.1.0-1
- Initial package