summaryrefslogtreecommitdiffstats
path: root/php-Monolog.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-Monolog.spec')
-rw-r--r--php-Monolog.spec17
1 files changed, 10 insertions, 7 deletions
diff --git a/php-Monolog.spec b/php-Monolog.spec
index 756813e..0a3e564 100644
--- a/php-Monolog.spec
+++ b/php-Monolog.spec
@@ -2,7 +2,7 @@
#
# Fedora spec file for php-Monolog
#
-# Copyright (c) 2012-2017 Shawn Iwinski <shawn.iwinski@gmail.com>
+# Copyright (c) 2012-2020 Shawn Iwinski <shawn.iwinski@gmail.com>
#
# License: MIT
# http://opensource.org/licenses/MIT
@@ -12,8 +12,8 @@
%global github_owner Seldaek
%global github_name monolog
-%global github_version 1.25.2
-%global github_commit d5e2fb341cb44f7e2ab639d12a1e5901091ec287
+%global github_version 1.25.5
+%global github_commit 1817faadd1846cd08be9a49e905dc68823bc38c0
%global composer_vendor monolog
%global composer_project monolog
@@ -36,7 +36,7 @@
%global swift_max_ver 6
# Build using "--without tests" to disable tests
-%global with_tests 0%{!?_without_tests:1}
+%bcond_without tests
%{!?phpdir: %global phpdir %{_datadir}/php}
@@ -57,7 +57,7 @@ Patch0: %{name}-tests-sentry-gte-0-16-0.patch
BuildArch: noarch
# Tests
-%if %{with_tests}
+%if %{with tests}
## composer.json
BuildRequires: php(language) >= %{php_min_ver}
BuildRequires: php-composer(phpunit/phpunit)
@@ -184,7 +184,7 @@ cp -pr src/Monolog %{buildroot}%{phpdir}/
%check
-%if %{with_tests}
+%if %{with tests}
: Create tests bootstrap
cat <<'BOOTSTRAP' | tee bootstrap.php
<?php
@@ -213,7 +213,7 @@ sed 's/function testThrowsOnInvalidEncoding/function SKIP_testThrowsOnInvalidEnc
: Upstream tests
RETURN_CODE=0
PHPUNIT=$(which phpunit)
-for PHP_EXEC in "" %{?rhel:php54 php55 php56 php70} php71 php72 php73 php74; do
+for PHP_EXEC in "" %{?rhel:php54 php55 php56 php70 php71} php72 php73 php74; do
if [ -z "$PHP_EXEC" ] || which $PHP_EXEC; then
$PHP_EXEC $PHPUNIT --verbose --bootstrap bootstrap.php || RETURN_CODE=1
fi
@@ -234,6 +234,9 @@ exit $RETURN_CODE
%changelog
+* Thu Jul 23 2020 Remi Collet <remi@remirepo.net> - 1.25.5-1
+- update to 1.25.5
+
* Thu Nov 14 2019 Remi Collet <remi@remirepo.net> - 1.25.2-1
- update to 1.25.2