summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json6
-rw-r--r--php-Metadata.spec27
2 files changed, 23 insertions, 10 deletions
diff --git a/composer.json b/composer.json
index 58dec88..b6329d5 100644
--- a/composer.json
+++ b/composer.json
@@ -3,11 +3,15 @@
"description": "Class/method/property metadata management in PHP",
"keywords": ["annotations","metadata","yaml","xml"],
"type": "library",
- "license": "Apache-2.0",
+ "license": "MIT",
"authors": [
{
"name": "Johannes M. Schmitt",
"email": "schmittjoh@gmail.com"
+ },
+ {
+ "name": "Asmir Mustafic",
+ "email": "goetas@gmail.com"
}
],
"require": {
diff --git a/php-Metadata.spec b/php-Metadata.spec
index 1201fea..7f9b18e 100644
--- a/php-Metadata.spec
+++ b/php-Metadata.spec
@@ -2,7 +2,7 @@
#
# Fedora spec file for php-Metadata
#
-# Copyright (c) 2013-2017 Shawn Iwinski <shawn.iwinski@gmail.com>
+# Copyright (c) 2013-2020 Shawn Iwinski <shawn.iwinski@gmail.com>
#
# License: MIT
# http://opensource.org/licenses/MIT
@@ -12,8 +12,8 @@
%global github_owner schmittjoh
%global github_name metadata
-%global github_version 1.6.0
-%global github_commit 6a06970a10e0a532fb52d3959547123b84a3b3ab
+%global github_version 1.7.0
+%global github_commit e5854ab1aa643623dc64adde718a8eec32b957a8
%global composer_vendor jms
%global composer_project metadata
@@ -35,8 +35,7 @@ Version: %{github_version}
Release: 1%{?github_release}%{?dist}
Summary: Class/method/property metadata management in PHP
-Group: Development/Libraries
-License: ASL 2.0
+License: MIT
URL: https://github.com/%{github_owner}/%{github_name}
Source0: %{url}/archive/%{github_commit}/%{name}-%{github_version}-%{github_commit}.tar.gz
@@ -46,7 +45,7 @@ BuildArch: noarch
BuildRequires: php-composer(phpunit/phpunit)
## composer.json
BuildRequires: php(language) >= %{php_min_ver}
-## phpcompatinfo (computed from version 1.6.0)
+## phpcompatinfo (computed from version 1.7.0)
BuildRequires: php-date
BuildRequires: php-reflection
BuildRequires: php-spl
@@ -56,14 +55,14 @@ BuildRequires: php-composer(fedora/autoloader)
# composer.json
Requires: php(language) >= %{php_min_ver}
-# phpcompatinfo (computed from version 1.6.0)
+# phpcompatinfo (computed from version 1.7.0)
Requires: php-date
Requires: php-reflection
Requires: php-spl
# Autoloader
Requires: php-composer(fedora/autoloader)
-%if 0%{?fedora} >= 21
+%if 0%{?fedora} >= 21 || 0%{?rhel} >= 8
# phpcompatinfo (computed from version 1.6.0)
Suggests: php-composer(doctrine/cache)
Suggests: php-composer(psr/cache)
@@ -128,7 +127,7 @@ BOOTSTRAP
: Upstream tests
RETURN_CODE=0
PHPUNIT=$(which phpunit)
-for PHP_EXEC in "" %{?rhel:php54 php55} php56 php70 php71 php72; do
+for PHP_EXEC in "" %{?rhel:php54 php55 php56 php70 php71} php72 php73 php74 php80; do
if [ -z "$PHP_EXEC" ] || which $PHP_EXEC; then
$PHP_EXEC $PHPUNIT --verbose --bootstrap bootstrap.php || RETURN_CODE=1
fi
@@ -149,6 +148,16 @@ exit $RETURN_CODE
%changelog
+* Mon Aug 17 2020 Shawn Iwinski <shawn.iwinski@gmail.com> - 1.7.0-1
+- Update to 1.7.0
+- Change license from ASL 2.0 to MIT
+
+* Tue Feb 26 2019 Remi Collet <remi@remirepo.net> - 1.6.0-8
+- cleanup for EL-8
+
+* Thu Sep 07 2017 Shawn Iwinski <shawn.iwinski@gmail.com> - 1.6.0-4
+- Bump release for rebuild
+
* Sun Jun 04 2017 Shawn Iwinski <shawn.iwinski@gmail.com> - 1.6.0-1
- Updated to 1.6.0
- Switched autoloader to php-composer(fedora/autoloader)