summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2013-03-19 17:55:27 +0100
committerRemi Collet <fedora@famillecollet.com>2013-03-19 17:55:27 +0100
commitffec025b1b448e93b69ab2ca1ff74a95301e6c1b (patch)
tree8e0d40b6f1893f3ad246620d5f79d91551e29473 /Makefile
parenta90b064525619dd4bb9c4cd99aea9467effe8fbf (diff)
php-JMSParser: backport for remi repo
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile10
1 files changed, 10 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..d095534
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,10 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+INCL1 := $(shell php-config --includes)
+INCL2 := -I $(shell php-config --include-dir)/sapi/embed
+LIBS := -lphp5 $(shell php-config --libs)
+
+include ../../common/Makefile
+
+tembed: tembed.c
+ gcc -Wall $(INCL1) $(INCL2) tembed.c $(LIBS) -o tembed