summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-05-26 07:59:50 +0200
committerRemi Collet <fedora@famillecollet.com>2015-05-26 07:59:50 +0200
commit80e8f30f7796361cb5958065f7adcffbb8572735 (patch)
treede34819f7cf56f82090a7dfb8bd513595acb2c20 /Makefile
parent5bdd9be2ddb4bbfc01313c66235ab0457647d71a (diff)
php-Analog: 1.0.6
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile10
1 files changed, 10 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..d095534
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,10 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+INCL1 := $(shell php-config --includes)
+INCL2 := -I $(shell php-config --include-dir)/sapi/embed
+LIBS := -lphp5 $(shell php-config --libs)
+
+include ../../common/Makefile
+
+tembed: tembed.c
+ gcc -Wall $(INCL1) $(INCL2) tembed.c $(LIBS) -o tembed