summaryrefslogtreecommitdiffstats
path: root/php-pecl-zmq.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-zmq.spec')
-rw-r--r--php-pecl-zmq.spec20
1 files changed, 14 insertions, 6 deletions
diff --git a/php-pecl-zmq.spec b/php-pecl-zmq.spec
index 4aaddc4..2162487 100644
--- a/php-pecl-zmq.spec
+++ b/php-pecl-zmq.spec
@@ -26,17 +26,17 @@
Summary: ZeroMQ messaging
Name: %{?sub_prefix}php-pecl-%{pecl_name}
Version: 1.1.3
-Release: 7%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 8%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD
URL: http://pecl.php.net/package/%{pecl_name}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
Patch0: https://patch-diff.githubusercontent.com/raw/mkoppanen/php-zmq/pull/170.patch
-Patch1: https://patch-diff.githubusercontent.com/raw/mkoppanen/php-zmq/pull/190.patch
+Patch1: https://patch-diff.githubusercontent.com/raw/mkoppanen/php-zmq/pull/195.patch
BuildRequires: %{?dtsprefix}gcc
# see https://github.com/mkoppanen/php-zmq/pull/190 build ok bug segfaults
-BuildRequires: %{?scl_prefix}php-devel < 7.3
+BuildRequires: %{?scl_prefix}php-devel
BuildRequires: %{?scl_prefix}php-pear
%if 0%{?fedora} >= 22 || 0%{?rhel} >= 7
# v4 in Fedora22+, EPEL-7
@@ -80,6 +80,10 @@ Obsoletes: php71w-pecl-%{pecl_name} <= %{version}
Obsoletes: php72u-pecl-%{pecl_name} <= %{version}
Obsoletes: php72w-pecl-%{pecl_name} <= %{version}
%endif
+%if "%{php_version}" > "7.3"
+Obsoletes: php73u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php73w-pecl-%{pecl_name} <= %{version}
+%endif
%endif
%if 0%{?fedora} < 20 && 0%{?rhel} < 7
@@ -108,7 +112,7 @@ mv %{pecl_name}-%{version} NTS
cd NTS
%patch0 -p1 -b .pr170
-%patch1 -p1 -b .pr190
+%patch1 -p1 -b .pr195
if pkg-config libzmq --atleast-version=4
then
@@ -218,7 +222,7 @@ cd NTS
%if %{with_tests}
: upstream test suite for NTS extension
-export TEST_PHP_ARGS="-n -d extension_dir=$PWD/modules -d extension=%{pecl_name}.so"
+export TEST_PHP_ARGS="-n -d extension=$PWD/modules/%{pecl_name}.so"
export REPORT_EXIT_STATUS=1
export NO_INTERACTION=1
export TEST_PHP_EXECUTABLE=%{__php}
@@ -234,7 +238,7 @@ cd ../ZTS
%if %{with_tests}
: upstream test suite for ZTS extension
-export TEST_PHP_ARGS="-n -d extension_dir=$PWD/modules -d extension=%{pecl_name}.so"
+export TEST_PHP_ARGS="-n -d extension=$PWD/modules/%{pecl_name}.so"
export TEST_PHP_EXECUTABLE=%{__ztsphp}
%{__ztsphp} -n run-tests.php --show-diff
%endif
@@ -256,6 +260,10 @@ export TEST_PHP_EXECUTABLE=%{__ztsphp}
%changelog
+* Fri Dec 14 2018 Remi Collet <remi@remirepo.net> - 1.1.3-8
+- add better patch for 7.3 from
+ https://github.com/mkoppanen/php-zmq/pull/195
+
* Wed Jun 27 2018 Remi Collet <remi@remirepo.net> - 1.1.3-7
- add patch for PHP 7.3 from
https://github.com/mkoppanen/php-zmq/pull/190