summaryrefslogtreecommitdiffstats
path: root/php-pecl-zip.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-zip.spec')
-rw-r--r--php-pecl-zip.spec24
1 files changed, 15 insertions, 9 deletions
diff --git a/php-pecl-zip.spec b/php-pecl-zip.spec
index 371e775..680c34a 100644
--- a/php-pecl-zip.spec
+++ b/php-pecl-zip.spec
@@ -18,9 +18,9 @@
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global pecl_name zip
-%global upstream_version 1.19.5
-#global upstream_prever dev
-#global upstream_lower DEV
+%global upstream_version 1.20.0
+%global upstream_prever dev
+%global upstream_lower DEV
%global libzip_version 1.8.0
@@ -137,9 +137,9 @@ sed -e 's/role="test"/role="src"/' \
cd NTS
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_ZIP_VERSION/{s/.* "//;s/".*$//;p}' php7/php_zip.h)
-if test "x${extver}" != "x%{upstream_version}%{?upstream_prever}"; then
+if test "x${extver}" != "x%{upstream_version}%{?upstream_prever}" -a "x${extver}" != "x%{upstream_version}-%{?upstream_prever}"; then
: Error: Upstream extension version is ${extver}, expecting %{upstream_version}%{?upstream_prever}.
- : exit 1
+ exit 1
fi
cd ..
@@ -201,6 +201,11 @@ done
%check
+OPT="-q --show-diff"
+%if "%{php_version}" > "7.4"
+OPT="$OPT %{?_smp_mflags}"
+%endif
+
cd NTS
: minimal load test of NTS extension
%{_bindir}/php --no-php-ini \
@@ -210,9 +215,8 @@ cd NTS
: upstream test suite for NTS extension
TEST_PHP_ARGS="-n -d extension_dir=$PWD/modules -d extension=%{pecl_name}.so" \
REPORT_EXIT_STATUS=1 \
-NO_INTERACTION=1 \
TEST_PHP_EXECUTABLE=%{_bindir}/php \
-%{_bindir}/php -n run-tests.php --show-diff
+%{_bindir}/php -n run-tests.php $OPT
%if %{with_zts}
cd ../ZTS
@@ -224,9 +228,8 @@ cd ../ZTS
: upstream test suite for ZTS extension
TEST_PHP_ARGS="-n -d extension_dir=$PWD/modules -d extension=%{pecl_name}.so" \
REPORT_EXIT_STATUS=1 \
-NO_INTERACTION=1 \
TEST_PHP_EXECUTABLE=%{_bindir}/zts-php \
-%{_bindir}/zts-php -n run-tests.php --show-diff
+%{_bindir}/zts-php -n run-tests.php $OPT
%endif
@@ -265,6 +268,9 @@ fi
%changelog
+* Wed Oct 6 2021 Remi Collet <remi@remirepo.net> - 1.20.0~DEV-1
+- test build for 1.20.0-dev
+
* Mon Sep 27 2021 Remi Collet <remi@remirepo.net> - 1.19.5-1
- update to 1.19.5