summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO11
-rw-r--r--REFLECTION25
-rw-r--r--php-pecl-zip.spec9
3 files changed, 35 insertions, 10 deletions
diff --git a/PHPINFO b/PHPINFO
index ed6bc73..8e00f0c 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,6 +2,11 @@
zip
Zip => enabled
-Zip version => 1.18.2
-Libzip headers version => 1.6.1
-Libzip library version => 1.6.1
+Zip version => 1.19.0
+Libzip headers version => 1.7.0
+Libzip library version => 1.7.0
+BZIP2 compression => Yes
+XZ compression => Yes
+AES-128 encryption => Yes
+AES-192 encryption => Yes
+AES-256 encryption => Yes
diff --git a/REFLECTION b/REFLECTION
index 5f8280e..0b8acbb 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #102 zip version 1.18.2 ] {
+Extension [ <persistent> extension #103 zip version 1.19.0 ] {
- Functions {
Function [ <internal:zip> function zip_open ] {
@@ -69,7 +69,7 @@ Extension [ <persistent> extension #102 zip version 1.18.2 ] {
- Classes [1] {
Class [ <internal:zip> class ZipArchive implements Countable ] {
- - Constants [98] {
+ - Constants [100] {
Constant [ public int CREATE ] { 1 }
Constant [ public int EXCL ] { 2 }
Constant [ public int CHECKCONS ] { 4 }
@@ -164,16 +164,33 @@ Extension [ <persistent> extension #102 zip version 1.18.2 ] {
Constant [ public int OPSYS_OS_X ] { 19 }
Constant [ public int OPSYS_DEFAULT ] { 3 }
Constant [ public int EM_NONE ] { 0 }
+ Constant [ public int EM_TRAD_PKWARE ] { 1 }
Constant [ public int EM_AES_128 ] { 257 }
Constant [ public int EM_AES_192 ] { 258 }
Constant [ public int EM_AES_256 ] { 259 }
- Constant [ public string LIBZIP_VERSION ] { 1.6.1 }
+ Constant [ public int EM_UNKNOWN ] { 65535 }
+ Constant [ public string LIBZIP_VERSION ] { 1.7.0 }
}
- Static properties [0] {
}
- - Static methods [0] {
+ - Static methods [2] {
+ Method [ <internal:zip> static public method isCompressionMethodSupported ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $method ]
+ Parameter #1 [ <optional> $encode ]
+ }
+ }
+
+ Method [ <internal:zip> static public method isEncryptionMethodSupported ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $method ]
+ Parameter #1 [ <optional> $encode ]
+ }
+ }
}
- Properties [6] {
diff --git a/php-pecl-zip.spec b/php-pecl-zip.spec
index c1ab070..11e70b8 100644
--- a/php-pecl-zip.spec
+++ b/php-pecl-zip.spec
@@ -19,8 +19,8 @@
%global pecl_name zip
%global upstream_version 1.19.0
-%global upstream_prever dev
-%global upstream_lower DEV
+#global upstream_prever dev
+#global upstream_lower DEV
%if "%{php_version}" < "5.6"
%global ini_name %{pecl_name}.ini
@@ -35,7 +35,7 @@ Summary: A ZIP archive management extension
Summary(fr): Une extension de gestion des ZIP
Name: %{?scl_prefix}php-pecl-zip
Version: %{upstream_version}%{?upstream_prever:~%{upstream_lower}}
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP
Group: Development/Languages
URL: https://pecl.php.net/package/zip
@@ -264,6 +264,9 @@ fi
#### TODO: SCLs on EL-8 still use libzip from default stream (7.2 => 1.5.1)
%changelog
+* Fri Jun 5 2020 Remi Collet <remi@remirepo.net> - 1.19.0-1
+- update to 1.19.0
+
* Fri Apr 10 2020 Remi Collet <remi@remirepo.net> - 1.19.0~DEV-2
- refresh for test suite