summaryrefslogtreecommitdiffstats
path: root/php-pecl-yar.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-yar.spec')
-rw-r--r--php-pecl-yar.spec12
1 files changed, 9 insertions, 3 deletions
diff --git a/php-pecl-yar.spec b/php-pecl-yar.spec
index 3576c5f..fd2b70f 100644
--- a/php-pecl-yar.spec
+++ b/php-pecl-yar.spec
@@ -30,12 +30,14 @@ Version: 2.3.0
Release: 0.14.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{pecl_name}-%{version}-%{gh_short}.tar.gz
%else
-Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: https://pecl.php.net/get/%{pecl_name}-%{version}.tgz
%endif
License: PHP
URL: https://pecl.php.net/package/%{pecl_name}
+Patch0: 0001-fix-172-provider-token-may-be-not-nul-terminated.patch
+
BuildRequires: %{?dtsprefix}gcc
BuildRequires: make
BuildRequires: curl-devel
@@ -96,6 +98,8 @@ sed -e 's/role="test"/role="src"/' \
-i package.xml
cd NTS
+%patch0 -p1 -b pr174
+
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_YAR_VERSION/{s/.* "//;s/".*$//;p}' php_yar.h)
if test "x${extver}" != "x%{version}%{?prever:-%{prever}}%{?gh_date:-dev}"; then
@@ -222,8 +226,6 @@ rm ?TS/tests/022.phpt
%if %{with tests}
cd NTS
-: erratic results
-#rm tests/047.phpt
: Create test configuration
export TEST_PHP_EXECUTABLE=%{__php}
@@ -255,6 +257,10 @@ export YAR_API_PORT=$(%{__php} -r 'echo 8960 + PHP_MAJOR_VERSION*100 + PHP_MINOR
%changelog
+* Thu May 5 2022 Remi Collet <remi@remirepo.net> - 2.3.0-2
+- add fix for https://github.com/laruence/yar/issues/172
+ using patch from https://github.com/laruence/yar/pull/174
+
* Mon Apr 25 2022 Remi Collet <remi@remirepo.net> - 2.3.0-1
- update to 2.3.0