summaryrefslogtreecommitdiffstats
path: root/php-pecl-yar.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-yar.spec')
-rw-r--r--php-pecl-yar.spec20
1 files changed, 10 insertions, 10 deletions
diff --git a/php-pecl-yar.spec b/php-pecl-yar.spec
index 8d55a6b..ea6a998 100644
--- a/php-pecl-yar.spec
+++ b/php-pecl-yar.spec
@@ -29,20 +29,18 @@
Summary: Light, concurrent RPC framework
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 2.0.2
+Version: 2.0.3
%if 0%{?gh_date:1}
Release: 0.12.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{pecl_name}-%{version}-%{gh_short}.tar.gz
%else
-Release: 3%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
%endif
License: PHP
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
-Patch0: 106.patch
-
BuildRequires: curl-devel
BuildRequires: %{?scl_prefix}php-devel > 7
BuildRequires: %{?scl_prefix}php-pear
@@ -111,7 +109,7 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
%setup -qc
%if 0%{?gh_date:1}
mv %{gh_project}-%{gh_commit} NTS
-mv NTS/package2.xml .
+mv NTS/package.xml .
%else
mv %{pecl_name}-%{version} NTS
%endif
@@ -119,10 +117,9 @@ mv %{pecl_name}-%{version} NTS
# Don't install/register tests
sed -e 's/role="test"/role="src"/' \
%{?_licensedir:-e '/LICENSE/s/role="doc"/role="src"/' } \
- -i package2.xml
+ -i package.xml
cd NTS
-%patch0 -p1 -b .pr106
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_YAR_VERSION/{s/.* "//;s/".*$//;p}' php_yar.h)
@@ -134,7 +131,7 @@ cd ..
sed -e 's:tools/yar_debug.inc:yar_debug.inc:' \
-e 's:tools/yar_debug.php:yar_debug:' \
- -i package2.xml
+ -i package.xml
%if %{with_zts}
# Duplicate source tree for NTS / ZTS build
@@ -187,7 +184,7 @@ make -C NTS install INSTALL_ROOT=%{buildroot}
install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
# Install XML package description
-install -D -m 644 package2.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
+install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
%if %{with_zts}
make -C ZTS install INSTALL_ROOT=%{buildroot}
@@ -201,7 +198,7 @@ install -Dpm 755 NTS/tools/yar_debug.php %{buildroot}%{_bindir}/yar_debug
# Documentation
cd NTS
-for i in $(grep 'role="doc"' ../package2.xml | sed -e 's/^.*name="//;s/".*$//')
+for i in $(grep 'role="doc"' ../package.xml | sed -e 's/^.*name="//;s/".*$//')
do install -Dpm 644 $i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
done
@@ -282,6 +279,9 @@ export YAR_API_PORT=8964
%changelog
+* Tue Aug 1 2017 Remi Collet <remi@remirepo.net> - 2.0.3-1
+- Update to 2.0.3
+
* Tue Jul 18 2017 Remi Collet <remi@remirepo.net> - 2.0.2-3
- rebuild for PHP 7.2.0beta1 new API