summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.gitignore2
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION136
-rw-r--r--php-pecl-yaf.spec39
4 files changed, 115 insertions, 64 deletions
diff --git a/.gitignore b/.gitignore
index 1ab5c4f..01f0400 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1,7 @@
+clog
package-*.xml
*.tgz
+*.tar.bz2
*.tar.gz
*.tar.xz
*.tar.xz.asc
diff --git a/PHPINFO b/PHPINFO
index 320bff2..fb40a9d 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,7 +2,7 @@
yaf
yaf support => enabled
-Version => 3.2.5
+Version => 3.3.0
Supports => http://pecl.php.net/package/yaf
Directive => Local Value => Master Value
diff --git a/REFLECTION b/REFLECTION
index e877cb7..59480d4 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #114 yaf version 3.2.5 ] {
+Extension [ <persistent> extension #119 yaf version 3.3.0 ] {
- Dependencies {
Dependency [ spl (Required) ]
@@ -37,7 +37,7 @@ Extension [ <persistent> extension #114 yaf version 3.2.5 ] {
}
- Constants [13] {
- Constant [ string YAF_VERSION ] { 3.2.5 }
+ Constant [ string YAF_VERSION ] { 3.3.0 }
Constant [ string YAF_ENVIRON ] { product }
Constant [ int YAF_ERR_STARTUP_FAILED ] { 512 }
Constant [ int YAF_ERR_ROUTE_FAILED ] { 513 }
@@ -204,6 +204,9 @@ Extension [ <persistent> extension #114 yaf version 3.2.5 ] {
- Methods [25] {
Method [ <internal:yaf, ctor> private method __construct ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:yaf> public method enableView ] {
@@ -293,7 +296,7 @@ Extension [ <persistent> extension #114 yaf version 3.2.5 ] {
- Parameters [2] {
Parameter #0 [ <required> $callback ]
- Parameter #1 [ <required> $error_types ]
+ Parameter #1 [ <optional> $error_types ]
}
}
@@ -328,14 +331,14 @@ Extension [ <persistent> extension #114 yaf version 3.2.5 ] {
Method [ <internal:yaf> public method autoRender ] {
- Parameters [1] {
- Parameter #0 [ <required> $flag ]
+ Parameter #0 [ <optional> $flag ]
}
}
Method [ <internal:yaf> public method flushInstantly ] {
- Parameters [1] {
- Parameter #0 [ <required> $flag ]
+ Parameter #0 [ <optional> $flag ]
}
}
@@ -550,7 +553,7 @@ Extension [ <persistent> extension #114 yaf version 3.2.5 ] {
Method [ <internal:yaf> public method getQuery ] {
- Parameters [2] {
- Parameter #0 [ <required> $name ]
+ Parameter #0 [ <optional> $name ]
Parameter #1 [ <optional> $default ]
}
}
@@ -558,7 +561,7 @@ Extension [ <persistent> extension #114 yaf version 3.2.5 ] {
Method [ <internal:yaf> public method getRequest ] {
- Parameters [2] {
- Parameter #0 [ <required> $name ]
+ Parameter #0 [ <optional> $name ]
Parameter #1 [ <optional> $default ]
}
}
@@ -566,7 +569,7 @@ Extension [ <persistent> extension #114 yaf version 3.2.5 ] {
Method [ <internal:yaf> public method getPost ] {
- Parameters [2] {
- Parameter #0 [ <required> $name ]
+ Parameter #0 [ <optional> $name ]
Parameter #1 [ <optional> $default ]
}
}
@@ -574,23 +577,21 @@ Extension [ <persistent> extension #114 yaf version 3.2.5 ] {
Method [ <internal:yaf> public method getCookie ] {
- Parameters [2] {
- Parameter #0 [ <required> $name ]
+ Parameter #0 [ <optional> $name ]
Parameter #1 [ <optional> $default ]
}
}
Method [ <internal:yaf> public method getRaw ] {
- - Parameters [2] {
- Parameter #0 [ <required> $name ]
- Parameter #1 [ <optional> $default ]
+ - Parameters [0] {
}
}
Method [ <internal:yaf> public method getFiles ] {
- Parameters [2] {
- Parameter #0 [ <required> $name ]
+ Parameter #0 [ <optional> $name ]
Parameter #1 [ <optional> $default ]
}
}
@@ -598,7 +599,7 @@ Extension [ <persistent> extension #114 yaf version 3.2.5 ] {
Method [ <internal:yaf> public method get ] {
- Parameters [2] {
- Parameter #0 [ <required> $name ]
+ Parameter #0 [ <optional> $name ]
Parameter #1 [ <optional> $default ]
}
}
@@ -606,7 +607,7 @@ Extension [ <persistent> extension #114 yaf version 3.2.5 ] {
Method [ <internal:yaf> public method getServer ] {
- Parameters [2] {
- Parameter #0 [ <required> $name ]
+ Parameter #0 [ <optional> $name ]
Parameter #1 [ <optional> $default ]
}
}
@@ -614,7 +615,7 @@ Extension [ <persistent> extension #114 yaf version 3.2.5 ] {
Method [ <internal:yaf> public method getEnv ] {
- Parameters [2] {
- Parameter #0 [ <required> $name ]
+ Parameter #0 [ <optional> $name ]
Parameter #1 [ <optional> $default ]
}
}
@@ -630,7 +631,7 @@ Extension [ <persistent> extension #114 yaf version 3.2.5 ] {
Method [ <internal:yaf> public method getParam ] {
- Parameters [2] {
- Parameter #0 [ <required> $name ]
+ Parameter #0 [ <optional> $name ]
Parameter #1 [ <optional> $default ]
}
}
@@ -777,6 +778,11 @@ Extension [ <persistent> extension #114 yaf version 3.2.5 ] {
- Methods [40] {
Method [ <internal:yaf, ctor> public method __construct ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <optional> $request_uri ]
+ Parameter #1 [ <optional> $base_uri ]
+ }
}
Method [ <internal:yaf, inherits Yaf_Request_Abstract> public method isGet ] {
@@ -836,7 +842,7 @@ Extension [ <persistent> extension #114 yaf version 3.2.5 ] {
Method [ <internal:yaf, inherits Yaf_Request_Abstract> public method getQuery ] {
- Parameters [2] {
- Parameter #0 [ <required> $name ]
+ Parameter #0 [ <optional> $name ]
Parameter #1 [ <optional> $default ]
}
}
@@ -844,7 +850,7 @@ Extension [ <persistent> extension #114 yaf version 3.2.5 ] {
Method [ <internal:yaf, inherits Yaf_Request_Abstract> public method getRequest ] {
- Parameters [2] {
- Parameter #0 [ <required> $name ]
+ Parameter #0 [ <optional> $name ]
Parameter #1 [ <optional> $default ]
}
}
@@ -852,7 +858,7 @@ Extension [ <persistent> extension #114 yaf version 3.2.5 ] {
Method [ <internal:yaf, inherits Yaf_Request_Abstract> public method getPost ] {
- Parameters [2] {
- Parameter #0 [ <required> $name ]
+ Parameter #0 [ <optional> $name ]
Parameter #1 [ <optional> $default ]
}
}
@@ -860,23 +866,21 @@ Extension [ <persistent> extension #114 yaf version 3.2.5 ] {
Method [ <internal:yaf, inherits Yaf_Request_Abstract> public method getCookie ] {
- Parameters [2] {
- Parameter #0 [ <required> $name ]
+ Parameter #0 [ <optional> $name ]
Parameter #1 [ <optional> $default ]
}
}
Method [ <internal:yaf, inherits Yaf_Request_Abstract> public method getRaw ] {
- - Parameters [2] {
- Parameter #0 [ <required> $name ]
- Parameter #1 [ <optional> $default ]
+ - Parameters [0] {
}
}
Method [ <internal:yaf, inherits Yaf_Request_Abstract> public method getFiles ] {
- Parameters [2] {
- Parameter #0 [ <required> $name ]
+ Parameter #0 [ <optional> $name ]
Parameter #1 [ <optional> $default ]
}
}
@@ -884,7 +888,7 @@ Extension [ <persistent> extension #114 yaf version 3.2.5 ] {
Method [ <internal:yaf, inherits Yaf_Request_Abstract> public method get ] {
- Parameters [2] {
- Parameter #0 [ <required> $name ]
+ Parameter #0 [ <optional> $name ]
Parameter #1 [ <optional> $default ]
}
}
@@ -892,7 +896,7 @@ Extension [ <persistent> extension #114 yaf version 3.2.5 ] {
Method [ <internal:yaf, inherits Yaf_Request_Abstract> public method getServer ] {
- Parameters [2] {
- Parameter #0 [ <required> $name ]
+ Parameter #0 [ <optional> $name ]
Parameter #1 [ <optional> $default ]
}
}
@@ -900,7 +904,7 @@ Extension [ <persistent> extension #114 yaf version 3.2.5 ] {
Method [ <internal:yaf, inherits Yaf_Request_Abstract> public method getEnv ] {
- Parameters [2] {
- Parameter #0 [ <required> $name ]
+ Parameter #0 [ <optional> $name ]
Parameter #1 [ <optional> $default ]
}
}
@@ -916,7 +920,7 @@ Extension [ <persistent> extension #114 yaf version 3.2.5 ] {
Method [ <internal:yaf, inherits Yaf_Request_Abstract> public method getParam ] {
- Parameters [2] {
- Parameter #0 [ <required> $name ]
+ Parameter #0 [ <optional> $name ]
Parameter #1 [ <optional> $default ]
}
}
@@ -1065,9 +1069,20 @@ Extension [ <persistent> extension #114 yaf version 3.2.5 ] {
- Methods [40] {
Method [ <internal:yaf, ctor> public method __construct ] {
+
+ - Parameters [5] {
+ Parameter #0 [ <optional> $method ]
+ Parameter #1 [ <optional> $module ]
+ Parameter #2 [ <optional> $controller ]
+ Parameter #3 [ <optional> $action ]
+ Parameter #4 [ <optional> $params ]
+ }
}
Method [ <internal:yaf, overwrites Yaf_Request_Abstract, prototype Yaf_Request_Abstract> public method isXmlHttpRequest ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:yaf, inherits Yaf_Request_Abstract> public method isGet ] {
@@ -1121,7 +1136,7 @@ Extension [ <persistent> extension #114 yaf version 3.2.5 ] {
Method [ <internal:yaf, inherits Yaf_Request_Abstract> public method getQuery ] {
- Parameters [2] {
- Parameter #0 [ <required> $name ]
+ Parameter #0 [ <optional> $name ]
Parameter #1 [ <optional> $default ]
}
}
@@ -1129,7 +1144,7 @@ Extension [ <persistent> extension #114 yaf version 3.2.5 ] {
Method [ <internal:yaf, inherits Yaf_Request_Abstract> public method getRequest ] {
- Parameters [2] {
- Parameter #0 [ <required> $name ]
+ Parameter #0 [ <optional> $name ]
Parameter #1 [ <optional> $default ]
}
}
@@ -1137,7 +1152,7 @@ Extension [ <persistent> extension #114 yaf version 3.2.5 ] {
Method [ <internal:yaf, inherits Yaf_Request_Abstract> public method getPost ] {
- Parameters [2] {
- Parameter #0 [ <required> $name ]
+ Parameter #0 [ <optional> $name ]
Parameter #1 [ <optional> $default ]
}
}
@@ -1145,23 +1160,21 @@ Extension [ <persistent> extension #114 yaf version 3.2.5 ] {
Method [ <internal:yaf, inherits Yaf_Request_Abstract> public method getCookie ] {
- Parameters [2] {
- Parameter #0 [ <required> $name ]
+ Parameter #0 [ <optional> $name ]
Parameter #1 [ <optional> $default ]
}
}
Method [ <internal:yaf, inherits Yaf_Request_Abstract> public method getRaw ] {
- - Parameters [2] {
- Parameter #0 [ <required> $name ]
- Parameter #1 [ <optional> $default ]
+ - Parameters [0] {
}
}
Method [ <internal:yaf, inherits Yaf_Request_Abstract> public method getFiles ] {
- Parameters [2] {
- Parameter #0 [ <required> $name ]
+ Parameter #0 [ <optional> $name ]
Parameter #1 [ <optional> $default ]
}
}
@@ -1169,7 +1182,7 @@ Extension [ <persistent> extension #114 yaf version 3.2.5 ] {
Method [ <internal:yaf, inherits Yaf_Request_Abstract> public method get ] {
- Parameters [2] {
- Parameter #0 [ <required> $name ]
+ Parameter #0 [ <optional> $name ]
Parameter #1 [ <optional> $default ]
}
}
@@ -1177,7 +1190,7 @@ Extension [ <persistent> extension #114 yaf version 3.2.5 ] {
Method [ <internal:yaf, inherits Yaf_Request_Abstract> public method getServer ] {
- Parameters [2] {
- Parameter #0 [ <required> $name ]
+ Parameter #0 [ <optional> $name ]
Parameter #1 [ <optional> $default ]
}
}
@@ -1185,7 +1198,7 @@ Extension [ <persistent> extension #114 yaf version 3.2.5 ] {
Method [ <internal:yaf, inherits Yaf_Request_Abstract> public method getEnv ] {
- Parameters [2] {
- Parameter #0 [ <required> $name ]
+ Parameter #0 [ <optional> $name ]
Parameter #1 [ <optional> $default ]
}
}
@@ -1201,7 +1214,7 @@ Extension [ <persistent> extension #114 yaf version 3.2.5 ] {
Method [ <internal:yaf, inherits Yaf_Request_Abstract> public method getParam ] {
- Parameters [2] {
- Parameter #0 [ <required> $name ]
+ Parameter #0 [ <optional> $name ]
Parameter #1 [ <optional> $default ]
}
}
@@ -1355,6 +1368,9 @@ Extension [ <persistent> extension #114 yaf version 3.2.5 ] {
}
Method [ <internal:yaf> public method __toString ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:yaf> public method setBody ] {
@@ -1469,6 +1485,9 @@ Extension [ <persistent> extension #114 yaf version 3.2.5 ] {
}
Method [ <internal:yaf, inherits Yaf_Response_Abstract> public method __toString ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:yaf, inherits Yaf_Response_Abstract> public method setBody ] {
@@ -1534,6 +1553,9 @@ Extension [ <persistent> extension #114 yaf version 3.2.5 ] {
}
Method [ <internal:yaf, inherits Yaf_Response_Abstract> public method __toString ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:yaf, inherits Yaf_Response_Abstract> public method setBody ] {
@@ -1722,12 +1744,21 @@ Extension [ <persistent> extension #114 yaf version 3.2.5 ] {
- Methods [18] {
Method [ <internal:yaf> abstract public method execute ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:yaf> public method getController ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:yaf> public method getControllerName ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:yaf, inherits Yaf_Controller_Abstract, ctor> public method __construct ] {
@@ -2012,7 +2043,7 @@ Extension [ <persistent> extension #114 yaf version 3.2.5 ] {
}
}
- Method [ <internal:yaf, overwrites Yaf_Config_Abstract, prototype Yaf_Config_Abstract> public method offsetSet ] {
+ Method [ <internal:yaf, overwrites Yaf_Config_Abstract, prototype ArrayAccess> public method offsetSet ] {
- Parameters [2] {
Parameter #0 [ <required> $name ]
@@ -2152,7 +2183,7 @@ Extension [ <persistent> extension #114 yaf version 3.2.5 ] {
}
}
- Method [ <internal:yaf, overwrites Yaf_Config_Abstract, prototype Yaf_Config_Abstract> public method offsetSet ] {
+ Method [ <internal:yaf, overwrites Yaf_Config_Abstract, prototype ArrayAccess> public method offsetSet ] {
- Parameters [2] {
Parameter #0 [ <required> $name ]
@@ -2424,12 +2455,25 @@ Extension [ <persistent> extension #114 yaf version 3.2.5 ] {
}
Method [ <internal:yaf> public method addRoute ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $name ]
+ Parameter #1 [ <required> $route ]
+ }
}
Method [ <internal:yaf> public method addConfig ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $config ]
+ }
}
Method [ <internal:yaf> public method route ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $request ]
+ }
}
Method [ <internal:yaf> public method getRoute ] {
@@ -2859,6 +2903,9 @@ Extension [ <persistent> extension #114 yaf version 3.2.5 ] {
- Methods [1] {
Method [ <internal:yaf, ctor> private method __construct ] {
+
+ - Parameters [0] {
+ }
}
}
}
@@ -2884,6 +2931,9 @@ Extension [ <persistent> extension #114 yaf version 3.2.5 ] {
- Methods [21] {
Method [ <internal:yaf, ctor> private method __construct ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:yaf> public method start ] {
diff --git a/php-pecl-yaf.spec b/php-pecl-yaf.spec
index 6efe4b4..d201a47 100644
--- a/php-pecl-yaf.spec
+++ b/php-pecl-yaf.spec
@@ -1,6 +1,6 @@
# remirepo spec file for php-pecl-yaf
#
-# Copyright (c) 2012-2020 Remi Collet
+# Copyright (c) 2012-2021 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -26,7 +26,7 @@
Summary: Yet Another Framework
Name: %{?sub_prefix}php-pecl-yaf
-Version: 3.2.5
+Version: 3.3.0
%if 0%{?gh_date:1}
Release: 0.12.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{pecl_name}-%{version}-%{gh_short}.tar.gz
@@ -38,11 +38,13 @@ License: PHP
URL: https://pecl.php.net/package/yaf
Source1: %{pecl_name}.ini
+BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
-BuildRequires: %{?scl_prefix}php-devel >= 7
+BuildRequires: %{?scl_prefix}php-devel >= 7.0
BuildRequires: %{?scl_prefix}php-pear
-BuildRequires: %{?scl_prefix}php-json
BuildRequires: pcre-devel
+# for tests
+BuildRequires: %{?scl_prefix}php-json
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
@@ -57,26 +59,17 @@ Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{relea
Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
%endif
-%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
+%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
# Other third party repo stuff
-%if "%{php_version}" > "7.2"
-Obsoletes: php72u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php72w-pecl-%{pecl_name} <= %{version}
-%endif
%if "%{php_version}" > "7.3"
Obsoletes: php73-pecl-%{pecl_name} <= %{version}
-Obsoletes: php73w-pecl-%{pecl_name} <= %{version}
%endif
%if "%{php_version}" > "7.4"
Obsoletes: php74-pecl-%{pecl_name} <= %{version}
-Obsoletes: php74w-pecl-%{pecl_name} <= %{version}
%endif
+%if "%{php_version}" > "8.0"
+Obsoletes: php80-pecl-%{pecl_name} <= %{version}
%endif
-
-%if 0%{?fedora} < 20 && 0%{?rhel} < 7
-# Filter shared private
-%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
-%{?filter_setup}
%endif
@@ -156,15 +149,18 @@ done
%check
+OPTS="-n"
+[ -f %{php_extdir}/json.so ] && OPTS="$OPTS -d extension=json.so"
+
cd NTS
: Minimal load test for NTS extension
%{__php} --no-php-ini \
--define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
- --modules | grep %{pecl_name}
+ --modules | grep '^%{pecl_name}$'
: Upstream test suite for NTS extension
TEST_PHP_EXECUTABLE=%{__php} \
-TEST_PHP_ARGS="-n -d extension=json.so -d extension=$PWD/modules/%{pecl_name}.so" \
+TEST_PHP_ARGS="$OPTS -d extension=$PWD/modules/%{pecl_name}.so" \
NO_INTERACTION=1 \
REPORT_EXIT_STATUS=1 \
%{__php} -n run-tests.php --show-diff
@@ -175,11 +171,11 @@ cd ../ZTS
: Minimal load test for ZTS extension
%{__ztsphp} --no-php-ini \
--define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
- --modules | grep %{pecl_name}
+ --modules | grep '^%{pecl_name}$'
: Upstream test suite for NTS extension
TEST_PHP_EXECUTABLE=%{__ztsphp} \
-TEST_PHP_ARGS="-n -d extension=json.so -d extension=$PWD/modules/%{pecl_name}.so" \
+TEST_PHP_ARGS="$OPTS -d extension=$PWD/modules/%{pecl_name}.so" \
NO_INTERACTION=1 \
REPORT_EXIT_STATUS=1 \
%{__ztsphp} -n run-tests.php --show-diff
@@ -221,6 +217,9 @@ fi
%changelog
+* Wed Jan 6 2021 Remi Collet <remi@remirepo.net> - 3.3.0-1
+- update to 3.3.0
+
* Thu Jun 11 2020 Remi Collet <remi@remirepo.net> - 3.2.5-1
- update to 3.2.5