summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-10-25 08:05:29 +0200
committerRemi Collet <fedora@famillecollet.com>2014-10-25 08:05:29 +0200
commitc169857f2ab21fa7dec9924d1916fe72fe20b0f0 (patch)
treecdf845a78a76c3e1bfb7ed819984d41122ae327c
parentf33415f84c541904518986dc71d132111738b3c3 (diff)
php-pecl-yaf: 2.3.3
-rw-r--r--REFLECTION21
-rw-r--r--php-pecl-yaf.spec23
-rw-r--r--yaf-git.patch55
3 files changed, 22 insertions, 77 deletions
diff --git a/REFLECTION b/REFLECTION
index f29bdf7..4e459b8 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #148 yaf version 2.3.2 ] {
+Extension [ <persistent> extension #160 yaf version 2.3.3 ] {
- Dependencies {
Dependency [ spl (Required) ]
@@ -43,7 +43,7 @@ Extension [ <persistent> extension #148 yaf version 2.3.2 ] {
}
- Constants [12] {
- Constant [ string PHP_YAF_VERSION ] { 2.3.2 }
+ Constant [ string YAF_VERSION ] { 2.3.3 }
Constant [ string YAF_ENVIRON ] { product }
Constant [ integer YAF_ERR_STARTUP_FAILED ] { 512 }
Constant [ integer YAF_ERR_ROUTE_FAILED ] { 513 }
@@ -2242,7 +2242,7 @@ Extension [ <persistent> extension #148 yaf version 2.3.2 ] {
Method [ <internal:yaf> abstract public method assemble ] {
- Parameters [2] {
- Parameter #0 [ <required> array $mvc ]
+ Parameter #0 [ <required> array $info ]
Parameter #1 [ <optional> array or NULL $query ]
}
}
@@ -2281,7 +2281,7 @@ Extension [ <persistent> extension #148 yaf version 2.3.2 ] {
Method [ <internal:yaf, prototype Yaf_Route_Interface> public method assemble ] {
- Parameters [2] {
- Parameter #0 [ <required> array $mvc ]
+ Parameter #0 [ <required> array $info ]
Parameter #1 [ <optional> array or NULL $query ]
}
}
@@ -2325,7 +2325,7 @@ Extension [ <persistent> extension #148 yaf version 2.3.2 ] {
Method [ <internal:yaf, prototype Yaf_Route_Interface> public method assemble ] {
- Parameters [2] {
- Parameter #0 [ <required> array $mvc ]
+ Parameter #0 [ <required> array $info ]
Parameter #1 [ <optional> array or NULL $query ]
}
}
@@ -2365,7 +2365,7 @@ Extension [ <persistent> extension #148 yaf version 2.3.2 ] {
Method [ <internal:yaf, prototype Yaf_Route_Interface> public method assemble ] {
- Parameters [2] {
- Parameter #0 [ <required> array $mvc ]
+ Parameter #0 [ <required> array $info ]
Parameter #1 [ <optional> array or NULL $query ]
}
}
@@ -2383,11 +2383,10 @@ Extension [ <persistent> extension #148 yaf version 2.3.2 ] {
- Static methods [0] {
}
- - Properties [4] {
+ - Properties [3] {
Property [ <default> protected $_route ]
Property [ <default> protected $_default ]
Property [ <default> protected $_verify ]
- Property [ <default> protected $_reverse ]
}
- Methods [3] {
@@ -2410,7 +2409,7 @@ Extension [ <persistent> extension #148 yaf version 2.3.2 ] {
Method [ <internal:yaf, overwrites Yaf_Route_Interface, prototype Yaf_Route_Interface> public method assemble ] {
- Parameters [2] {
- Parameter #0 [ <required> array $mvc ]
+ Parameter #0 [ <required> array $info ]
Parameter #1 [ <optional> array or NULL $query ]
}
}
@@ -2458,7 +2457,7 @@ Extension [ <persistent> extension #148 yaf version 2.3.2 ] {
Method [ <internal:yaf, overwrites Yaf_Route_Interface, prototype Yaf_Route_Interface> public method assemble ] {
- Parameters [2] {
- Parameter #0 [ <required> array $mvc ]
+ Parameter #0 [ <required> array $info ]
Parameter #1 [ <optional> array or NULL $query ]
}
}
@@ -2500,7 +2499,7 @@ Extension [ <persistent> extension #148 yaf version 2.3.2 ] {
Method [ <internal:yaf, prototype Yaf_Route_Interface> public method assemble ] {
- Parameters [2] {
- Parameter #0 [ <required> array $mvc ]
+ Parameter #0 [ <required> array $info ]
Parameter #1 [ <optional> array or NULL $query ]
}
}
diff --git a/php-pecl-yaf.spec b/php-pecl-yaf.spec
index 52a63e0..cd141ca 100644
--- a/php-pecl-yaf.spec
+++ b/php-pecl-yaf.spec
@@ -21,16 +21,14 @@
Summary: Yet Another Framework
Name: %{?scl_prefix}php-pecl-yaf
-Version: 2.3.2
-Release: 4%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Version: 2.3.3
+Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: PHP
Group: Development/Languages
URL: http://pecl.php.net/package/yaf
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
Source1: %{pecl_name}.ini
-Patch0: %{pecl_name}-git.patch
-
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildRequires: %{?scl_prefix}php-devel >= 5.2.0
BuildRequires: %{?scl_prefix}php-pear
@@ -40,6 +38,7 @@ Requires(post): %{__pecl}
Requires(postun): %{__pecl}
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
+%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
@@ -73,14 +72,17 @@ Obsoletes: php56w-pecl-%{pecl_name} <= %{version}
The Yet Another Framework (Yaf) extension is a PHP framework that is used
to develop web applications.
+Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection}.
+
%prep
%setup -q -c
mv %{pecl_name}-%{version} NTS
-cd NTS
-%patch0 -p1 -b .upstream
+# Don't install/register tests
+sed -e 's/role="test"/role="src"/' -i package.xml
+cd NTS
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_YAF_VERSION/{s/.*\t"//;s/".*$//;p}' php_yaf.h )
if test "x${extver}" != "x%{version}"; then
@@ -124,10 +126,7 @@ install -D -m 644 %{SOURCE1} %{buildroot}%{php_ztsinidir}/%{ini_name}
# Install the package XML file
install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
-# Test & Documentation
-for i in $(grep 'role="test"' package.xml | sed -e 's/^.*name="//;s/".*$//')
-do install -Dpm 644 NTS/$i %{buildroot}%{pecl_testdir}/%{pecl_name}/$i
-done
+# Documentation
for i in $(grep 'role="doc"' package.xml | sed -e 's/^.*name="//;s/".*$//')
do install -Dpm 644 NTS/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
done
@@ -180,7 +179,6 @@ rm -rf %{buildroot}
%files
%defattr(-,root,root,-)
%doc %{pecl_docdir}/%{pecl_name}
-%doc %{pecl_testdir}/%{pecl_name}
%config(noreplace) %{php_inidir}/%{ini_name}
%{php_extdir}/%{pecl_name}.so
@@ -193,6 +191,9 @@ rm -rf %{buildroot}
%changelog
+* Sat Oct 25 2014 Remi Collet <remi@fedoraproject.org> - 2.3.3-1
+- Update to 2.3.3
+
* Tue Aug 26 2014 Remi Collet <rcollet@redhat.com> - 2.3.2-4
- improve SCL build
diff --git a/yaf-git.patch b/yaf-git.patch
deleted file mode 100644
index 7453ca4..0000000
--- a/yaf-git.patch
+++ /dev/null
@@ -1,55 +0,0 @@
-From d5878063d8c654419f27d958134a1bf220e2344b Mon Sep 17 00:00:00 2001
-From: Xinchen Hui <laruence@gmail.com>
-Date: Sun, 1 Jun 2014 19:57:31 +0800
-Subject: [PATCH] Fixed bug #67291 (Compile Error with PHP-5.6)
-
----
- yaf_config.c | 18 ++++++++++++------
- 1 file changed, 12 insertions(+), 6 deletions(-)
-
-diff --git a/yaf_config.c b/yaf_config.c
-index e4a56b9..c1f1997 100644
---- a/yaf_config.c
-+++ b/yaf_config.c
-@@ -77,8 +77,10 @@ static void yaf_config_zval_dtor(zval **value) {
- pefree((*value)->value.str.val, 1);
- pefree(*value, 1);
- break;
-- case IS_ARRAY:
-- case IS_CONSTANT_ARRAY: {
-+#if ((PHP_MAJOR_VERSION == 5) && (PHP_MINOR_VERSION < 6))
-+ case IS_CONSTANT_ARRAY:
-+#endif
-+ case IS_ARRAY: {
- zend_hash_destroy((*value)->value.ht);
- pefree((*value)->value.ht, 1);
- pefree(*value, 1);
-@@ -179,8 +181,10 @@ static zval * yaf_config_ini_zval_persistent(zval *zvalue TSRMLS_DC) {
- ret->value.str.val = pestrndup(zvalue->value.str.val, zvalue->value.str.len, 1);
- ret->value.str.len = zvalue->value.str.len;
- break;
-- case IS_ARRAY:
-- case IS_CONSTANT_ARRAY: {
-+#if ((PHP_MAJOR_VERSION == 5) && (PHP_MINOR_VERSION < 6))
-+ case IS_CONSTANT_ARRAY:
-+#endif
-+ case IS_ARRAY: {
- HashTable *tmp_ht, *original_ht = zvalue->value.ht;
-
- tmp_ht = (HashTable *)pemalloc(sizeof(HashTable), 1);
-@@ -218,8 +222,10 @@ static zval * yaf_config_ini_zval_losable(zval *zvalue TSRMLS_DC) {
- CHECK_ZVAL_STRING(zvalue);
- ZVAL_STRINGL(ret, zvalue->value.str.val, zvalue->value.str.len, 1);
- break;
-- case IS_ARRAY:
-- case IS_CONSTANT_ARRAY: {
-+#if ((PHP_MAJOR_VERSION == 5) && (PHP_MINOR_VERSION < 6))
-+ case IS_CONSTANT_ARRAY:
-+#endif
-+ case IS_ARRAY: {
- HashTable *original_ht = zvalue->value.ht;
- array_init(ret);
- yaf_config_copy_losable(Z_ARRVAL_P(ret), original_ht TSRMLS_CC);
---
-1.9.3
-