summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-09-06 14:21:31 +0200
committerRemi Collet <fedora@famillecollet.com>2015-09-06 14:21:31 +0200
commit9f9ec279521c50bf471001de8ce4b386f27958e9 (patch)
treebccb17db1b5be8640d31a3459333f74ab745eb0f
parent0e204a14c3cb554e961a77bfba01f739021d0c9e (diff)
php-pecl-yaf: 2.3.5
-rw-r--r--REFLECTION4
-rw-r--r--REFLECTION-DEV255
-rw-r--r--php-pecl-yaf-dev.spec11
-rw-r--r--php-pecl-yaf.spec9
4 files changed, 156 insertions, 123 deletions
diff --git a/REFLECTION b/REFLECTION
index 4fc3b09..41119bf 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #176 yaf version 2.3.4 ] {
+Extension [ <persistent> extension #178 yaf version 2.3.5 ] {
- Dependencies {
Dependency [ spl (Required) ]
@@ -43,7 +43,7 @@ Extension [ <persistent> extension #176 yaf version 2.3.4 ] {
}
- Constants [12] {
- Constant [ string YAF_VERSION ] { 2.3.4 }
+ Constant [ string YAF_VERSION ] { 2.3.5 }
Constant [ string YAF_ENVIRON ] { product }
Constant [ integer YAF_ERR_STARTUP_FAILED ] { 512 }
Constant [ integer YAF_ERR_ROUTE_FAILED ] { 513 }
diff --git a/REFLECTION-DEV b/REFLECTION-DEV
index 774469e..30baa1d 100644
--- a/REFLECTION-DEV
+++ b/REFLECTION-DEV
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #90 yaf version 3.0.0-dev ] {
+Extension [ <persistent> extension #96 yaf version 3.0.0-dev ] {
- Dependencies {
Dependency [ spl (Required) ]
@@ -28,9 +28,6 @@ Extension [ <persistent> extension #90 yaf version 3.0.0-dev ] {
Entry [ yaf.name_separator <ALL> ]
Current = ''
}
- Entry [ yaf.cache_config <SYSTEM> ]
- Current = '0'
- }
Entry [ yaf.st_compatible <ALL> ]
Current = '0'
}
@@ -2804,7 +2801,7 @@ Extension [ <persistent> extension #90 yaf version 3.0.0-dev ] {
}
}
- Class [ <internal:yaf> class Yaf_Exception extends Exception ] {
+ Class [ <internal:yaf> class Yaf_Exception extends Exception implements Throwable ] {
- Constants [0] {
}
@@ -2823,8 +2820,8 @@ Extension [ <persistent> extension #90 yaf version 3.0.0-dev ] {
Property [ <default> protected $previous ]
}
- - Methods [9] {
- Method [ <internal:Core, inherits BaseException, ctor> public method __construct ] {
+ - Methods [10] {
+ Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
- Parameters [3] {
Parameter #0 [ <optional> $message ]
@@ -2833,33 +2830,36 @@ Extension [ <persistent> extension #90 yaf version 3.0.0-dev ] {
}
}
- Method [ <internal:Core, inherits BaseException> final public method getMessage ] {
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
}
- Method [ <internal:Core, inherits BaseException> final public method getCode ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
}
- Method [ <internal:Core, inherits BaseException> final public method getFile ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
}
- Method [ <internal:Core, inherits BaseException> final public method getLine ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
}
- Method [ <internal:Core, inherits BaseException> final public method getTrace ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
}
- Method [ <internal:Core, inherits BaseException> final public method getPrevious ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
}
- Method [ <internal:Core, inherits BaseException> final public method getTraceAsString ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
}
- Method [ <internal:Core, inherits BaseException> public method __toString ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
}
}
}
- Class [ <internal:yaf> class Yaf_Exception_StartupError extends Yaf_Exception ] {
+ Class [ <internal:yaf> class Yaf_Exception_StartupError extends Yaf_Exception implements Throwable ] {
- Constants [0] {
}
@@ -2878,8 +2878,8 @@ Extension [ <persistent> extension #90 yaf version 3.0.0-dev ] {
Property [ <default> protected $previous ]
}
- - Methods [9] {
- Method [ <internal:Core, inherits BaseException, ctor> public method __construct ] {
+ - Methods [10] {
+ Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
- Parameters [3] {
Parameter #0 [ <optional> $message ]
@@ -2888,33 +2888,36 @@ Extension [ <persistent> extension #90 yaf version 3.0.0-dev ] {
}
}
- Method [ <internal:Core, inherits BaseException> final public method getMessage ] {
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
}
- Method [ <internal:Core, inherits BaseException> final public method getCode ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
}
- Method [ <internal:Core, inherits BaseException> final public method getFile ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
}
- Method [ <internal:Core, inherits BaseException> final public method getLine ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
}
- Method [ <internal:Core, inherits BaseException> final public method getTrace ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
}
- Method [ <internal:Core, inherits BaseException> final public method getPrevious ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
}
- Method [ <internal:Core, inherits BaseException> final public method getTraceAsString ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
}
- Method [ <internal:Core, inherits BaseException> public method __toString ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
}
}
}
- Class [ <internal:yaf> class Yaf_Exception_RouterFailed extends Yaf_Exception ] {
+ Class [ <internal:yaf> class Yaf_Exception_RouterFailed extends Yaf_Exception implements Throwable ] {
- Constants [0] {
}
@@ -2933,8 +2936,8 @@ Extension [ <persistent> extension #90 yaf version 3.0.0-dev ] {
Property [ <default> protected $previous ]
}
- - Methods [9] {
- Method [ <internal:Core, inherits BaseException, ctor> public method __construct ] {
+ - Methods [10] {
+ Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
- Parameters [3] {
Parameter #0 [ <optional> $message ]
@@ -2943,33 +2946,36 @@ Extension [ <persistent> extension #90 yaf version 3.0.0-dev ] {
}
}
- Method [ <internal:Core, inherits BaseException> final public method getMessage ] {
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
}
- Method [ <internal:Core, inherits BaseException> final public method getCode ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
}
- Method [ <internal:Core, inherits BaseException> final public method getFile ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
}
- Method [ <internal:Core, inherits BaseException> final public method getLine ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
}
- Method [ <internal:Core, inherits BaseException> final public method getTrace ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
}
- Method [ <internal:Core, inherits BaseException> final public method getPrevious ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
}
- Method [ <internal:Core, inherits BaseException> final public method getTraceAsString ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
}
- Method [ <internal:Core, inherits BaseException> public method __toString ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
}
}
}
- Class [ <internal:yaf> class Yaf_Exception_DispatchFailed extends Yaf_Exception ] {
+ Class [ <internal:yaf> class Yaf_Exception_DispatchFailed extends Yaf_Exception implements Throwable ] {
- Constants [0] {
}
@@ -2988,8 +2994,8 @@ Extension [ <persistent> extension #90 yaf version 3.0.0-dev ] {
Property [ <default> protected $previous ]
}
- - Methods [9] {
- Method [ <internal:Core, inherits BaseException, ctor> public method __construct ] {
+ - Methods [10] {
+ Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
- Parameters [3] {
Parameter #0 [ <optional> $message ]
@@ -2998,33 +3004,36 @@ Extension [ <persistent> extension #90 yaf version 3.0.0-dev ] {
}
}
- Method [ <internal:Core, inherits BaseException> final public method getMessage ] {
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
}
- Method [ <internal:Core, inherits BaseException> final public method getCode ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
}
- Method [ <internal:Core, inherits BaseException> final public method getFile ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
}
- Method [ <internal:Core, inherits BaseException> final public method getLine ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
}
- Method [ <internal:Core, inherits BaseException> final public method getTrace ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
}
- Method [ <internal:Core, inherits BaseException> final public method getPrevious ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
}
- Method [ <internal:Core, inherits BaseException> final public method getTraceAsString ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
}
- Method [ <internal:Core, inherits BaseException> public method __toString ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
}
}
}
- Class [ <internal:yaf> class Yaf_Exception_LoadFailed extends Yaf_Exception ] {
+ Class [ <internal:yaf> class Yaf_Exception_LoadFailed extends Yaf_Exception implements Throwable ] {
- Constants [0] {
}
@@ -3043,8 +3052,8 @@ Extension [ <persistent> extension #90 yaf version 3.0.0-dev ] {
Property [ <default> protected $previous ]
}
- - Methods [9] {
- Method [ <internal:Core, inherits BaseException, ctor> public method __construct ] {
+ - Methods [10] {
+ Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
- Parameters [3] {
Parameter #0 [ <optional> $message ]
@@ -3053,33 +3062,36 @@ Extension [ <persistent> extension #90 yaf version 3.0.0-dev ] {
}
}
- Method [ <internal:Core, inherits BaseException> final public method getMessage ] {
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
}
- Method [ <internal:Core, inherits BaseException> final public method getCode ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
}
- Method [ <internal:Core, inherits BaseException> final public method getFile ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
}
- Method [ <internal:Core, inherits BaseException> final public method getLine ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
}
- Method [ <internal:Core, inherits BaseException> final public method getTrace ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
}
- Method [ <internal:Core, inherits BaseException> final public method getPrevious ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
}
- Method [ <internal:Core, inherits BaseException> final public method getTraceAsString ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
}
- Method [ <internal:Core, inherits BaseException> public method __toString ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
}
}
}
- Class [ <internal:yaf> class Yaf_Exception_LoadFailed_Module extends Yaf_Exception_LoadFailed ] {
+ Class [ <internal:yaf> class Yaf_Exception_LoadFailed_Module extends Yaf_Exception_LoadFailed implements Throwable ] {
- Constants [0] {
}
@@ -3098,8 +3110,8 @@ Extension [ <persistent> extension #90 yaf version 3.0.0-dev ] {
Property [ <default> protected $previous ]
}
- - Methods [9] {
- Method [ <internal:Core, inherits BaseException, ctor> public method __construct ] {
+ - Methods [10] {
+ Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
- Parameters [3] {
Parameter #0 [ <optional> $message ]
@@ -3108,33 +3120,36 @@ Extension [ <persistent> extension #90 yaf version 3.0.0-dev ] {
}
}
- Method [ <internal:Core, inherits BaseException> final public method getMessage ] {
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
}
- Method [ <internal:Core, inherits BaseException> final public method getCode ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
}
- Method [ <internal:Core, inherits BaseException> final public method getFile ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
}
- Method [ <internal:Core, inherits BaseException> final public method getLine ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
}
- Method [ <internal:Core, inherits BaseException> final public method getTrace ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
}
- Method [ <internal:Core, inherits BaseException> final public method getPrevious ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
}
- Method [ <internal:Core, inherits BaseException> final public method getTraceAsString ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
}
- Method [ <internal:Core, inherits BaseException> public method __toString ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
}
}
}
- Class [ <internal:yaf> class Yaf_Exception_LoadFailed_Controller extends Yaf_Exception_LoadFailed ] {
+ Class [ <internal:yaf> class Yaf_Exception_LoadFailed_Controller extends Yaf_Exception_LoadFailed implements Throwable ] {
- Constants [0] {
}
@@ -3153,8 +3168,8 @@ Extension [ <persistent> extension #90 yaf version 3.0.0-dev ] {
Property [ <default> protected $previous ]
}
- - Methods [9] {
- Method [ <internal:Core, inherits BaseException, ctor> public method __construct ] {
+ - Methods [10] {
+ Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
- Parameters [3] {
Parameter #0 [ <optional> $message ]
@@ -3163,33 +3178,36 @@ Extension [ <persistent> extension #90 yaf version 3.0.0-dev ] {
}
}
- Method [ <internal:Core, inherits BaseException> final public method getMessage ] {
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
}
- Method [ <internal:Core, inherits BaseException> final public method getCode ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
}
- Method [ <internal:Core, inherits BaseException> final public method getFile ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
}
- Method [ <internal:Core, inherits BaseException> final public method getLine ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
}
- Method [ <internal:Core, inherits BaseException> final public method getTrace ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
}
- Method [ <internal:Core, inherits BaseException> final public method getPrevious ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
}
- Method [ <internal:Core, inherits BaseException> final public method getTraceAsString ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
}
- Method [ <internal:Core, inherits BaseException> public method __toString ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
}
}
}
- Class [ <internal:yaf> class Yaf_Exception_LoadFailed_Action extends Yaf_Exception_LoadFailed ] {
+ Class [ <internal:yaf> class Yaf_Exception_LoadFailed_Action extends Yaf_Exception_LoadFailed implements Throwable ] {
- Constants [0] {
}
@@ -3208,8 +3226,8 @@ Extension [ <persistent> extension #90 yaf version 3.0.0-dev ] {
Property [ <default> protected $previous ]
}
- - Methods [9] {
- Method [ <internal:Core, inherits BaseException, ctor> public method __construct ] {
+ - Methods [10] {
+ Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
- Parameters [3] {
Parameter #0 [ <optional> $message ]
@@ -3218,33 +3236,36 @@ Extension [ <persistent> extension #90 yaf version 3.0.0-dev ] {
}
}
- Method [ <internal:Core, inherits BaseException> final public method getMessage ] {
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
}
- Method [ <internal:Core, inherits BaseException> final public method getCode ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
}
- Method [ <internal:Core, inherits BaseException> final public method getFile ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
}
- Method [ <internal:Core, inherits BaseException> final public method getLine ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
}
- Method [ <internal:Core, inherits BaseException> final public method getTrace ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
}
- Method [ <internal:Core, inherits BaseException> final public method getPrevious ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
}
- Method [ <internal:Core, inherits BaseException> final public method getTraceAsString ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
}
- Method [ <internal:Core, inherits BaseException> public method __toString ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
}
}
}
- Class [ <internal:yaf> class Yaf_Exception_LoadFailed_View extends Yaf_Exception_LoadFailed ] {
+ Class [ <internal:yaf> class Yaf_Exception_LoadFailed_View extends Yaf_Exception_LoadFailed implements Throwable ] {
- Constants [0] {
}
@@ -3263,8 +3284,8 @@ Extension [ <persistent> extension #90 yaf version 3.0.0-dev ] {
Property [ <default> protected $previous ]
}
- - Methods [9] {
- Method [ <internal:Core, inherits BaseException, ctor> public method __construct ] {
+ - Methods [10] {
+ Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
- Parameters [3] {
Parameter #0 [ <optional> $message ]
@@ -3273,33 +3294,36 @@ Extension [ <persistent> extension #90 yaf version 3.0.0-dev ] {
}
}
- Method [ <internal:Core, inherits BaseException> final public method getMessage ] {
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
}
- Method [ <internal:Core, inherits BaseException> final public method getCode ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
}
- Method [ <internal:Core, inherits BaseException> final public method getFile ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
}
- Method [ <internal:Core, inherits BaseException> final public method getLine ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
}
- Method [ <internal:Core, inherits BaseException> final public method getTrace ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
}
- Method [ <internal:Core, inherits BaseException> final public method getPrevious ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
}
- Method [ <internal:Core, inherits BaseException> final public method getTraceAsString ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
}
- Method [ <internal:Core, inherits BaseException> public method __toString ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
}
}
}
- Class [ <internal:yaf> class Yaf_Exception_TypeError extends Yaf_Exception ] {
+ Class [ <internal:yaf> class Yaf_Exception_TypeError extends Yaf_Exception implements Throwable ] {
- Constants [0] {
}
@@ -3318,8 +3342,8 @@ Extension [ <persistent> extension #90 yaf version 3.0.0-dev ] {
Property [ <default> protected $previous ]
}
- - Methods [9] {
- Method [ <internal:Core, inherits BaseException, ctor> public method __construct ] {
+ - Methods [10] {
+ Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
- Parameters [3] {
Parameter #0 [ <optional> $message ]
@@ -3328,28 +3352,31 @@ Extension [ <persistent> extension #90 yaf version 3.0.0-dev ] {
}
}
- Method [ <internal:Core, inherits BaseException> final public method getMessage ] {
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
}
- Method [ <internal:Core, inherits BaseException> final public method getCode ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
}
- Method [ <internal:Core, inherits BaseException> final public method getFile ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
}
- Method [ <internal:Core, inherits BaseException> final public method getLine ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
}
- Method [ <internal:Core, inherits BaseException> final public method getTrace ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
}
- Method [ <internal:Core, inherits BaseException> final public method getPrevious ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
}
- Method [ <internal:Core, inherits BaseException> final public method getTraceAsString ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
}
- Method [ <internal:Core, inherits BaseException> public method __toString ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
}
}
}
diff --git a/php-pecl-yaf-dev.spec b/php-pecl-yaf-dev.spec
index 5f45e63..ad957e9 100644
--- a/php-pecl-yaf-dev.spec
+++ b/php-pecl-yaf-dev.spec
@@ -19,11 +19,11 @@
%{!?__pecl: %global __pecl %{_bindir}/pecl}
%{!?__php: %global __php %{_bindir}/php}
-%global gh_commit 2dd49abe02fb2c17870b18d1ae3a45a0a14ab456
+%global gh_commit 63222a2c40782fd79a14257475e951de3ce33d87
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laruence
%global gh_project yaf
-%global gh_date 20150813
+%global gh_date 20150906
%global with_zts 0%{?__ztsphp:1}
%global pecl_name yaf
%if "%{php_version}" < "5.6"
@@ -36,7 +36,7 @@ Summary: Yet Another Framework
Name: %{?sub_prefix}php-pecl-yaf
Version: 3.0.0
%if 0%{?gh_date:1}
-Release: 0.6.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 0.7.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%else
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%endif
@@ -91,7 +91,7 @@ Obsoletes: php70w-pecl-%{pecl_name} <= %{version}
The Yet Another Framework (Yaf) extension is a PHP framework that is used
to develop web applications.
-Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl})}.
+Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{scl_vendor})}.
%prep
@@ -223,6 +223,9 @@ rm -rf %{buildroot}
%changelog
+* Sun Sep 6 2015 Remi Collet <remi@fedoraproject.org> - 3.0.0-0.7.20150906git63222a2
+- new shapshot (changes from 2.3.5)
+
* Thu Aug 13 2015 Remi Collet <remi@fedoraproject.org> - 3.0.0-0.6.20150813git2dd49ab
- new shapshot
diff --git a/php-pecl-yaf.spec b/php-pecl-yaf.spec
index 354e5c7..70c3d6b 100644
--- a/php-pecl-yaf.spec
+++ b/php-pecl-yaf.spec
@@ -1,4 +1,4 @@
-# spec file for php-pecl-yaf
+# remirepo spec file for php-pecl-yaf
#
# Copyright (c) 2012-2015 Remi Collet
# License: CC-BY-SA
@@ -29,7 +29,7 @@
Summary: Yet Another Framework
Name: %{?sub_prefix}php-pecl-yaf
-Version: 2.3.4
+Version: 2.3.5
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP
Group: Development/Languages
@@ -78,7 +78,7 @@ Obsoletes: php56w-pecl-%{pecl_name} <= %{version}
The Yet Another Framework (Yaf) extension is a PHP framework that is used
to develop web applications.
-Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl})}.
+Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{scl_vendor})}.
%prep
@@ -206,6 +206,9 @@ rm -rf %{buildroot}
%changelog
+* Sun Sep 6 2015 Remi Collet <remi@fedoraproject.org> - 2.3.5-1
+- Update to 2.3.5
+
* Thu Aug 13 2015 Remi Collet <remi@fedoraproject.org> - 2.3.4-1
- Update to 2.3.4