summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-04-17 18:05:45 +0200
committerRemi Collet <fedora@famillecollet.com>2014-04-17 18:05:45 +0200
commit69a440a7987ad64e5c17b7876c61bc2716486ec1 (patch)
tree8ee57bd59ab7e13414aa9d16ec0cfcd7193b4717
parentd5fd645df8388b92ed97881caae5305ce13f013d (diff)
php-pecl: add numerical prefix to extension configuration file (all done !)
-rw-r--r--php-pecl-yaf.spec21
1 files changed, 16 insertions, 5 deletions
diff --git a/php-pecl-yaf.spec b/php-pecl-yaf.spec
index 04ea5d6..2247dff 100644
--- a/php-pecl-yaf.spec
+++ b/php-pecl-yaf.spec
@@ -13,11 +13,16 @@
%global with_zts 0%{?__ztsphp:1}
%global pecl_name yaf
+%if "%{php_version}" < "5.6"
+%global ini_name %{pecl_name}.ini
+%else
+%global ini_name 40-%{pecl_name}.ini
+%endif
Summary: Yet Another Framework
Name: %{?scl_prefix}php-pecl-yaf
Version: 2.3.2
-Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Release: 2%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: PHP
Group: Development/Languages
URL: http://pecl.php.net/package/yaf
@@ -47,6 +52,9 @@ Obsoletes: php54-pecl-%{pecl_name}
%if "%{php_version}" > "5.5"
Obsoletes: php55u-pecl-%{pecl_name}
%endif
+%if "%{php_version}" > "5.6"
+Obsoletes: php56u-pecl-%{pecl_name}
+%endif
%endif
%if 0%{?fedora} < 20 && 0%{?rhel} < 7
@@ -96,12 +104,12 @@ make %{?_smp_mflags}
rm -rf %{buildroot}
# Install the NTS stuff
make -C NTS install INSTALL_ROOT=%{buildroot}
-install -D -m 644 %{SOURCE1} %{buildroot}%{_sysconfdir}/php.d/%{pecl_name}.ini
+install -D -m 644 %{SOURCE1} %{buildroot}%{php_inidir}/%{ini_name}
# Install the ZTS stuff
%if %{with_zts}
make -C ZTS install INSTALL_ROOT=%{buildroot}
-install -D -m 644 %{SOURCE1} %{buildroot}%{php_ztsinidir}/%{pecl_name}.ini
+install -D -m 644 %{SOURCE1} %{buildroot}%{php_ztsinidir}/%{ini_name}
%endif
# Install the package XML file
@@ -165,17 +173,20 @@ rm -rf %{buildroot}
%doc %{pecl_docdir}/%{pecl_name}
%doc %{pecl_testdir}/%{pecl_name}
-%config(noreplace) %{_sysconfdir}/php.d/%{pecl_name}.ini
+%config(noreplace) %{php_inidir}/%{ini_name}
%{php_extdir}/%{pecl_name}.so
%{pecl_xmldir}/%{name}.xml
%if %{with_zts}
%{php_ztsextdir}/%{pecl_name}.so
-%config(noreplace) %{php_ztsinidir}/%{pecl_name}.ini
+%config(noreplace) %{php_ztsinidir}/%{ini_name}
%endif
%changelog
+* Thu Apr 17 2014 Remi Collet <remi@fedoraproject.org> - 2.3.2-2
+- add numerical prefix to extension configuration file (php 5.6)
+
* Thu Jan 09 2014 Remi Collet <remi@fedoraproject.org> - 2.3.2-1
- Update to 2.3.2 (beta)