summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION26
-rw-r--r--php-pecl-yac.spec5
3 files changed, 10 insertions, 23 deletions
diff --git a/PHPINFO b/PHPINFO
index 5af536f..a11340b 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,7 +2,7 @@
yac
yac support => enabled
-Version => 2.2.0
+Version => 2.2.1
Shared Memory => mmap
Serializer => php, msgpack, igbinary, json
diff --git a/REFLECTION b/REFLECTION
index a7b3b62..4f6396a 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #112 yac version 2.2.0 ] {
+Extension [ <persistent> extension #113 yac version 2.2.1 ] {
- Dependencies {
Dependency [ msgpack (Required) ]
@@ -31,7 +31,7 @@ Extension [ <persistent> extension #112 yac version 2.2.0 ] {
}
- Constants [9] {
- Constant [ string YAC_VERSION ] { 2.2.0 }
+ Constant [ string YAC_VERSION ] { 2.2.1 }
Constant [ int YAC_MAX_KEY_LEN ] { 48 }
Constant [ int YAC_MAX_VALUE_RAW_LEN ] { 67108863 }
Constant [ int YAC_MAX_RAW_COMPRESSED_LEN ] { 1048576 }
@@ -43,7 +43,7 @@ Extension [ <persistent> extension #112 yac version 2.2.0 ] {
}
- Classes [1] {
- Class [ <internal:yac> class Yac ] {
+ Class [ <internal:yac> final class Yac ] {
- Constants [0] {
}
@@ -54,11 +54,10 @@ Extension [ <persistent> extension #112 yac version 2.2.0 ] {
- Static methods [0] {
}
- - Properties [1] {
- Property [ <default> protected $_prefix ]
+ - Properties [0] {
}
- - Methods [10] {
+ - Methods [8] {
Method [ <internal:yac, ctor> public method __construct ] {
- Parameters [1] {
@@ -84,14 +83,6 @@ Extension [ <persistent> extension #112 yac version 2.2.0 ] {
}
}
- Method [ <internal:yac> public method __set ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> $key ]
- Parameter #1 [ <required> $value ]
- }
- }
-
Method [ <internal:yac> public method get ] {
- Parameters [1] {
@@ -99,13 +90,6 @@ Extension [ <persistent> extension #112 yac version 2.2.0 ] {
}
}
- Method [ <internal:yac> public method __get ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $key ]
- }
- }
-
Method [ <internal:yac> public method delete ] {
- Parameters [2] {
diff --git a/php-pecl-yac.spec b/php-pecl-yac.spec
index 59708ab..367de44 100644
--- a/php-pecl-yac.spec
+++ b/php-pecl-yac.spec
@@ -28,7 +28,7 @@
Summary: Lockless user data cache
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 2.2.0
+Version: 2.2.1
%if 0%{?gh_date:1}
Release: 0.12.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{pecl_name}-%{version}-%{gh_short}.tar.gz
@@ -277,6 +277,9 @@ fi
%changelog
+* Fri May 15 2020 Remi Collet <remi@remirepo.net> - 2.2.1-1
+- update to 2.2.1
+
* Tue Mar 31 2020 Remi Collet <remi@remirepo.net> - 2.2.0-1
- update to 2.2.0
- enable json, igbinary and msgpack serializers