summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-06-23 16:42:51 +0200
committerRemi Collet <fedora@famillecollet.com>2015-06-23 16:42:51 +0200
commit66678a8342da7a6748693d432399cbe8dc025ee3 (patch)
tree783b3837bfebaea60cd5531b557354e7d5771c81
parenta5b6f255b24b6462e95304361e6658985e65cdf7 (diff)
php-pecl-yac: allow build against rh-php56 (as more-php56)
-rw-r--r--php-pecl-yac-dev.spec16
-rw-r--r--php-pecl-yac.spec23
2 files changed, 31 insertions, 8 deletions
diff --git a/php-pecl-yac-dev.spec b/php-pecl-yac-dev.spec
index 437d69c..a7f1451 100644
--- a/php-pecl-yac-dev.spec
+++ b/php-pecl-yac-dev.spec
@@ -9,6 +9,14 @@
#
# Please, preserve the changelog entries
#
+%if 0%{?scl:1}
+%if "%{scl}" == "rh-php56"
+%global sub_prefix more-php56-
+%else
+%global sub_prefix %{scl_prefix}
+%endif
+%endif
+
%{?scl: %scl_package php-yac}
%{!?php_inidir: %global php_inidir %{_sysconfdir}/php.d}
%{!?__pecl: %global __pecl %{_bindir}/pecl}
@@ -30,12 +38,12 @@
%global with_fastlz 1
Summary: Lockless user data cache
-Name: %{?scl_prefix}php-pecl-%{pecl_name}
+Name: %{?sub_prefix}php-pecl-%{pecl_name}
Version: 0.9.3
%if 0%{?gh_date:1}
-Release: 0.1.%{gh_date}git%{gh_short}%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Release: 0.1.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%else
-Release: 2%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%endif
License: PHP
@@ -94,7 +102,7 @@ chance you will get a wrong data(depends on how many key slots are
allocated and how many keys are stored), so you'd better make sure
that your product is not very sensitive to that.
-Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection}.
+Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl})}.
%prep
diff --git a/php-pecl-yac.spec b/php-pecl-yac.spec
index 6775331..6a3e05c 100644
--- a/php-pecl-yac.spec
+++ b/php-pecl-yac.spec
@@ -1,4 +1,7 @@
-# spec file for php-pecl-yac (previously php-yac)
+# remirepo spec file for php-pecl-yac
+# with SCL compatibility, from:
+#
+# Fedora spec file for php-pecl-yac (previously php-yac)
#
# Copyright (c) 2013-2015 Remi Collet
# License: CC-BY-SA
@@ -6,6 +9,14 @@
#
# Please, preserve the changelog entries
#
+%if 0%{?scl:1}
+%if "%{scl}" == "rh-php56"
+%global sub_prefix more-php56-
+%else
+%global sub_prefix %{scl_prefix}
+%endif
+%endif
+
%{?scl: %scl_package php-yac}
%{!?php_inidir: %global php_inidir %{_sysconfdir}/php.d}
%{!?__pecl: %global __pecl %{_bindir}/pecl}
@@ -22,9 +33,9 @@
%global with_fastlz 1
Summary: Lockless user data cache
-Name: %{?scl_prefix}php-pecl-%{pecl_name}
+Name: %{?sub_prefix}php-pecl-%{pecl_name}
Version: 0.9.2
-Release: 2%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Release: 3%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP
Group: Development/Languages
@@ -82,7 +93,7 @@ chance you will get a wrong data(depends on how many key slots are
allocated and how many keys are stored), so you'd better make sure
that your product is not very sensitive to that.
-Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection}.
+Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl})}.
%prep
@@ -233,6 +244,7 @@ rm -rf %{buildroot}
%files
%defattr(-, root, root, 0755)
+%{?_licensedir:%license NTS/LICENSE}
%doc %{pecl_docdir}/%{pecl_name}
%{pecl_xmldir}/%{name}.xml
@@ -246,6 +258,9 @@ rm -rf %{buildroot}
%changelog
+* Tue Jun 23 2015 Remi Collet <remi@fedoraproject.org> - 0.9.2-3
+- allow build against rh-php56 (as more-php56)
+
* Sun Mar 1 2015 Remi Collet <remi@fedoraproject.org> - 0.9.2-2
- drop runtime dependency on pear, new scriplets