summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-06-16 17:35:53 +0200
committerRemi Collet <fedora@famillecollet.com>2015-06-16 17:35:53 +0200
commit11719e1240fe8e34020c256e4c49aef052cf0b7c (patch)
tree6e0a5907ed926f15fbf4cc19ab593f7fa407b801
parent1c4daa9198ef397995ba21f540842e5f7796b2b9 (diff)
php-pecl-yac: 0.9.3-dev for php 7
-rw-r--r--REFLECTION-DEV110
-rw-r--r--php-pecl-yac-dev.spec36
2 files changed, 137 insertions, 9 deletions
diff --git a/REFLECTION-DEV b/REFLECTION-DEV
new file mode 100644
index 0000000..8c8af55
--- /dev/null
+++ b/REFLECTION-DEV
@@ -0,0 +1,110 @@
+Extension [ <persistent> extension #89 yac version 0.9.3-dev ] {
+
+ - INI {
+ Entry [ yac.enable <SYSTEM> ]
+ Current = '1'
+ }
+ Entry [ yac.debug <ALL> ]
+ Current = '0'
+ }
+ Entry [ yac.keys_memory_size <SYSTEM> ]
+ Current = '4M'
+ }
+ Entry [ yac.values_memory_size <SYSTEM> ]
+ Current = '64M'
+ }
+ Entry [ yac.compress_threshold <SYSTEM> ]
+ Current = '-1'
+ }
+ Entry [ yac.enable_cli <SYSTEM> ]
+ Current = '0'
+ }
+ }
+
+ - Constants [5] {
+ Constant [ string YAC_VERSION ] { 0.9.3-dev }
+ Constant [ integer YAC_MAX_KEY_LEN ] { 48 }
+ Constant [ integer YAC_MAX_VALUE_RAW_LEN ] { 67108863 }
+ Constant [ integer YAC_MAX_RAW_COMPRESSED_LEN ] { 1048576 }
+ Constant [ string YAC_SERIALIZER ] { PHP }
+ }
+
+ - Classes [1] {
+ Class [ <internal:yac> class Yac ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [1] {
+ Property [ <default> protected $_prefix ]
+ }
+
+ - Methods [8] {
+ Method [ <internal:yac, ctor> public method __construct ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> $prefix ]
+ }
+ }
+
+ Method [ <internal:yac> public method add ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $keys ]
+ Parameter #1 [ <optional> $value ]
+ Parameter #2 [ <optional> $ttl ]
+ }
+ }
+
+ Method [ <internal:yac> public method set ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $keys ]
+ Parameter #1 [ <optional> $value ]
+ Parameter #2 [ <optional> $ttl ]
+ }
+ }
+
+ Method [ <internal:yac> public method get ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $keys ]
+ }
+ }
+
+ Method [ <internal:yac> public method delete ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $keys ]
+ Parameter #1 [ <optional> $ttl ]
+ }
+ }
+
+ Method [ <internal:yac> public method flush ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:yac> public method info ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:yac> public method dump ] {
+
+ - Parameters [0] {
+ }
+ }
+ }
+ }
+ }
+}
+
diff --git a/php-pecl-yac-dev.spec b/php-pecl-yac-dev.spec
index 6775331..0fd41eb 100644
--- a/php-pecl-yac-dev.spec
+++ b/php-pecl-yac-dev.spec
@@ -1,4 +1,7 @@
-# spec file for php-pecl-yac (previously php-yac)
+# remirepo spec file for php-pecl-yac
+# with SCL stuff, from:
+#
+# Fedora spec file for php-pecl-yac (previously php-yac)
#
# Copyright (c) 2013-2015 Remi Collet
# License: CC-BY-SA
@@ -11,6 +14,11 @@
%{!?__pecl: %global __pecl %{_bindir}/pecl}
%{!?__php: %global __php %{_bindir}/php}
+%global gh_commit 1d26cd46e37d42b47cfea16d3391464022453570
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global gh_owner laruence
+%global gh_project yac
+%global gh_date 20150616
%global with_zts 0%{?__ztsphp:1}
%global pecl_name yac
%global with_tests %{!?_without_tests:1}%{?_without_tests:0}
@@ -23,13 +31,17 @@
Summary: Lockless user data cache
Name: %{?scl_prefix}php-pecl-%{pecl_name}
-Version: 0.9.2
+Version: 0.9.3
+%if 0%{?gh_date:1}
+Release: 0.1.%{gh_date}git%{gh_short}%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+%else
Release: 2%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+%endif
License: PHP
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
-Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
+Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{pecl_name}-%{version}-%{gh_short}.tar.gz
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: %{?scl_prefix}php-devel > 5.2
@@ -87,7 +99,8 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
%prep
%setup -qc
-mv %{pecl_name}-%{version} NTS
+mv %{gh_project}-%{gh_commit} NTS
+mv NTS/package.xml .
# Don't install (register) the tests
sed -e 's/role="test"/role="src"/' -i package.xml
@@ -100,8 +113,8 @@ rm -r compressor/fastlz
# Check version as upstream often forget to update this
extver=$(sed -n '/#define PHP_YAC_VERSION/{s/.* "//;s/".*$//;p}' php_yac.h)
-if test "x${extver}" != "x%{version}%{?prever}"; then
- : Error: Upstream YAC version is ${extver}, expecting %{version}%{?prever}.
+if test "x${extver}" != "x%{version}%{?prever}%{?gh_date:-dev}"; then
+ : Error: Upstream YAC version is ${extver}, expecting %{version}%{?prever}%{?gh_date:-dev}.
exit 1
fi
cd ..
@@ -163,9 +176,9 @@ make -C ZTS install INSTALL_ROOT=%{buildroot}
install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
%endif
-# Test & Documentation
-for i in $(grep 'role="doc"' package.xml | sed -e 's/^.*name="//;s/".*$//')
-do install -Dpm 644 NTS/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
+# Documentation
+for i in README.md $(grep 'role="doc"' package.xml | sed -e 's/^.*name="//;s/".*$//')
+do [ -f NTS/$i ] && install -Dpm 644 NTS/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
done
@@ -233,6 +246,7 @@ rm -rf %{buildroot}
%files
%defattr(-, root, root, 0755)
+%{?_licensedir:%license NTS/LICENSE}
%doc %{pecl_docdir}/%{pecl_name}
%{pecl_xmldir}/%{name}.xml
@@ -246,6 +260,10 @@ rm -rf %{buildroot}
%changelog
+* Tue Jun 16 2015 Remi Collet <remi@fedoraproject.org> - 0.9.3-0.1.20150616git1d26cd4
+- update to 0.9.3-dev for PHP 7
+- sources from github
+
* Sun Mar 1 2015 Remi Collet <remi@fedoraproject.org> - 0.9.2-2
- drop runtime dependency on pear, new scriplets