summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-03-06 08:52:23 +0100
committerRemi Collet <remi@remirepo.net>2021-03-06 08:52:23 +0100
commit8bebb904499dbc2421b1e6bbe73181a1d4dc8331 (patch)
tree578ae3dce9db2603d66b0ba2eb7131c950894440
parentf3e1c18cb0f6e0dca58680f10a902eeb0d0400ee (diff)
clean for Fedora review
-rw-r--r--php-pecl-xmlrpc.spec88
1 files changed, 29 insertions, 59 deletions
diff --git a/php-pecl-xmlrpc.spec b/php-pecl-xmlrpc.spec
index ce6b777..8bbfa58 100644
--- a/php-pecl-xmlrpc.spec
+++ b/php-pecl-xmlrpc.spec
@@ -1,3 +1,6 @@
+# Fedora spec file for php-pecl-xmlrpc
+# Without SCL compatibility, from
+#
# remirepo spec file for php-pecl-xmlrpc
#
# Copyright (c) 2020-2021 Remi Collet
@@ -10,20 +13,10 @@
# we don't want -z defs linker flag
%undefine _strict_symbol_defs_build
-%if 0%{?scl:1}
-%global sub_prefix %{scl_prefix}
-%scl_package php-pecl-xmlrpc
-%endif
+%bcond_without tests
-# https://github.com/php/pecl-networking-xmlrpc/commits/master
-%global gh_commit e71da6ad6f86fd149de14e42b54019edf3e629b7
-%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
-%global gh_owner php
-%global gh_project pecl-networking-xmlrpc
-#global gh_date 20200602
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global pecl_name xmlrpc
-%global with_tests 0%{!?_without_tests:1}
%global upver 1.0.0
%global rcver RC2
%global lower rc2
@@ -31,48 +24,32 @@
%global ini_name 30-%{pecl_name}.ini
Summary: Functions to write XML-RPC servers and clients
-Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: %{upver}%{?lower:~%{lower}}%{?gh_date:.%{gh_date}}
-Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Name: php-pecl-%{pecl_name}
+Version: %{upver}%{?lower:~%{lower}}
+Release: 2%{?dist}
# Extension is PHP
# Library is BSD
License: PHP and BSD
URL: https://pecl.php.net/package/%{pecl_name}
-%if 0%{?gh_date}
-Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{pecl_name}-%{upver}-%{gh_short}.tar.gz
-%else
Source0: https://pecl.php.net/get/%{pecl_name}-%{upver}%{?rcver}.tgz
-%endif
BuildRequires: make
-BuildRequires: %{?dtsprefix}gcc
-BuildRequires: %{?scl_prefix}php-devel > 8.0
-BuildRequires: %{?scl_prefix}php-pear
-BuildRequires: %{?scl_prefix}php-xml
-
-Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
-Requires: %{?scl_prefix}php(api) = %{php_core_api}
-Requires: %{?scl_prefix}php-xml%{?_isa}
-%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
-
-# Set epoch so provides is > 0:8.0
-Obsoletes: %{?scl_prefix}php-%{pecl_name} < 8.0.0
-Provides: %{?scl_prefix}php-%{pecl_name} = 1:%{version}
-Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = 1:%{version}
-Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
-Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
-%if "%{?scl_prefix}" != "%{?sub_prefix}"
-Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
-Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
-%endif
+BuildRequires: gcc
+BuildRequires: php-devel >= 8
+BuildRequires: php-pear
+BuildRequires: php-xml
-%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
-# Other third party repo stuff
-%if "%{php_version}" > "8.0"
-Obsoletes: php80-pecl-%{pecl_name} <= %{version}
-%endif
-%endif
+Requires: php(zend-abi) = %{php_zend_api}
+Requires: php(api) = %{php_core_api}
+Requires: php-xml%{?_isa}
+
+# Set epoch so 1:1.0 > 0:8.0
+Obsoletes: php-%{pecl_name} < 8.0.0
+Provides: php-%{pecl_name} = 1:%{version}
+Provides: php-%{pecl_name}%{?_isa} = 1:%{version}
+Provides: php-pecl(%{pecl_name}) = %{version}
+Provides: php-pecl(%{pecl_name})%{?_isa} = %{version}
%description
@@ -85,20 +62,14 @@ The extension is unbundled from php-src as of PHP 8.0.0, because the underlying
libxmlrpc has obviously been abandoned. It is recommended to reevaluate using
this extension.
-Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{?scl_vendor}%{!?scl_vendor:rh})}.
-
%prep
%setup -qc
-%if 0%{?gh_date}
-mv %{gh_project}-%{gh_commit} NTS
-%else
mv %{pecl_name}-%{upver}%{?rcver} NTS
-%endif
sed -e 's/role="test"/role="src"/' \
- %{?_licensedir:-e '/COPYING/s/role="doc"/role="src"/' } \
- %{?_licensedir:-e '/LICENSE/s/role="doc"/role="src"/' } \
+ -e '/COPYING/s/role="doc"/role="src"/' \
+ -e '/LICENSE/s/role="doc"/role="src"/' \
-i package.xml
cd NTS
@@ -124,8 +95,6 @@ cp -pr NTS ZTS
%build
-%{?dtsenable}
-
peclconf() {
%configure \
--with-xmlrpc \
@@ -146,8 +115,6 @@ make %{?_smp_mflags}
%install
-%{?dtsenable}
-
# Install the NTS stuff
make -C NTS install INSTALL_ROOT=%{buildroot}
install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
@@ -187,7 +154,7 @@ cd ../ZTS
%endif
-%if %{with_tests}
+%if %{with tests}
cd ../NTS
: Run upstream test suite
@@ -201,8 +168,8 @@ REPORT_EXIT_STATUS=1 \
%files
-%{?_licensedir:%license NTS/LICENSE}
-%{?_licensedir:%license NTS/libxmlrpc/COPYING}
+%license NTS/LICENSE
+%license NTS/libxmlrpc/COPYING
%doc %{pecl_docdir}/%{pecl_name}
%{pecl_xmldir}/%{name}.xml
@@ -216,6 +183,9 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Sat Mar 6 2021 Remi Collet <remi@remirepo.net> - 1.0.0~rc2-2
+- clean for Fedora review
+
* Fri Jan 15 2021 Remi Collet <remi@remirepo.net> - 1.0.0~rc2-1
- update to 1.0.0RC2 (beta)