summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO5
-rw-r--r--REFLECTION29
-rw-r--r--php-pecl-xlswriter.spec5
3 files changed, 34 insertions, 5 deletions
diff --git a/PHPINFO b/PHPINFO
new file mode 100644
index 0000000..5f4c880
--- /dev/null
+++ b/PHPINFO
@@ -0,0 +1,5 @@
+
+xlswriter
+
+xlswriter support => enabled
+Version => 1.2.2
diff --git a/REFLECTION b/REFLECTION
index 3ccac6b..11e4099 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #169 xlswriter version 1.2.1 ] {
+Extension [ <persistent> extension #169 xlswriter version 1.2.2 ] {
- Classes [3] {
Class [ <internal:xlswriter> class Vtiful\Kernel\Exception extends Exception implements Throwable ] {
@@ -190,17 +190,29 @@ Extension [ <persistent> extension #169 xlswriter version 1.2.1 ] {
Class [ <internal:xlswriter> class Vtiful\Kernel\Format ] {
- - Constants [4] {
+ - Constants [16] {
Constant [ public integer UNDERLINE_SINGLE ] { 1 }
Constant [ public integer UNDERLINE_DOUBLE ] { 2 }
Constant [ public integer UNDERLINE_SINGLE_ACCOUNTING ] { 3 }
Constant [ public integer UNDERLINE_DOUBLE_ACCOUNTING ] { 4 }
+ Constant [ public integer FORMAT_ALIGN_LEFT ] { 1 }
+ Constant [ public integer FORMAT_ALIGN_CENTER ] { 2 }
+ Constant [ public integer FORMAT_ALIGN_RIGHT ] { 3 }
+ Constant [ public integer FORMAT_ALIGN_FILL ] { 4 }
+ Constant [ public integer FORMAT_ALIGN_JUSTIFY ] { 5 }
+ Constant [ public integer FORMAT_ALIGN_CENTER_ACROSS ] { 6 }
+ Constant [ public integer FORMAT_ALIGN_DISTRIBUTED ] { 7 }
+ Constant [ public integer FORMAT_ALIGN_VERTICAL_TOP ] { 8 }
+ Constant [ public integer FORMAT_ALIGN_VERTICAL_BOTTOM ] { 9 }
+ Constant [ public integer FORMAT_ALIGN_VERTICAL_CENTER ] { 10 }
+ Constant [ public integer FORMAT_ALIGN_VERTICAL_JUSTIFY ] { 11 }
+ Constant [ public integer FORMAT_ALIGN_VERTICAL_DISTRIBUTED ] { 12 }
}
- Static properties [0] {
}
- - Static methods [3] {
+ - Static methods [4] {
Method [ <internal:xlswriter> static public method bold ] {
- Parameters [1] {
@@ -217,8 +229,17 @@ Extension [ <persistent> extension #169 xlswriter version 1.2.1 ] {
Method [ <internal:xlswriter> static public method underline ] {
- - Parameters [1] {
+ - Parameters [2] {
+ Parameter #0 [ <required> $handle ]
+ Parameter #1 [ <required> $style ]
+ }
+ }
+
+ Method [ <internal:xlswriter> static public method align ] {
+
+ - Parameters [2] {
Parameter #0 [ <required> $handle ]
+ Parameter #1 [ <required> $style ]
}
}
}
diff --git a/php-pecl-xlswriter.spec b/php-pecl-xlswriter.spec
index 68916cd..0e49865 100644
--- a/php-pecl-xlswriter.spec
+++ b/php-pecl-xlswriter.spec
@@ -29,7 +29,7 @@
Summary: An efficient and fast xlsx file export extension
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 1.2.1
+Version: 1.2.2
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD
URL: http://pecl.php.net/package/%{pecl_name}
@@ -237,6 +237,9 @@ cd ..
%changelog
+* Thu Jul 12 2018 Remi Collet <remi@remirepo.net> - 1.2.2-1
+- update to 1.2.2
+
* Sun Jun 3 2018 Remi Collet <remi@remirepo.net> - 1.2.1-1
- update to 1.2.1
- drop patch merged upstream