summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO4
-rw-r--r--REFLECTION2
-rw-r--r--php-pecl-xlswriter.spec13
-rw-r--r--xlswriter-build.patch61
4 files changed, 12 insertions, 68 deletions
diff --git a/PHPINFO b/PHPINFO
index 5f4c880..ca684de 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,4 +2,6 @@
xlswriter
xlswriter support => enabled
-Version => 1.2.2
+Version => 1.2.3
+libxlsxwriter headers version => 0.8.4
+libxlsxwriter library version => 0.8.4
diff --git a/REFLECTION b/REFLECTION
index ccc6e75..d4e4e3b 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #170 xlswriter version 1.2.2 ] {
+Extension [ <persistent> extension #171 xlswriter version 1.2.3 ] {
- Classes [3] {
Class [ <internal:xlswriter> class Vtiful\Kernel\Exception extends Exception implements Throwable ] {
diff --git a/php-pecl-xlswriter.spec b/php-pecl-xlswriter.spec
index fb5f8a6..92c0d50 100644
--- a/php-pecl-xlswriter.spec
+++ b/php-pecl-xlswriter.spec
@@ -29,14 +29,12 @@
Summary: An efficient and fast xlsx file export extension
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 1.2.2
-Release: 8%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Version: 1.2.3
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD
URL: http://pecl.php.net/package/%{pecl_name}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
-Patch0: %{pecl_name}-build.patch
-
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel >= 7
BuildRequires: %{?scl_prefix}php-pear
@@ -104,7 +102,8 @@ sed -e 's/role="test"/role="src"/' \
-i package.xml
cd NTS
-%patch0 -p1 -b .fixbuild
+# we use the system library
+#rm -r library
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_XLSWRITER_VERSION/{s/.* "//;s/".*$//;p}' php_xls_writer.h)
@@ -132,6 +131,7 @@ EOF
peclbuild() {
%configure \
--with-xlswriter \
+ --with-libxlsxwriter=%{_prefix} \
--with-php-config=$1
make %{?_smp_mflags}
@@ -245,6 +245,9 @@ cd ..
%changelog
+* Sun Nov 25 2018 Remi Collet <remi@remirepo.net> - 1.2.3-1
+- update to 1.2.3
+
* Tue Oct 2 2018 Remi Collet <remi@remirepo.net> - 1.2.2-8
- rebuild with libxlsxwriter 0.8.3
diff --git a/xlswriter-build.patch b/xlswriter-build.patch
deleted file mode 100644
index 15526e5..0000000
--- a/xlswriter-build.patch
+++ /dev/null
@@ -1,61 +0,0 @@
-diff -up ./kernel/excel.c.fixbuild ./kernel/excel.c
---- ./kernel/excel.c.fixbuild 2018-07-11 14:15:31.000000000 +0200
-+++ ./kernel/excel.c 2018-09-12 11:26:05.455567873 +0200
-@@ -10,10 +10,6 @@
- +----------------------------------------------------------------------+
- */
-
--#ifdef HAVE_CONFIG_H
--#include "config.h"
--#endif
--
- #include "include.h"
-
- zend_class_entry *vtiful_xls_ce;
-diff -up ./kernel/format.c.fixbuild ./kernel/format.c
---- ./kernel/format.c.fixbuild 2018-07-11 14:15:31.000000000 +0200
-+++ ./kernel/format.c 2018-09-12 11:26:05.456567879 +0200
-@@ -10,10 +10,6 @@
- +----------------------------------------------------------------------+
- */
-
--#ifdef HAVE_CONFIG_H
--#include "config.h"
--#endif
--
- #include "include.h"
- #include "ext/standard/php_var.h"
-
-diff -up ./kernel/include.h.fixbuild ./kernel/include.h
---- ./kernel/include.h.fixbuild 2018-07-11 14:15:31.000000000 +0200
-+++ ./kernel/include.h 2018-09-12 11:26:05.456567879 +0200
-@@ -13,6 +13,10 @@
- #ifndef PHP_XLS_WRITER_INCLUDE_H
- #define PHP_XLS_WRITER_INCLUDE_H
-
-+#ifdef HAVE_CONFIG_H
-+#include "config.h"
-+#endif
-+
- #include <php.h>
-
- #include "zend_exceptions.h"
-diff -up ./kernel/write.c.fixbuild ./kernel/write.c
---- ./kernel/write.c.fixbuild 2018-09-12 11:26:05.456567879 +0200
-+++ ./kernel/write.c 2018-09-12 11:26:54.646837194 +0200
-@@ -368,7 +368,7 @@ _prepare_drawings(lxw_workbook *self)
- STAILQ_FOREACH(image_options, worksheet->chart_data, list_pointers) {
- chart_ref_id++;
- lxw_worksheet_prepare_chart(worksheet, chart_ref_id, drawing_id,
-- image_options);
-+ image_options, 0);
- if (image_options->chart)
- STAILQ_INSERT_TAIL(self->ordered_charts, image_options->chart,
- ordered_list_pointers);
-@@ -755,4 +755,4 @@ _populate_range(lxw_workbook *self, lxw_
- {
- _populate_range_dimensions(self, range);
- _populate_range_data_cache(self, range);
--}
-\ Pas de fin de ligne à la fin du fichier
-+}