summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO6
-rw-r--r--REFLECTION229
-rw-r--r--php-pecl-xlswriter.spec9
3 files changed, 132 insertions, 112 deletions
diff --git a/PHPINFO b/PHPINFO
index 219202a..1a0e7aa 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,8 +2,8 @@
xlswriter
xlswriter support => enabled
-Version => 1.3.2
-libxlsxwriter headers version => 0.8.8
-libxlsxwriter library version => 0.8.8
+Version => 1.3.3
+libxlsxwriter headers version => 0.8.9
+libxlsxwriter library version => 0.8.9
libxlsxio headers version => 0.2.21
libxlsxio library version => 0.2.21
diff --git a/REFLECTION b/REFLECTION
index a11b38f..b470ce3 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #174 xlswriter version 1.3.2 ] {
+Extension [ <persistent> extension #96 xlswriter version 1.3.3 ] {
- Classes [4] {
Class [ <internal:xlswriter> class Vtiful\Kernel\Exception extends Exception implements Throwable ] {
@@ -61,17 +61,17 @@ Extension [ <persistent> extension #174 xlswriter version 1.3.2 ] {
Class [ <internal:xlswriter> class Vtiful\Kernel\Excel ] {
- Constants [11] {
- Constant [ public integer SKIP_NONE ] { 0 }
- Constant [ public integer SKIP_EMPTY_ROW ] { 1 }
- Constant [ public integer SKIP_EMPTY_CELLS ] { 2 }
- Constant [ public integer GRIDLINES_HIDE_ALL ] { 0 }
- Constant [ public integer GRIDLINES_SHOW_ALL ] { 3 }
- Constant [ public integer GRIDLINES_SHOW_PRINT ] { 2 }
- Constant [ public integer GRIDLINES_SHOW_SCREEN ] { 1 }
- Constant [ public integer TYPE_INT ] { 2 }
- Constant [ public integer TYPE_DOUBLE ] { 4 }
- Constant [ public integer TYPE_STRING ] { 1 }
- Constant [ public integer TYPE_TIMESTAMP ] { 8 }
+ Constant [ public int SKIP_NONE ] { 0 }
+ Constant [ public int SKIP_EMPTY_ROW ] { 1 }
+ Constant [ public int SKIP_EMPTY_CELLS ] { 2 }
+ Constant [ public int GRIDLINES_HIDE_ALL ] { 0 }
+ Constant [ public int GRIDLINES_SHOW_ALL ] { 3 }
+ Constant [ public int GRIDLINES_SHOW_PRINT ] { 2 }
+ Constant [ public int GRIDLINES_SHOW_SCREEN ] { 1 }
+ Constant [ public int TYPE_INT ] { 2 }
+ Constant [ public int TYPE_DOUBLE ] { 4 }
+ Constant [ public int TYPE_STRING ] { 1 }
+ Constant [ public int TYPE_TIMESTAMP ] { 8 }
}
- Static properties [0] {
@@ -99,7 +99,7 @@ Extension [ <persistent> extension #174 xlswriter version 1.3.2 ] {
Property [ <default> private $read_row_type ]
}
- - Methods [30] {
+ - Methods [32] {
Method [ <internal:xlswriter, ctor> public method __construct ] {
- Parameters [1] {
@@ -218,18 +218,20 @@ Extension [ <persistent> extension #174 xlswriter version 1.3.2 ] {
Method [ <internal:xlswriter> public method insertFormula ] {
- - Parameters [3] {
+ - Parameters [4] {
Parameter #0 [ <required> $row ]
Parameter #1 [ <required> $column ]
Parameter #2 [ <required> $formula ]
+ Parameter #3 [ <optional> $format_handle ]
}
}
Method [ <internal:xlswriter> public method mergeCells ] {
- - Parameters [2] {
+ - Parameters [3] {
Parameter #0 [ <required> $range ]
Parameter #1 [ <required> $data ]
+ Parameter #2 [ <optional> $format_handle ]
}
}
@@ -251,6 +253,13 @@ Extension [ <persistent> extension #174 xlswriter version 1.3.2 ] {
}
}
+ Method [ <internal:xlswriter> public method defaultFormat ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $format_handle ]
+ }
+ }
+
Method [ <internal:xlswriter> public method freezePanes ] {
- Parameters [2] {
@@ -294,6 +303,14 @@ Extension [ <persistent> extension #174 xlswriter version 1.3.2 ] {
}
}
+ Method [ <internal:xlswriter> public method putCSVCallback ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $callback ]
+ Parameter #1 [ <required> $fp ]
+ }
+ }
+
Method [ <internal:xlswriter> public method sheetList ] {
}
@@ -323,70 +340,70 @@ Extension [ <persistent> extension #174 xlswriter version 1.3.2 ] {
Class [ <internal:xlswriter> class Vtiful\Kernel\Format ] {
- Constants [64] {
- Constant [ public integer UNDERLINE_SINGLE ] { 1 }
- Constant [ public integer UNDERLINE_DOUBLE ] { 2 }
- Constant [ public integer UNDERLINE_SINGLE_ACCOUNTING ] { 3 }
- Constant [ public integer UNDERLINE_DOUBLE_ACCOUNTING ] { 4 }
- Constant [ public integer FORMAT_ALIGN_LEFT ] { 1 }
- Constant [ public integer FORMAT_ALIGN_CENTER ] { 2 }
- Constant [ public integer FORMAT_ALIGN_RIGHT ] { 3 }
- Constant [ public integer FORMAT_ALIGN_FILL ] { 4 }
- Constant [ public integer FORMAT_ALIGN_JUSTIFY ] { 5 }
- Constant [ public integer FORMAT_ALIGN_CENTER_ACROSS ] { 6 }
- Constant [ public integer FORMAT_ALIGN_DISTRIBUTED ] { 7 }
- Constant [ public integer FORMAT_ALIGN_VERTICAL_TOP ] { 8 }
- Constant [ public integer FORMAT_ALIGN_VERTICAL_BOTTOM ] { 9 }
- Constant [ public integer FORMAT_ALIGN_VERTICAL_CENTER ] { 10 }
- Constant [ public integer FORMAT_ALIGN_VERTICAL_JUSTIFY ] { 11 }
- Constant [ public integer FORMAT_ALIGN_VERTICAL_DISTRIBUTED ] { 12 }
- Constant [ public integer COLOR_BLACK ] { 16777216 }
- Constant [ public integer COLOR_BLUE ] { 255 }
- Constant [ public integer COLOR_BROWN ] { 8388608 }
- Constant [ public integer COLOR_CYAN ] { 65535 }
- Constant [ public integer COLOR_GRAY ] { 8421504 }
- Constant [ public integer COLOR_GREEN ] { 32768 }
- Constant [ public integer COLOR_LIME ] { 65280 }
- Constant [ public integer COLOR_MAGENTA ] { 16711935 }
- Constant [ public integer COLOR_NAVY ] { 128 }
- Constant [ public integer COLOR_ORANGE ] { 16737792 }
- Constant [ public integer COLOR_PINK ] { 16711935 }
- Constant [ public integer COLOR_PURPLE ] { 8388736 }
- Constant [ public integer COLOR_RED ] { 16711680 }
- Constant [ public integer COLOR_SILVER ] { 12632256 }
- Constant [ public integer COLOR_WHITE ] { 16777215 }
- Constant [ public integer COLOR_YELLOW ] { 16776960 }
- Constant [ public integer PATTERN_NONE ] { 0 }
- Constant [ public integer PATTERN_SOLID ] { 1 }
- Constant [ public integer PATTERN_MEDIUM_GRAY ] { 2 }
- Constant [ public integer PATTERN_DARK_GRAY ] { 3 }
- Constant [ public integer PATTERN_LIGHT_GRAY ] { 4 }
- Constant [ public integer PATTERN_DARK_HORIZONTAL ] { 5 }
- Constant [ public integer PATTERN_DARK_VERTICAL ] { 6 }
- Constant [ public integer PATTERN_DARK_DOWN ] { 7 }
- Constant [ public integer PATTERN_DARK_UP ] { 8 }
- Constant [ public integer PATTERN_DARK_GRID ] { 9 }
- Constant [ public integer PATTERN_DARK_TRELLIS ] { 10 }
- Constant [ public integer PATTERN_LIGHT_HORIZONTAL ] { 11 }
- Constant [ public integer PATTERN_LIGHT_VERTICAL ] { 12 }
- Constant [ public integer PATTERN_LIGHT_DOWN ] { 13 }
- Constant [ public integer PATTERN_LIGHT_UP ] { 14 }
- Constant [ public integer PATTERN_LIGHT_GRID ] { 15 }
- Constant [ public integer PATTERN_LIGHT_TRELLIS ] { 16 }
- Constant [ public integer PATTERN_GRAY_125 ] { 17 }
- Constant [ public integer PATTERN_GRAY_0625 ] { 18 }
- Constant [ public integer BORDER_THIN ] { 1 }
- Constant [ public integer BORDER_MEDIUM ] { 2 }
- Constant [ public integer BORDER_DASHED ] { 3 }
- Constant [ public integer BORDER_DOTTED ] { 4 }
- Constant [ public integer BORDER_THICK ] { 5 }
- Constant [ public integer BORDER_DOUBLE ] { 6 }
- Constant [ public integer BORDER_HAIR ] { 7 }
- Constant [ public integer BORDER_MEDIUM_DASHED ] { 8 }
- Constant [ public integer BORDER_DASH_DOT ] { 9 }
- Constant [ public integer BORDER_MEDIUM_DASH_DOT ] { 10 }
- Constant [ public integer BORDER_DASH_DOT_DOT ] { 11 }
- Constant [ public integer BORDER_MEDIUM_DASH_DOT_DOT ] { 12 }
- Constant [ public integer BORDER_SLANT_DASH_DOT ] { 13 }
+ Constant [ public int UNDERLINE_SINGLE ] { 1 }
+ Constant [ public int UNDERLINE_DOUBLE ] { 2 }
+ Constant [ public int UNDERLINE_SINGLE_ACCOUNTING ] { 3 }
+ Constant [ public int UNDERLINE_DOUBLE_ACCOUNTING ] { 4 }
+ Constant [ public int FORMAT_ALIGN_LEFT ] { 1 }
+ Constant [ public int FORMAT_ALIGN_CENTER ] { 2 }
+ Constant [ public int FORMAT_ALIGN_RIGHT ] { 3 }
+ Constant [ public int FORMAT_ALIGN_FILL ] { 4 }
+ Constant [ public int FORMAT_ALIGN_JUSTIFY ] { 5 }
+ Constant [ public int FORMAT_ALIGN_CENTER_ACROSS ] { 6 }
+ Constant [ public int FORMAT_ALIGN_DISTRIBUTED ] { 7 }
+ Constant [ public int FORMAT_ALIGN_VERTICAL_TOP ] { 8 }
+ Constant [ public int FORMAT_ALIGN_VERTICAL_BOTTOM ] { 9 }
+ Constant [ public int FORMAT_ALIGN_VERTICAL_CENTER ] { 10 }
+ Constant [ public int FORMAT_ALIGN_VERTICAL_JUSTIFY ] { 11 }
+ Constant [ public int FORMAT_ALIGN_VERTICAL_DISTRIBUTED ] { 12 }
+ Constant [ public int COLOR_BLACK ] { 16777216 }
+ Constant [ public int COLOR_BLUE ] { 255 }
+ Constant [ public int COLOR_BROWN ] { 8388608 }
+ Constant [ public int COLOR_CYAN ] { 65535 }
+ Constant [ public int COLOR_GRAY ] { 8421504 }
+ Constant [ public int COLOR_GREEN ] { 32768 }
+ Constant [ public int COLOR_LIME ] { 65280 }
+ Constant [ public int COLOR_MAGENTA ] { 16711935 }
+ Constant [ public int COLOR_NAVY ] { 128 }
+ Constant [ public int COLOR_ORANGE ] { 16737792 }
+ Constant [ public int COLOR_PINK ] { 16711935 }
+ Constant [ public int COLOR_PURPLE ] { 8388736 }
+ Constant [ public int COLOR_RED ] { 16711680 }
+ Constant [ public int COLOR_SILVER ] { 12632256 }
+ Constant [ public int COLOR_WHITE ] { 16777215 }
+ Constant [ public int COLOR_YELLOW ] { 16776960 }
+ Constant [ public int PATTERN_NONE ] { 0 }
+ Constant [ public int PATTERN_SOLID ] { 1 }
+ Constant [ public int PATTERN_MEDIUM_GRAY ] { 2 }
+ Constant [ public int PATTERN_DARK_GRAY ] { 3 }
+ Constant [ public int PATTERN_LIGHT_GRAY ] { 4 }
+ Constant [ public int PATTERN_DARK_HORIZONTAL ] { 5 }
+ Constant [ public int PATTERN_DARK_VERTICAL ] { 6 }
+ Constant [ public int PATTERN_DARK_DOWN ] { 7 }
+ Constant [ public int PATTERN_DARK_UP ] { 8 }
+ Constant [ public int PATTERN_DARK_GRID ] { 9 }
+ Constant [ public int PATTERN_DARK_TRELLIS ] { 10 }
+ Constant [ public int PATTERN_LIGHT_HORIZONTAL ] { 11 }
+ Constant [ public int PATTERN_LIGHT_VERTICAL ] { 12 }
+ Constant [ public int PATTERN_LIGHT_DOWN ] { 13 }
+ Constant [ public int PATTERN_LIGHT_UP ] { 14 }
+ Constant [ public int PATTERN_LIGHT_GRID ] { 15 }
+ Constant [ public int PATTERN_LIGHT_TRELLIS ] { 16 }
+ Constant [ public int PATTERN_GRAY_125 ] { 17 }
+ Constant [ public int PATTERN_GRAY_0625 ] { 18 }
+ Constant [ public int BORDER_THIN ] { 1 }
+ Constant [ public int BORDER_MEDIUM ] { 2 }
+ Constant [ public int BORDER_DASHED ] { 3 }
+ Constant [ public int BORDER_DOTTED ] { 4 }
+ Constant [ public int BORDER_THICK ] { 5 }
+ Constant [ public int BORDER_DOUBLE ] { 6 }
+ Constant [ public int BORDER_HAIR ] { 7 }
+ Constant [ public int BORDER_MEDIUM_DASHED ] { 8 }
+ Constant [ public int BORDER_DASH_DOT ] { 9 }
+ Constant [ public int BORDER_MEDIUM_DASH_DOT ] { 10 }
+ Constant [ public int BORDER_DASH_DOT_DOT ] { 11 }
+ Constant [ public int BORDER_MEDIUM_DASH_DOT_DOT ] { 12 }
+ Constant [ public int BORDER_SLANT_DASH_DOT ] { 13 }
}
- Static properties [0] {
@@ -483,33 +500,33 @@ Extension [ <persistent> extension #174 xlswriter version 1.3.2 ] {
Class [ <internal:xlswriter> class Vtiful\Kernel\Chart ] {
- Constants [27] {
- Constant [ public integer CHART_BAR ] { 4 }
- Constant [ public integer CHART_BAR_STACKED ] { 5 }
- Constant [ public integer CHART_BAR_STACKED_PERCENT ] { 6 }
- Constant [ public integer CHART_AREA ] { 1 }
- Constant [ public integer CHART_AREA_STACKED ] { 2 }
- Constant [ public integer CHART_AREA_STACKED_PERCENT ] { 3 }
- Constant [ public integer CHART_LINE ] { 11 }
- Constant [ public integer CHART_COLUMN ] { 7 }
- Constant [ public integer CHART_COLUMN_STACKED ] { 8 }
- Constant [ public integer CHART_COLUMN_STACKED_PERCENT ] { 9 }
- Constant [ public integer CHART_DOUGHNUT ] { 10 }
- Constant [ public integer CHART_PIE ] { 12 }
- Constant [ public integer CHART_SCATTER ] { 13 }
- Constant [ public integer CHART_SCATTER_STRAIGHT ] { 14 }
- Constant [ public integer CHART_SCATTER_STRAIGHT_WITH_MARKERS ] { 15 }
- Constant [ public integer CHART_SCATTER_SMOOTH ] { 16 }
- Constant [ public integer CHART_SCATTER_SMOOTH_WITH_MARKERS ] { 17 }
- Constant [ public integer CHART_RADAR ] { 18 }
- Constant [ public integer CHART_RADAR_WITH_MARKERS ] { 19 }
- Constant [ public integer CHART_RADAR_FILLED ] { 20 }
- Constant [ public integer CHART_LEGEND_NONE ] { 0 }
- Constant [ public integer CHART_LEGEND_RIGHT ] { 1 }
- Constant [ public integer CHART_LEGEND_LEFT ] { 2 }
- Constant [ public integer CHART_LEGEND_TOP ] { 3 }
- Constant [ public integer CHART_LEGEND_BOTTOM ] { 4 }
- Constant [ public integer CHART_LEGEND_OVERLAY_RIGHT ] { 6 }
- Constant [ public integer CHART_LEGEND_OVERLAY_LEFT ] { 7 }
+ Constant [ public int CHART_BAR ] { 4 }
+ Constant [ public int CHART_BAR_STACKED ] { 5 }
+ Constant [ public int CHART_BAR_STACKED_PERCENT ] { 6 }
+ Constant [ public int CHART_AREA ] { 1 }
+ Constant [ public int CHART_AREA_STACKED ] { 2 }
+ Constant [ public int CHART_AREA_STACKED_PERCENT ] { 3 }
+ Constant [ public int CHART_LINE ] { 11 }
+ Constant [ public int CHART_COLUMN ] { 7 }
+ Constant [ public int CHART_COLUMN_STACKED ] { 8 }
+ Constant [ public int CHART_COLUMN_STACKED_PERCENT ] { 9 }
+ Constant [ public int CHART_DOUGHNUT ] { 10 }
+ Constant [ public int CHART_PIE ] { 12 }
+ Constant [ public int CHART_SCATTER ] { 13 }
+ Constant [ public int CHART_SCATTER_STRAIGHT ] { 14 }
+ Constant [ public int CHART_SCATTER_STRAIGHT_WITH_MARKERS ] { 15 }
+ Constant [ public int CHART_SCATTER_SMOOTH ] { 16 }
+ Constant [ public int CHART_SCATTER_SMOOTH_WITH_MARKERS ] { 17 }
+ Constant [ public int CHART_RADAR ] { 18 }
+ Constant [ public int CHART_RADAR_WITH_MARKERS ] { 19 }
+ Constant [ public int CHART_RADAR_FILLED ] { 20 }
+ Constant [ public int CHART_LEGEND_NONE ] { 0 }
+ Constant [ public int CHART_LEGEND_RIGHT ] { 1 }
+ Constant [ public int CHART_LEGEND_LEFT ] { 2 }
+ Constant [ public int CHART_LEGEND_TOP ] { 3 }
+ Constant [ public int CHART_LEGEND_BOTTOM ] { 4 }
+ Constant [ public int CHART_LEGEND_OVERLAY_RIGHT ] { 6 }
+ Constant [ public int CHART_LEGEND_OVERLAY_LEFT ] { 7 }
}
- Static properties [0] {
diff --git a/php-pecl-xlswriter.spec b/php-pecl-xlswriter.spec
index 9c657d8..8fd36ef 100644
--- a/php-pecl-xlswriter.spec
+++ b/php-pecl-xlswriter.spec
@@ -27,11 +27,11 @@
Summary: An efficient and fast xlsx file export extension
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 1.3.2
+Version: 1.3.3
Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD
-URL: http://pecl.php.net/package/%{pecl_name}
-Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
+URL: https://pecl.php.net/package/%{pecl_name}
+Source0: https://pecl.php.net/get/%{pecl_name}-%{version}.tgz
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel >= 7
@@ -250,6 +250,9 @@ cd ..
%changelog
+* Thu Dec 26 2019 Remi Collet <remi@remirepo.net> - 1.3.3-1
+- update to 1.3.3
+
* Wed Dec 18 2019 Remi Collet <remi@remirepo.net> - 1.3.2-2
- rebuild with libxlsxwriter 0.8.9