summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--71.patch41
-rw-r--r--REFLECTION5
-rw-r--r--php-pecl-xlswriter.spec10
3 files changed, 8 insertions, 48 deletions
diff --git a/71.patch b/71.patch
deleted file mode 100644
index 300754c..0000000
--- a/71.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-From 03e9a8aa2c88208c60511d239bf6f66f5d064723 Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Fri, 1 Jun 2018 06:45:22 +0200
-Subject: [PATCH 1/2] fix arginfo for Vtiful\Kernel\Excel::fileName() and
- Vtiful\Kernel\Excel::constMemory()
-
----
- kernel/excel.c | 8 ++++++--
- 1 file changed, 6 insertions(+), 2 deletions(-)
-
-diff --git a/kernel/excel.c b/kernel/excel.c
-index 25e120e..0fd05cb 100644
---- a/kernel/excel.c
-+++ b/kernel/excel.c
-@@ -61,11 +61,15 @@ ZEND_BEGIN_ARG_INFO_EX(xls_construct_arginfo, 0, 0, 1)
- ZEND_ARG_INFO(0, config)
- ZEND_END_ARG_INFO()
-
--ZEND_BEGIN_ARG_INFO_EX(xls_file_name_arginfo, 0, 0, 2)
-+ZEND_BEGIN_ARG_INFO_EX(xls_file_name_arginfo, 0, 0, 1)
- ZEND_ARG_INFO(0, file_name)
- ZEND_ARG_INFO(0, sheet_name)
- ZEND_END_ARG_INFO()
-
-+ZEND_BEGIN_ARG_INFO_EX(xls_const_memory_arginfo, 0, 0, 1)
-+ ZEND_ARG_INFO(0, file_name)
-+ZEND_END_ARG_INFO()
-+
- ZEND_BEGIN_ARG_INFO_EX(xls_file_add_sheet, 0, 0, 1)
- ZEND_ARG_INFO(0, sheet_name)
- ZEND_END_ARG_INFO()
-@@ -496,7 +500,7 @@ zend_function_entry xls_methods[] = {
- PHP_ME(vtiful_xls, __construct, xls_construct_arginfo, ZEND_ACC_PUBLIC|ZEND_ACC_CTOR)
- PHP_ME(vtiful_xls, fileName, xls_file_name_arginfo, ZEND_ACC_PUBLIC)
- PHP_ME(vtiful_xls, addSheet, xls_file_add_sheet, ZEND_ACC_PUBLIC)
-- PHP_ME(vtiful_xls, constMemory, xls_file_name_arginfo, ZEND_ACC_PUBLIC)
-+ PHP_ME(vtiful_xls, constMemory, xls_const_memory_arginfo, ZEND_ACC_PUBLIC)
- PHP_ME(vtiful_xls, header, xls_header_arginfo, ZEND_ACC_PUBLIC)
- PHP_ME(vtiful_xls, data, xls_data_arginfo, ZEND_ACC_PUBLIC)
- PHP_ME(vtiful_xls, output, NULL, ZEND_ACC_PUBLIC)
-
diff --git a/REFLECTION b/REFLECTION
index 2369480..3ccac6b 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #169 xlswriter version 1.2.0 ] {
+Extension [ <persistent> extension #169 xlswriter version 1.2.1 ] {
- Classes [3] {
Class [ <internal:xlswriter> class Vtiful\Kernel\Exception extends Exception implements Throwable ] {
@@ -99,8 +99,9 @@ Extension [ <persistent> extension #169 xlswriter version 1.2.0 ] {
Method [ <internal:xlswriter> public method constMemory ] {
- - Parameters [1] {
+ - Parameters [2] {
Parameter #0 [ <required> $file_name ]
+ Parameter #1 [ <optional> $sheet_name ]
}
}
diff --git a/php-pecl-xlswriter.spec b/php-pecl-xlswriter.spec
index 9fb584f..68916cd 100644
--- a/php-pecl-xlswriter.spec
+++ b/php-pecl-xlswriter.spec
@@ -29,14 +29,12 @@
Summary: An efficient and fast xlsx file export extension
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 1.2.0
+Version: 1.2.1
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD
URL: http://pecl.php.net/package/%{pecl_name}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
-Patch0: 71.patch
-
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel >= 7
BuildRequires: %{?scl_prefix}php-pear
@@ -100,8 +98,6 @@ sed -e 's/role="test"/role="src"/' \
-i package.xml
cd NTS
-%patch0 -p1
-
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_XLSWRITER_VERSION/{s/.* "//;s/".*$//;p}' php_xls_writer.h)
if test "x${extver}" != "x%{version}%{?prever:-%{prever}}"; then
@@ -241,6 +237,10 @@ cd ..
%changelog
+* Sun Jun 3 2018 Remi Collet <remi@remirepo.net> - 1.2.1-1
+- update to 1.2.1
+- drop patch merged upstream
+
* Fri Jun 1 2018 Remi Collet <remi@remirepo.net> - 1.2.0-1
- update to 1.2.0
- add patch to fix reflection from