summaryrefslogtreecommitdiffstats
path: root/php-pecl-xdebug3.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-10-15 14:15:58 +0200
committerRemi Collet <remi@remirepo.net>2020-10-15 14:15:58 +0200
commit6f8067e404ee2d6bc608902f33f4e8c5f018479f (patch)
treeea2653c927a72719130e6ad011214bcc75bbc4e3 /php-pecl-xdebug3.spec
parent661d409def5803c0d710fd2508136b6bbc111433 (diff)
cleanup
Diffstat (limited to 'php-pecl-xdebug3.spec')
-rw-r--r--php-pecl-xdebug3.spec22
1 files changed, 10 insertions, 12 deletions
diff --git a/php-pecl-xdebug3.spec b/php-pecl-xdebug3.spec
index e223c98..62d5ac9 100644
--- a/php-pecl-xdebug3.spec
+++ b/php-pecl-xdebug3.spec
@@ -1,7 +1,7 @@
-# remirepo spec file for php-pecl-xdebug
+# remirepo spec file for php-pecl-xdebug3
# with SCL compatibility, from:
#
-# Fedora spec file for php-pecl-xdebug
+# Fedora spec file for php-pecl-xdebug3
#
# Copyright (c) 2010-2020 Remi Collet
# Copyright (c) 2006-2009 Christopher Stone
@@ -12,6 +12,8 @@
# Please, preserve the changelog entries
#
+%bcond_without tests
+
# we don't want -z defs linker flag
%undefine _strict_symbol_defs_build
@@ -22,7 +24,8 @@
%global gh_commit e3158f5b7bd84b4e9a18eb170d512416557de803
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20201011
-%global with_tests 0%{!?_without_tests:1}
+
+# version/release
%global upstream_version 3.0.0
%global upstream_prever beta1
%global upstream_lower beta1
@@ -31,7 +34,7 @@
%global ini_name 15-%{pecl_name}.ini
Name: %{?scl_prefix}php-pecl-xdebug3
-Summary: PECL package for debugging PHP scripts
+Summary: Provides functions for function traces and profiling
Version: %{upstream_version}%{?upstream_lower:~%{upstream_lower}}
%if 0%{?gh_date:1}
Release: 1.%{gh_date}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
@@ -49,11 +52,8 @@ BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel > 7.2
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: %{?scl_prefix}php-simplexml
-BuildRequires: libedit-devel
BuildRequires: libtool
-%if %{with_tests}
BuildRequires: %{?scl_prefix}php-soap
-%endif
%if 0%{?rhel} == 6
BuildRequires: autoconf268
%endif
@@ -68,12 +68,12 @@ Provides: %{?scl_prefix}php-pecl(Xdebug) = %{version}
Provides: %{?scl_prefix}php-pecl(Xdebug)%{?_isa} = %{version}
%if 0%{?fedora} >= 35 || 0%{?rhel} >= 9 || "%{php_version}" > "8.0"
-Obsoletes: %{?scl_prefix}php-pecl-%{pecl_name} < 5
+Obsoletes: %{?scl_prefix}php-pecl-%{pecl_name} < 3
Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
%else
# A single version can be installed
-Conflicts: %{?scl_prefix}php-pecl-%{pecl_name} < 3
+Conflicts: %{?scl_prefix}php-pecl-%{pecl_name} < 3
%endif
%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
@@ -252,12 +252,10 @@ done
--modules | grep Xdebug
%endif
-%if %{with_tests}
+%if %{with tests}
cd NTS
: Upstream test suite NTS extension
-sed -e '/var_display_max_data/s/2048/3075/' -i tests/develop/error_collection-003.phpt
-
# bug00886 is marked as slow as it uses a lot of disk space
TEST_OPTS="-q -x --show-diff"