summaryrefslogtreecommitdiffstats
path: root/php-pecl-xdebug.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-xdebug.spec')
-rw-r--r--php-pecl-xdebug.spec34
1 files changed, 19 insertions, 15 deletions
diff --git a/php-pecl-xdebug.spec b/php-pecl-xdebug.spec
index 44c2e4c..bec8f6f 100644
--- a/php-pecl-xdebug.spec
+++ b/php-pecl-xdebug.spec
@@ -35,7 +35,7 @@ Version: 2.5.5
%if 0%{?gh_date:1}
Release: 0.5.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%else
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 3%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%endif
# The Xdebug License, version 1.01
@@ -45,6 +45,9 @@ Group: Development/Languages
URL: http://xdebug.org/
Source0: https://github.com/%{pecl_name}/%{pecl_name}/archive/%{gh_commit}/%{pecl_name}-%{version}%{?prever}-%{gh_short}.tar.gz
+Patch1: https://github.com/xdebug/xdebug/commit/db46ff6bc2b3401ac7f4c90b699b005ad678db44.patch
+Patch2: https://github.com/xdebug/xdebug/commit/6f90bb196268a5fc5e7b9c2fbb344972af7fdc5b.patch
+
BuildRequires: %{?scl_prefix}php-pear > 1.9.1
BuildRequires: %{?scl_prefix}php-devel > 5.5
BuildRequires: libedit-devel
@@ -133,6 +136,8 @@ mv NTS/package.xml .
%{?_licensedir:sed -e '/LICENSE/s/role="doc"/role="src"/' -i package.xml}
cd NTS
+%patch1 -p1 -b .upstream1
+%patch2 -p1 -b .upstream2
# Check extension version
ver=$(sed -n '/XDEBUG_VERSION/{s/.* "//;s/".*$//;p}' php_xdebug.h)
@@ -216,6 +221,14 @@ done
%check
+# Shared needed extensions
+modules=""
+for mod in simplexml; do
+ if [ -f %{php_extdir}/${mod}.so ]; then
+ modules="$modules -d extension=${mod}.so"
+ fi
+done
+
# only check if build extension can be loaded
%{_bindir}/php \
--no-php-ini \
@@ -231,22 +244,10 @@ done
%if %{with_tests}
cd NTS
-# ignore kwown failed tests
-#rm tests/bug00623.phpt
-#rm tests/bug00687.phpt
-#rm tests/bug00778.phpt
-#rm tests/bug00806.phpt
-#rm tests/bug00840.phpt
-#rm tests/bug00886.phpt
-#rm tests/bug00913.phpt
-#rm tests/bug01059.phpt
-#rm tests/bug01104.phpt
-#rm tests/dbgp-context-get.phpt
-#rm tests/dbgp-property-get-constants.phpt
-
: Upstream test suite NTS extension
+SKIP_SLOW_TESTS=1 \
TEST_PHP_EXECUTABLE=%{_bindir}/php \
-TEST_PHP_ARGS="-n -d extension=soap.so -d zend_extension=%{buildroot}%{php_extdir}/%{pecl_name}.so" \
+TEST_PHP_ARGS="-n $modules -d zend_extension=%{buildroot}%{php_extdir}/%{pecl_name}.so -d xdebug.auto_trace=0" \
NO_INTERACTION=1 \
REPORT_EXIT_STATUS=1 \
%{__php} -n run-tests.php --show-diff
@@ -291,6 +292,9 @@ fi
%changelog
+* Wed Oct 18 2017 Remi Collet <remi@remirepo.net> - 2.5.5-3
+- fix test suite
+
* Mon Oct 2 2017 Remi Collet <remi@remirepo.net> - 2.5.5-2
- F27 rebuild