summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--php-pecl-xdebug.spec13
1 files changed, 6 insertions, 7 deletions
diff --git a/php-pecl-xdebug.spec b/php-pecl-xdebug.spec
index cee7ad6..a3e632c 100644
--- a/php-pecl-xdebug.spec
+++ b/php-pecl-xdebug.spec
@@ -16,9 +16,9 @@
%global pecl_name xdebug
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
-%global gh_commit d82879d022cea73287b86e8b909ec75910f87fa5
+%global gh_commit 9da805ce2a7ec32ff6e7db1ca43cca64811753a5
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
-%global gh_date 20170601
+%global gh_date 20170925
%global with_tests 0%{?_with_tests:1}
#global prever rc1
@@ -29,7 +29,7 @@ Name: %{?scl_prefix}php-pecl-xdebug
Summary: PECL package for debugging PHP scripts
Version: 2.6.0
%if 0%{?gh_date:1}
-Release: 0.4.%{gh_date}.%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 0.5.%{gh_date}.%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%else
Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%endif
@@ -41,8 +41,6 @@ Group: Development/Languages
URL: http://xdebug.org/
Source0: https://github.com/%{pecl_name}/%{pecl_name}/archive/%{gh_commit}/%{pecl_name}-%{version}%{?prever}-%{gh_short}.tar.gz
-Patch0: 359.patch
-
BuildRequires: %{?scl_prefix}php-devel > 7
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: libedit-devel
@@ -129,8 +127,6 @@ mv NTS/package.xml .
%{?_licensedir:sed -e '/LICENSE/s/role="doc"/role="src"/' -i package.xml}
cd NTS
-%patch0 -p1 -b .pr359
-
# Check extension version
ver=$(sed -n '/XDEBUG_VERSION/{s/.* "//;s/".*$//;p}' php_xdebug.h)
if test "$ver" != "%{version}%{?prever}%{?gh_date:-dev}"; then
@@ -288,6 +284,9 @@ fi
%changelog
+* Mon Oct 2 2017 Remi Collet <remi@remirepo.net> - 2.6.0-0.5.20170925.9da805c
+rebuild
+
* Tue Jul 18 2017 Remi Collet <remi@remirepo.net> - 2.6.0-0.4.20170601.d82879d
- rebuild for PHP 7.2.0beta1 new API