summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--2d9cebd20b8e2eeac8c0116876b5ba76bd4d24ee.patch25
-rw-r--r--REFLECTION2
-rw-r--r--php-pecl-xdebug.spec12
3 files changed, 7 insertions, 32 deletions
diff --git a/2d9cebd20b8e2eeac8c0116876b5ba76bd4d24ee.patch b/2d9cebd20b8e2eeac8c0116876b5ba76bd4d24ee.patch
deleted file mode 100644
index 13fe7ad..0000000
--- a/2d9cebd20b8e2eeac8c0116876b5ba76bd4d24ee.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From 2d9cebd20b8e2eeac8c0116876b5ba76bd4d24ee Mon Sep 17 00:00:00 2001
-From: "Frode E. Moe" <fluff.github@git.noloop.net>
-Date: Thu, 20 Apr 2017 17:34:10 -0400
-Subject: [PATCH] Fix set_time_limit hanging on PHP 5.6 when pcntl_exec does
- not exist
-
----
- xdebug.c | 4 +++-
- 1 file changed, 3 insertions(+), 1 deletion(-)
-
-diff --git a/xdebug.c b/xdebug.c
-index 54932db..c4e8768 100644
---- a/xdebug.c
-+++ b/xdebug.c
-@@ -1292,7 +1292,9 @@ PHP_RINIT_FUNCTION(xdebug)
- #if PHP_VERSION_ID >= 70000
- orig = zend_hash_str_find_ptr(EG(function_table), "pcntl_exec", sizeof("pcntl_exec") - 1);
- #else
-- zend_hash_find(EG(function_table), "pcntl_exec", sizeof("pcntl_exec"), (void **)&orig);
-+ if (zend_hash_find(EG(function_table), "pcntl_exec", sizeof("pcntl_exec"), (void **)&orig) == FAILURE) {
-+ orig = NULL;
-+ }
- #endif
- if (orig) {
- XG(orig_pcntl_exec_func) = orig->internal_function.handler;
diff --git a/REFLECTION b/REFLECTION
index 360661f..54d399b 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #178 xdebug version 2.5.3 ] {
+Extension [ <persistent> extension #180 xdebug version 2.5.4 ] {
- INI {
Entry [ xdebug.auto_trace <ALL> ]
diff --git a/php-pecl-xdebug.spec b/php-pecl-xdebug.spec
index a4f263e..5abba77 100644
--- a/php-pecl-xdebug.spec
+++ b/php-pecl-xdebug.spec
@@ -16,7 +16,7 @@
%global pecl_name xdebug
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
-%global gh_commit ca89d2486378852da9a20effdcc5b6d0f3f751e0
+%global gh_commit 48fc95c76a246d3fdc2c5410ee08bdce5f52f228
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20161004
%global with_tests 0%{?_with_tests:1}
@@ -31,11 +31,11 @@
Name: %{?scl_prefix}php-pecl-xdebug
Summary: PECL package for debugging PHP scripts
-Version: 2.5.3
+Version: 2.5.4
%if 0%{?gh_date:1}
Release: 0.5.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%else
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%endif
# The Xdebug License, version 1.01
@@ -45,8 +45,6 @@ Group: Development/Languages
URL: http://xdebug.org/
Source0: https://github.com/%{pecl_name}/%{pecl_name}/archive/%{gh_commit}/%{pecl_name}-%{version}%{?prever}-%{gh_short}.tar.gz
-Patch0: 2d9cebd20b8e2eeac8c0116876b5ba76bd4d24ee.patch
-
BuildRequires: %{?scl_prefix}php-pear > 1.9.1
BuildRequires: %{?scl_prefix}php-devel > 5.5
BuildRequires: libedit-devel
@@ -135,7 +133,6 @@ mv NTS/package.xml .
%{?_licensedir:sed -e '/LICENSE/s/role="doc"/role="src"/' -i package.xml}
cd NTS
-%patch0 -p1 -b .upstream
# Check extension version
ver=$(sed -n '/XDEBUG_VERSION/{s/.* "//;s/".*$//;p}' php_xdebug.h)
@@ -294,6 +291,9 @@ fi
%changelog
+* Mon May 15 2017 Remi Collet <remi@remirepo.net> - 2.5.4-1
+- update to 2.5.4
+
* Mon May 1 2017 Remi Collet <remi@remirepo.net> - 2.5.3-2
- add upstream patch for https://bugs.xdebug.org/view.php?id=1424