summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION2
-rw-r--r--php-pecl-xdebug.spec30
3 files changed, 27 insertions, 7 deletions
diff --git a/PHPINFO b/PHPINFO
index 6a4bb61..facb1ef 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,7 +2,7 @@
xdebug
xdebug support => enabled
-Version => 2.9.5
+Version => 2.9.8
Support Xdebug on Patreon, GitHub, or as a business: https://xdebug.org/support
Debugger => enabled
diff --git a/REFLECTION b/REFLECTION
index 0247336..54a00b8 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #113 xdebug version 2.9.5 ] {
+Extension [ <persistent> extension #117 xdebug version 2.9.8 ] {
- INI {
Entry [ xdebug.coverage_enable <SYSTEM> ]
diff --git a/php-pecl-xdebug.spec b/php-pecl-xdebug.spec
index 5548c27..f611c41 100644
--- a/php-pecl-xdebug.spec
+++ b/php-pecl-xdebug.spec
@@ -19,11 +19,11 @@
%global pecl_name xdebug
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
-%global gh_commit 1f11f5a389cfcebf8e1ca64e092f75be9224abea
+%global gh_commit 3e09864af111d63b7eb486d88bfc6eb7d6429b85
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20190614
%global with_tests 0%{!?_without_tests:1}
-%global upstream_version 2.9.5
+%global upstream_version 2.9.8
#global upstream_prever beta2
#global upstream_lower beta2
@@ -31,7 +31,7 @@
%global ini_name 15-%{pecl_name}.ini
Name: %{?scl_prefix}php-pecl-xdebug
-Summary: PECL package for debugging PHP scripts
+Summary: Provides functions for function traces and profiling
Version: %{upstream_version}%{?upstream_lower:~%{upstream_lower}}
%if 0%{?gh_date:1}
Release: 1%{gh_date}.%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
@@ -54,6 +54,9 @@ BuildRequires: libtool
%if %{with_tests}
BuildRequires: %{?scl_prefix}php-soap
%endif
+%if 0%{?rhel} == 6
+BuildRequires: autoconf268
+%endif
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
@@ -64,7 +67,7 @@ Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
Provides: %{?scl_prefix}php-pecl(Xdebug) = %{version}
Provides: %{?scl_prefix}php-pecl(Xdebug)%{?_isa} = %{version}
-%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
+%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
# Other third party repo stuff
Obsoletes: php53-pecl-%{pecl_name} <= %{version}
Obsoletes: php53u-pecl-%{pecl_name} <= %{version}
@@ -88,7 +91,9 @@ Obsoletes: php73w-pecl-%{pecl_name} <= %{version}
%endif
%if "%{php_version}" > "7.4"
Obsoletes: php74-pecl-%{pecl_name} <= %{version}
-Obsoletes: php74w-pecl-%{pecl_name} <= %{version}
+%endif
+%if "%{php_version}" > "8.0"
+Obsoletes: php80-pecl-%{pecl_name} <= %{version}
%endif
%endif
@@ -167,6 +172,9 @@ sed -e '1d' NTS/%{pecl_name}.ini >>%{ini_name}
%build
+%if 0%{?rhel} == 6
+export PHP_AUTOCONF=autoconf268;export PHP_AUTOHEADER=autoheader268
+%endif
%{?dtsenable}
cd NTS
@@ -299,6 +307,18 @@ fi
%changelog
+* Mon Sep 28 2020 Remi Collet <remi@remirepo.net> - 2.9.8-1
+- update to 2.9.8
+
+* Wed Sep 16 2020 Remi Collet <remi@remirepo.net> - 2.9.7-1
+- update to 2.9.7
+
+* Sat May 30 2020 Remi Collet <remi@remirepo.net> - 2.9.6-1
+- update to 2.9.6
+
+* Tue May 5 2020 Remi Collet <remi@remirepo.net> - 2.9.5-2
+- rebuild for https://github.com/remicollet/remirepo/issues/146
+
* Sun Apr 26 2020 Remi Collet <remi@remirepo.net> - 2.9.5-1
- update to 2.9.5