summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--REFLECTION37
-rw-r--r--php-pecl-xdebug.spec11
2 files changed, 43 insertions, 5 deletions
diff --git a/REFLECTION b/REFLECTION
index 8955ad0..78b2c12 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #191 xdebug version 2.6.0beta1 ] {
+Extension [ <persistent> extension #191 xdebug version 2.6.0RC2 ] {
- INI {
Entry [ xdebug.auto_trace <ALL> ]
@@ -187,6 +187,15 @@ Extension [ <persistent> extension #191 xdebug version 2.6.0beta1 ] {
Entry [ xdebug.scream <ALL> ]
Current = '0'
}
+ Entry [ xdebug.gc_stats_enable <PERDIR,SYSTEM> ]
+ Current = '0'
+ }
+ Entry [ xdebug.gc_stats_output_dir <PERDIR,SYSTEM> ]
+ Current = '/tmp'
+ }
+ Entry [ xdebug.gc_stats_output_name <PERDIR,SYSTEM> ]
+ Current = 'gcstats.%p'
+ }
}
- Constants [15] {
@@ -335,6 +344,32 @@ Extension [ <persistent> extension #191 xdebug version 2.6.0beta1 ] {
- Parameters [0] {
}
}
+ Function [ <internal:xdebug> function xdebug_start_gcstats ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> $fname ]
+ }
+ }
+ Function [ <internal:xdebug> function xdebug_stop_gcstats ] {
+
+ - Parameters [0] {
+ }
+ }
+ Function [ <internal:xdebug> function xdebug_get_gcstats_filename ] {
+
+ - Parameters [0] {
+ }
+ }
+ Function [ <internal:xdebug> function xdebug_get_gc_run_count ] {
+
+ - Parameters [0] {
+ }
+ }
+ Function [ <internal:xdebug> function xdebug_get_gc_total_collected_roots ] {
+
+ - Parameters [0] {
+ }
+ }
Function [ <internal:xdebug> function xdebug_memory_usage ] {
- Parameters [0] {
diff --git a/php-pecl-xdebug.spec b/php-pecl-xdebug.spec
index 292d11b..fc296c0 100644
--- a/php-pecl-xdebug.spec
+++ b/php-pecl-xdebug.spec
@@ -3,7 +3,7 @@
#
# Fedora spec file for php-pecl-xdebug
#
-# Copyright (c) 2010-2017 Remi Collet
+# Copyright (c) 2010-2018 Remi Collet
# Copyright (c) 2006-2009 Christopher Stone
#
# License: MIT
@@ -16,11 +16,11 @@
%global pecl_name xdebug
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
-%global gh_commit f7db5b771a63d338e4af0c5b123d4084d2fd49cd
+%global gh_commit e53e2073568dc26a74b73479bff4e3fd88fe3ab2
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20171202
%global with_tests 0%{!?_without_tests:1}
-%global prever beta1
+%global prever RC2
# XDebug should be loaded after opcache
%global ini_name 15-%{pecl_name}.ini
@@ -29,7 +29,7 @@ Name: %{?scl_prefix}php-pecl-xdebug
Summary: PECL package for debugging PHP scripts
Version: 2.6.0
%if 0%{?prever:1}
-Release: 0.10.%{prever}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 0.11.%{prever}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%else
%if 0%{?gh_date:1}
Release: 0.8.%{gh_date}.%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
@@ -286,6 +286,9 @@ fi
%changelog
+* Tue Jan 23 2018 Remi Collet <remi@remirepo.net> - 2.6.0-0.11.RC2
+- update to 2.6.0RC2
+
* Fri Dec 29 2017 Remi Collet <remi@remirepo.net> - 2.6.0-0.10.beta1
- update to 2.6.0beta1