summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--0001-skip-test-if-localhost-doesn-t-resolve-as-IPv6.patch24
-rw-r--r--php-pecl-xdebug.spec11
2 files changed, 32 insertions, 3 deletions
diff --git a/0001-skip-test-if-localhost-doesn-t-resolve-as-IPv6.patch b/0001-skip-test-if-localhost-doesn-t-resolve-as-IPv6.patch
new file mode 100644
index 0000000..66f11b8
--- /dev/null
+++ b/0001-skip-test-if-localhost-doesn-t-resolve-as-IPv6.patch
@@ -0,0 +1,24 @@
+From 610c661364a443978729abbfd8fd62f3a36d22c7 Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@remirepo.net>
+Date: Tue, 3 Apr 2018 12:45:17 +0200
+Subject: [PATCH] skip test if localhost doesn't resolve as IPv6
+
+---
+ tests/bug00998-ipv6_localhost.phpt | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/tests/bug00998-ipv6_localhost.phpt b/tests/bug00998-ipv6_localhost.phpt
+index fe471f7a..b6b2b51f 100644
+--- a/tests/bug00998-ipv6_localhost.phpt
++++ b/tests/bug00998-ipv6_localhost.phpt
+@@ -6,6 +6,7 @@ if (getenv("SKIP_IPV6_TESTS")) { exit("skip Excluding IPv6 tests"); }
+ if (getenv("SKIP_DBGP_TESTS")) { exit("skip Excluding DBGp tests"); }
+ require 'dbgp/dbgpclient.php';
+ if (!DebugClientIPv6::isSupported($errno, $errstr)) echo "skip IPv6 support is not configured. Error: $errstr, errno: $errno\n";
++if (strstr(exec("getent ahostsv6 localhost"), '::1')===false) echo "skip localhost doesn't resolve as IPv6";
+ ?>
+ --FILE--
+ <?php
+--
+2.14.3
+
diff --git a/php-pecl-xdebug.spec b/php-pecl-xdebug.spec
index 718ae26..584633b 100644
--- a/php-pecl-xdebug.spec
+++ b/php-pecl-xdebug.spec
@@ -35,7 +35,7 @@ Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
%if 0%{?gh_date:1}
Release: 0.8.%{gh_date}.%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%else
-Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%endif
# The Xdebug License, version 1.01
@@ -44,6 +44,8 @@ License: BSD
URL: http://xdebug.org/
Source0: https://github.com/%{pecl_name}/%{pecl_name}/archive/%{gh_commit}/%{pecl_name}-%{upstream_version}%{?upstream_prever}-%{gh_short}.tar.gz
+Patch0: 0001-skip-test-if-localhost-doesn-t-resolve-as-IPv6.patch
+
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel > 7
BuildRequires: %{?scl_prefix}php-pear
@@ -132,6 +134,8 @@ mv NTS/package.xml .
%{?_licensedir:sed -e '/LICENSE/s/role="doc"/role="src"/' -i package.xml}
cd NTS
+%patch0 -p1
+
# Check extension version
ver=$(sed -n '/XDEBUG_VERSION/{s/.* "//;s/".*$//;p}' php_xdebug.h)
if test "$ver" != "%{upstream_version}%{?upstream_prever}%{?gh_date:-dev}"; then
@@ -237,8 +241,6 @@ done
%if %{with_tests}
cd NTS
-# TODO Need investigation
-rm tests/bug00998-ipv6_localhost.phpt
: Upstream test suite NTS extension
# bug00886 is marked as slow as it uses a lot of disk space
@@ -289,6 +291,9 @@ fi
%changelog
+* Tue Apr 3 2018 Remi Collet <remi@remirepo.net> - 2.7.0~alpha1-2
+- test build for https://github.com/xdebug/xdebug/pull/419
+
* Mon Apr 2 2018 Remi Collet <remi@remirepo.net> - 2.7.0~alpha1-1
- update to 2.7.0alpha1