summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--php-pecl-xdebug-php7.spec9
-rw-r--r--xdebug-upstream.patch28
2 files changed, 36 insertions, 1 deletions
diff --git a/php-pecl-xdebug-php7.spec b/php-pecl-xdebug-php7.spec
index 8b7b115..a51a159 100644
--- a/php-pecl-xdebug-php7.spec
+++ b/php-pecl-xdebug-php7.spec
@@ -34,13 +34,15 @@
Name: %{?scl_prefix}php-pecl-xdebug
Summary: PECL package for debugging PHP scripts
Version: 2.4.0
-Release: 0.1.%{prever}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 0.2.%{prever}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: https://github.com/%{pecl_name}/%{pecl_name}/archive/%{gh_commit}/%{pecl_name}-%{version}%{?prever}-%{gh_short}.tar.gz
# https://github.com/xdebug/xdebug/pull/217
Patch1: 217.patch
# https://github.com/xdebug/xdebug/pull/221
Patch2: 221.patch
+# Upstream patches
+Patch3: %{pecl_name}-upstream.patch
# The Xdebug License, version 1.01
# (Based on "The PHP License", version 3.0)
@@ -122,6 +124,7 @@ mv NTS/package.xml .
cd NTS
%patch1 -p1 -b .pr217
%patch2 -p1 -b .pr221
+%patch3 -p1 -b .upstream
# Check extension version
ver=$(sed -n '/XDEBUG_VERSION/{s/.* "//;s/".*$//;p}' php_xdebug.h)
@@ -294,6 +297,10 @@ rm -rf %{buildroot}
%changelog
+* Mon Nov 9 2015 Remi Collet <remi@fedoraproject.org> - 2.4.0-0.2.beta1
+- add 1 upstream patch (segfault in code coverage)
+ http://bugs.xdebug.org/view.php?id=1195
+
* Thu Nov 5 2015 Remi Collet <remi@fedoraproject.org> - 2.4.0-0.1.beta1
- update to 2.4.0beta1
diff --git a/xdebug-upstream.patch b/xdebug-upstream.patch
new file mode 100644
index 0000000..c0d73fb
--- /dev/null
+++ b/xdebug-upstream.patch
@@ -0,0 +1,28 @@
+From ac8557ff69d2961e91a9212a81ef5eb535beda5f Mon Sep 17 00:00:00 2001
+From: Derick Rethans <github@derickrethans.nl>
+Date: Sun, 8 Nov 2015 20:35:36 -0500
+Subject: [PATCH] Fixed issue #1195: Segfault with code coverage and foreach
+
+---
+ tests/bug01195-php5.phpt | 37 +++++++++++++++++++++++++++++++++++++
+ tests/bug01195-php7.phpt | 38 ++++++++++++++++++++++++++++++++++++++
+ tests/bug01195.inc | 12 ++++++++++++
+ xdebug_code_coverage.c | 2 +-
+ 4 files changed, 88 insertions(+), 1 deletion(-)
+ create mode 100644 tests/bug01195-php5.phpt
+ create mode 100644 tests/bug01195-php7.phpt
+ create mode 100644 tests/bug01195.inc
+
+diff --git a/xdebug_code_coverage.c b/xdebug_code_coverage.c
+index 6c52f81..85a9752 100644
+--- a/xdebug_code_coverage.c
++++ b/xdebug_code_coverage.c
+@@ -615,7 +615,7 @@ static int xdebug_find_jump(zend_op_array *opa, unsigned int position, long *jmp
+ #endif
+ *jmp1 = position + 1;
+ #if PHP_VERSION_ID >= 70000
+- *jmp2 = XDEBUG_ZNODE_JMP_LINE(opcode.op2, position, base_address) * sizeof(zend_op);
++ *jmp2 = XDEBUG_ZNODE_JMP_LINE(opcode.op2, position, base_address);
+ #else
+ *jmp2 = XDEBUG_ZNODE_ELEM(opcode.op2, opline_num);
+ #endif